System compatibility


New Member
Apr 27, 2024
Reaction score
Hey, I recently was trying to get into linux, so I was attempting to install it on a old notebook.
I installed arch 4 times using different methods, always got the sabe wifi error, I plugged a cabble and was trying to fix it but a bunch of commands show as not found. I installed debian today to try it and same thing happened. The wifi works during the instalation (I used iwctl on a couple arch instalations) and it seems to be connected (I checked on debian and at /etc/network/interfaces.d shows the connected wifi(I think maybe this lines help in any way "allow-hotplug wpl6s0" next line "iface wpl6s0 inet dhcp").
The notebook is an Acer Aspire 7720-6619, intel centrino, core 2 duo T5750 (
It's my first install so I'm not yet familliarized with the command line, nor with linux

always got the sabe wifi error
welcome to the forums!
Is there output of screenshot of the error?

After system is installed and you boot into it from hard drive (or SSD) you need to delete the connection entry from
/etc/network/interfaces.d and then configure network connection in desktop environment UI, usually NetworkManager.

If you need help with that or not sure how to let us know.
so you have a 2008 machine, Depending on which country it was originaly supplied to,it came with 2 or 4 Gb of ram, unless it has its max of 4 gb, you will need to choose a distribution for minimal resources, some distros that should run [albeit a bit slow] on that machine are, Mint -LMDE, Linux-Lite, Peppermint, MX-linux, Bodhi-linux, Lubuntu, [there are others]

There is a slim possibility it may have a 64 bit CPU slotted into a 32 bit motherboard in which case it will only install a 32 bit distribution, but by 2008 this practice had all but died out [I have an Acer ZG5 from 2008 and that only has a 32 bit motherboard]

use my how do I install guide [link below] to make sure you have not missed a step when installing,

My own laptop [from 2010 wth the intel T series CPU and 4gb, happily runs Mint-LMDE, Parrot, Debian stable [among other distributions]

Why Linux fails to load/install direct to HDD, common reasons [those in italics do not apply to your machine]
1] Corrupt download [check SHA sum]
2] bad burn to installation medium [try again] [if you used Rufus then try Balena Etcher]
3] Wind 8.2 and higher quick start/fast boot or secure boot not disabled [doesn't normally apply to older versions]
4] defective pen-drive/DVD
5] hardware fault,
5A] If old style HDD run integrity check
5B]if SATA SSD check for hidden partition at the beginning of drive [this will stop Grub from loading] and delete it before re-installing Linux
If M2.NVMe check, your system is NVMe compatible [not all older kit is]
Last edited:
I tried the Mint-LMDE, while downloading seems to be going ok, after restart and removing the bootable I was getting an error

I think maybe the hd has a problem or something, because the system seems to work fine when at the bootable(I'm using a external hd as a bootable, I know it works fine cause I normally format my windows pc with it). Maybe I should try to install the system on the external hd for testing it. Do you know how can I do it and if it's an viable option to test it out?

I'm running ´´´sudo badblocks -v /dev/sda -s´´´ , I will annex a photo of the results below.

It was taking too long to scan and it already found some errors so I stopped the process. Was running for 1:30 hours and less than 40%


  • IMG_20240427_150215_589.jpg
    3.3 MB · Views: 51
  • IMG_20240427_150226_386.jpg
    3.6 MB · Views: 48
  • IMG_20240427_155511_284.jpg
    2.8 MB · Views: 48
  • IMG_20240427_165031_670.jpg
    2.1 MB · Views: 53
looks like its on the way out..

also looks like you may have a broadcom wi-fi, you will need another form of internet connection to download the broadcom B43 fwcutter [this will install the correct BCM driver for the broadcom wi-fi
Do you know how can I do it and if it's an viable option to test it out?

when you get to the partitioning part of the installation, just make sure you choose the correct hard-drive
While I was installing I was connected to the internet cable, I also checked the hard drive it was installing into and the only option on the installer was the notebook's hard drive.
What do you mean by "looks like its on the way out.."? English is not my first language..

Can I get the broadcom B43 fwcutter after the installation? Or I need to do something during the installation?
"looks like its on the way out..
Sorry, too many bad sectors, looks like it won't last much longer
you can install the B43 drivers from the mint software manage after installation of the distribution
I think I'll try to install the os on the external hd and use it as boot on notebook to see if it the other components are working well. What do you think?
Also, will I need other usb to install linux on the external hd? or can I work around it?
I keep 2 usb flash drives around with Mint or some other Linux distro as they can become handy.
Last edited:
I managed to install arch following a tutorial, I tried mint but I was getting an error downloading it on the legacy bios.

The instalation worked when I tested it on the "boot existing os" on the iso file and change the disk to HD1. But when I restart the notebook without the external hd and selected the boot option as the notebook's hd, I got an error(the same as the one at a picture above).

I dont think I could explain it properly so I recorded a video...( 3AchDF3ZUd8)

ST95... is the external hd, I put it on last on the boot priority queue you can see none of the above work

Obs: I changed the notebook's hard drive, the new one works


  • IMG_20240427_165031_670.jpg
    2.1 MB · Views: 27
Last edited:
You made your video on YouTube so that it can't be played back here on this site...
I just edited it above, just delete the space after the "/". I thought you could play it as it was

Staff online

Members online