Linux mint21. Show all available kernels in grub at boot

OP
Condobloke

Condobloke

Well-Known Member
Joined
Apr 30, 2017
Messages
5,588
Reaction score
4,673
Credits
33,998
I do have a lingering question.....where in the hell is grub ???!!

Not in its usual spot. (/etc/default/grub )

and....when I shut down the screen shows :

wow.jpg



Never seen thta before !

Just a rough stab in the dark....anything to do with os prober?....it was mentioned in post#71....

Warning: os-prober will be executed to detect other bootable partitions.
Its output will be used to detect bootable binaries on them and create new boot entries.

save the pic and expand it and the writing is readable.

It is accompanied by a ton of gobblededock
 


OP
Condobloke

Condobloke

Well-Known Member
Joined
Apr 30, 2017
Messages
5,588
Reaction score
4,673
Credits
33,998
If i could find an editable version of grub I would insert the :: GRUB_DISABLE_OS_PROBER=false
 
OP
Condobloke

Condobloke

Well-Known Member
Joined
Apr 30, 2017
Messages
5,588
Reaction score
4,673
Credits
33,998
better pic

1665800737843.jpeg
 

wizardfromoz

Administrator
Staff member
Gold Supporter
Joined
Apr 30, 2017
Messages
8,126
Reaction score
7,001
Credits
31,317
That looks a lot like a typical shutdown screen for when you have

noquiet nosplash

in your /etc/default/grub

before it gets to "powering down".

I am not going to rub you for good luck.
 
OP
Condobloke

Condobloke

Well-Known Member
Joined
Apr 30, 2017
Messages
5,588
Reaction score
4,673
Credits
33,998
but....where is /etc/default/grub ...??

1665818981808.png
 
OP
Condobloke

Condobloke

Well-Known Member
Joined
Apr 30, 2017
Messages
5,588
Reaction score
4,673
Credits
33,998
At least I found GRUB_DISABLE_OS_PROBER=false

It is in /etc/default/grub.d

All good. Sorta.
 
OP
Condobloke

Condobloke

Well-Known Member
Joined
Apr 30, 2017
Messages
5,588
Reaction score
4,673
Credits
33,998
but wait !....there's more ~!!!

I wanted grub back.....
SO
Wrote this into terminal


GRUB_TIMEOUT_STYLE=menu


that established a file in etc/default called grub.save in this i wrote acpi=off


Then in terminal I wrote sudo nano /etc/default/grub


Then i wrote in Terminal : GRUB_CMDLINE_LINUX_DEFAULT="quiet splash loglevel=3"


saved it (ctrl+x) Y


sudo update-grub and then rebooted



splash of acpi errors is gone....this was occuring at boot and also at shut down. I just didn't want to see it !


Now I have grub in /etc/default ....(and grub.save has been deleted by me....with the acpi=off in there, copied and pasted into grub)

That looks and feels better.

Any other suggestions??.....don't rush me.... ;)
 

KGIII

Super Moderator
Staff member
Gold Supporter
Joined
Jul 23, 2020
Messages
8,108
Reaction score
6,959
Credits
65,830
OP
Condobloke

Condobloke

Well-Known Member
Joined
Apr 30, 2017
Messages
5,588
Reaction score
4,673
Credits
33,998
I am aware. I have encountered 'weirdness' in many forms before today. (I never use sleep or hibernation)

I will be vigilant. I promise not to be drunk
 
Last edited:

wizardfromoz

Administrator
Staff member
Gold Supporter
Joined
Apr 30, 2017
Messages
8,126
Reaction score
7,001
Credits
31,317
I promise not to be drunk

That rules me out 9.76% of the time.

I always use "noquiet nosplash" so that it eliminates the graphics and just spools off what is loading - it gives me a headstart on startup errors.

Wiz
 
OP
Condobloke

Condobloke

Well-Known Member
Joined
Apr 30, 2017
Messages
5,588
Reaction score
4,673
Credits
33,998
Done and dusted....my /etc/default/grub now looks like....

1665992877808.png


I have no idea where the rest of it is.
 
OP
Condobloke

Condobloke

Well-Known Member
Joined
Apr 30, 2017
Messages
5,588
Reaction score
4,673
Credits
33,998
Even better......a new kernel became available this morning.....5.15.0-52

i installed it...rebooted as requested.

The result....Perfect

5.15.0-52 went straight to the top of the list of kernels available in my shiny bright blue grub page and was instantly available.

I have a Timeshift snapshot in place just in case something goes south, but so far I see no need to change that arrangement.
 

Brickwizard

Well-Known Member
Joined
Apr 28, 2021
Messages
3,491
Reaction score
2,317
Credits
25,981
As I keep saying, the best way to learn Linux, is to break it and have to fix it
 
OP
Condobloke

Condobloke

Well-Known Member
Joined
Apr 30, 2017
Messages
5,588
Reaction score
4,673
Credits
33,998
I note that if another kernel is selected at the grub screen (advanced options etc) it only stays in play for that one session.

If I wish to continue using that other kernel at each and every shutdown/reboot etc is there a way to make that happen?

There are only two kernels...total.

The third 'automagically' disappeared.....the setting to do this was not enabled.
 
Last edited:

Brickwizard

Well-Known Member
Joined
Apr 28, 2021
Messages
3,491
Reaction score
2,317
Credits
25,981
morning Brian

here you go
 
OP
Condobloke

Condobloke

Well-Known Member
Joined
Apr 30, 2017
Messages
5,588
Reaction score
4,673
Credits
33,998
Evening Brian,

Thank you for that

In a further case of weirdness, I need to insert the two lines (GRUB_DEFAULT=saved GRUB_SAVEDEFAULT=true) into etc/default/grub.d/50_linuxmint.cfg ....for it to work
.....but work it does !

Have a good day. I am off to snoozy land
 
OP
Condobloke

Condobloke

Well-Known Member
Joined
Apr 30, 2017
Messages
5,588
Reaction score
4,673
Credits
33,998
Still working the following day...all good.

I prefer the earlier kernel.
 

wizardfromoz

Administrator
Staff member
Gold Supporter
Joined
Apr 30, 2017
Messages
8,126
Reaction score
7,001
Credits
31,317
I am just playing catchup on this saga of Icelandic proportions LOL.

Always tricky with dealing with two Brians in the same Thread.

Brian @Brickwizard - Abhishek Prakash, although he has a good website and writes a lot of good articles and tips, is obviously not a multi-booter of note, or else he would know that Grub Customizer is not worth a pinch of salt under many circumstances.

Written by Daniel Richter in 2007, its shelf life should have been no more than 5 years. When I used it in 2014-2015 it created havoc, and Brian @Condobloke has more recent problems with it.

I mean no offence either to your good self nor to Daniel, it is just a fact I can prove elsewhere.

Brian @Condobloke

There is one option I can think of easily, and it just involves the following, as you have a Grub Menu ready.

  1. Add or amend the line to your /etc/default/grub to say
  2. Code:
    GRUB_DISABLE_SUBMENU=y
    - if y does not work, try true or "true", they have been mucking around lately with the old conventions.
  3. Save the altered file and run update-grub and reboot
  4. Once you reboot, you should now have the kernel choices on the front page of the grub menu.
  5. Count the line entries from the top, with the first as 0 (zero), so if the kernel you like is 4th down it will be 3
  6. Launch your distro and edit /etc/default /grub again and change the line
  7. Code:
    GRUB_DEFAULT=0
    
    #to eg
    
    GRUB_DEFAULT=3
  8. Save the altered file, run update-grub and reboot

The end result is that you should boot into your preferred kernel. To be sure that happens every time, you should have, at the bottom of /etc/default/grub , the line

Code:
GRUB_SAVEDEFAULT=true

Wiz
 
OP
Condobloke

Condobloke

Well-Known Member
Joined
Apr 30, 2017
Messages
5,588
Reaction score
4,673
Credits
33,998
Thanks Chris.

two screenshots......one of my etc/default/grub.......and the second of etc/default/50_linuxmint.cfg

2022-10-25_06-34.png

2022-10-25_06-33.png


Bit of an "unusual" set up....but it works.

The steps you provided above worked beautifully.

Now, when a new kernel arrives, I will test it out to see how it performs.....and then if I deem it worth locking in place....I will simply alter the number GRUB-DEFAULT=2....to whatever the new number is.....and all will be cool.
 

bob466

Well-Known Member
Joined
Oct 22, 2020
Messages
764
Reaction score
542
Credits
5,658
morning Brian

here you go

The old "Roll back the Kernel" trick...that's something I haven't done for a long time. Had to check my notes as I forgot.
m1213.gif
 
$100 Digital Ocean Credit
Get a free VM to test out Linux!

Linux.org Hosting Donations
Consider making a donation

Staff online

Members online


Top