Linux mint21. Show all available kernels in grub at boot

Condobloke

Well-Known Member
Joined
Apr 30, 2017
Messages
8,350
Reaction score
6,780
Credits
55,727
Linux Mint 21 (Cinnamon)

I have 3 kernels installed.

((I will never use grub-customizer again in order to select which one to run.))
((Grub-customizer spells Trouble.))

At boot, just ONE of those kernels appears

How to get all three to appear ?

(is it possible I am having a dumb moment?....more than possible!)
 


Show us a copy of your

/etc/default/grub

Brian, I likely know an answer.

Chris
 
# If you change this file, run 'update-grub' afterwards to update
# /boot/grub/grub.cfg.
# For full documentation of the options in this file, see:
# info -f grub -n 'Simple configuration'

GRUB_DEFAULT=4
GRUB_TIMEOUT_STYLE=menu
GRUB_TIMEOUT=10
GRUB_DISTRIBUTOR=`lsb_release -i -s 2> /dev/null || echo Debian`
#GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash acpi=off"
GRUB_CMDLINE_LINUX=""



# Uncomment to enable BadRAM filtering, modify to suit your needs
# This works with Linux (no patch required) and with any kernel that obtains
# the memory map information from GRUB (GNU Mach, kernel of FreeBSD ...)
#GRUB_BADRAM="0x01234567,0xfefefefe,0x89abcdef,0xefefefef"

# Uncomment to disable graphical terminal (grub-pc only)
#GRUB_TERMINAL=console
exit

# The resolution used on graphical terminal
# note that you can use only modes which your graphic card supports via VBE
# you can see them in real GRUB with the command `vbeinfo'
#GRUB_GFXMODE=640x480

# Uncomment if you don't want GRUB to pass "root=UUID=xxx" parameter to Linux
#GRUB_DISABLE_LINUX_UUID=true

# Uncomment to disable generation of recovery mode menu entries
#GRUB_DISABLE_RECOVERY="true"

# Uncomment to get a beep at grub start
#GRUB_INIT_TUNE="480 440 1"
GRUB_DISABLE_OS_PROBER=false
 
OK, it's not the disable recovery option at fault.

Do you have an option for Advanced Options in your Grub Menu, and does that have only one option on it or more?

Wiz
 
Have you tried generating new grub.cfg with # grub-mkconfig -o /boot/grub/grub.cfg?
 
Aah, might take a moment or two, I am flipping between about 3 distros.

Output of

Code:
ls /boot

would be good.

Welcome to linux.org @dankobatina , and thanks for the input but that won't be it.

Chris Turner
wizardfromoz
 
brian@brian-desktop:~$ ls /boot
config-5.15.0-46-generic initrd.img.old
config-5.15.0-50-generic System.map-5.15.0-46-generic
efi System.map-5.15.0-50-generic
grub vmlinuz
initrd.img vmlinuz-5.15.0-46-generic
initrd.img-5.15.0-46-generic vmlinuz-5.15.0-50-generic
initrd.img-5.15.0-50-generic vmlinuz.old
brian@brian-desktop:~$
 
Oh, and
Code:
uname -r
 
brian@brian-desktop:~$ uname -r
5.15.0-46-generic
brian@brian-desktop:~$
 
5.15.0-50 is also installed, but not showing in grub
 
5.15.0-50 is also installed,...

Well, parts of it are, but not complete.

Hang on and I'll jump ship from MX-21 and slip into Vanessa and a dry martini.
 
My ls /boot looks as follows but I have not run my updates yet.

config-5.15.0-41-generic initrd.img.old
config-5.15.0-43-generic System.map-5.15.0-41-generic
config-5.15.0-47-generic System.map-5.15.0-43-generic
efi System.map-5.15.0-47-generic
grub vmlinuz
initrd.img vmlinuz-5.15.0-41-generic
initrd.img-5.15.0-41-generic vmlinuz-5.15.0-43-generic
initrd.img-5.15.0-43-generic vmlinuz-5.15.0-47-generic
initrd.img-5.15.0-47-generic vmlinuz.old

I only run updates about once a month except for security updates, and before and after, Timeshift a full snap.

I'm due to run the updates around now, so I can see if there is anything unusual about 5.15.0-50 , or else you might choose to restore a Timeshift snap in the meantime, and see what effect that has/hasn't.

More info we get, the better, IMO.
 
Got it - probably, back soon, gotta fill my glass, if I find the bugger who emptied it, he's dead.
 
make sure you give him a bloody good hiding !!
 
Ta for your patience ;)

Went into Update Manager - View - kernels which I had not been to for ages and found this

Dd7BQIT.png


Now, historically, you have usually had, in this environment, several options perhaps in the left-hand pane, and a number of active and installed options in the right-hand column.

Note all the "superseded", now.

So, my bad, first question I should have asked was

"Have you run updates recently?"

I will know more when I run mine, but this will be connected.

Wiz
 
I run updates every day....sometimes a few times a day

1665556003406.png
 
condobloke wrote:
I have 3 kernels installed.
....
How to get all three to appear ?
In my debian, if I add: GRUB_DISABLE_SUBMENU=y, to /etc/default/grub, and update grub, then all kernels present on screen at boot.
 
I tried GRUB_DISABLE_SUBMENU=y, earlier in my day, with no effect
 

Members online


Top