Solved X server not running [SOLVED]

Solved issue
This is a pretty old thread. Odds are good that OP has moved on and/or resolved the issue (one way or another).
You reckon? Yeah, the OP has probably sold his PC by now after not being able to fix it. /s

But since the OPs question contained the most concise command to restore the xfce GUI I could find...

apt install xserver-xorg x11-xserver-utils xfonts-base x11-utils lightdm lightdm-gtk-greeter xfce4 xfce4-goodies xinit -y

... which helped me, I thought I'd repay in kind.

So, to add value to this forum and for the sake of future Googlers, the correct answer to the OPs question is:

startxfce4
 


... which helped me, I thought I'd repay in kind.

The general consensus is to start your own new thread to share your fix, but it's not like a hard rule or anything. We just try not to dredge up old threads - again, only as a general rule. Depending on folk's settings, your post would have sent out all sorts of notifications to people sometimes long gone.

But, hopefully, your fix is effective and solves issues for people. If it helps even one person, that'd be a good thing. So, thanks for adding it.
 
I does not really know why installing xserver-xorg-legacy works but now startx is working without any Login Manager and root user.
You reckon? Yeah, the OP has probably sold his PC by now after not being able to fix it. /s
Hi! I was able to fix this issue. I also marked is as solved and also provided the solution which worked for me.

It looks like I forgot to mention that i have tried to run X server using startxfce4. I also had exec startxfce4 in my .xinitrc file.
Staring window/desktop environment was not the issue as I already stated that at start of this thread. It was something related to graphics driver and permissions of current user. Because withusing root as user, everything was working fine. But it was not working with normal user.

Thanks!
 
Last edited:


Top