Linux Mint Install Failure on older ASUS Zenbook N501JW

Just to be thorough I disconnected the battery, the "watch battery", and the RAM. I pressed the Power Button for minutes at a time, and waited a full 15 minutes before reconnecting everything.

The BIOS date/time reset. I load into Linux Boot Repair and still get the 'Locked-NVram detected' error. I don't know how to clear that. Perhaps that is the problem?
 

Attachments

  • ASUS disconnected.jpg
    ASUS disconnected.jpg
    2.4 MB · Views: 159
  • Locked NVram.jpg
    Locked NVram.jpg
    940.4 KB · Views: 205


And just to triple-check... I installed the Linux NVMe into my desktop computer and Linux Mint booted up. So it seems like the problem is pointing at the ASUS laptop.
 

Attachments

  • Desktop Linux.jpg
    Desktop Linux.jpg
    1 MB · Views: 149
Just to be thorough I disconnected the battery, the "watch battery", and the RAM. I pressed the Power Button for minutes at a time, and waited a full 15 minutes before reconnecting everything.

The BIOS date/time reset. I load into Linux Boot Repair and still get the 'Locked-NVram detected' error. I don't know how to clear that. Perhaps that is the problem?
I'm out of ideas, I'm sorry.
However I did look up that exact message {error nvram is locked (linuxmint not found in efibootmgr) that you are getting and found this. It looks promising to me. I hope it works for you.

 
Last edited:
Yes, it does appear that the problem is with the Asus laptop. Not 100 % sure but I think it's a BIOS issue.
You could call the Asus Technical Support # and ask them how to get around this issue.

1 (888) 678-3688

 
I'm out of ideas, I'm sorry.
However I did look up that exact message {error nvram is locked (linuxmint not found in efibootmgr) that you are getting and found this. It looks promising to me. I hope it works for you.
Thank you for your help and your suggestion.

I did try steps 6 - 11. I opened Terminal and pasted this code:
sudo efibootmgr -c -d /dev/nvme0n1 -p 1 -l \\efi\\ubuntu\\grubx64.efi -L "Linux Mint"

Relaunched Boot Repair and ran it. Upon reboot unfortunately my laptop went straight to BIOS again. The 'Boot" section of my BIOS still does not show a drive. ASUS really didn't want anyone to install Linux on their machine, I think.
 

Attachments

  • easylinuxtipsproject.jpg
    easylinuxtipsproject.jpg
    961.1 KB · Views: 171
It is possible that the BIOS upgrade you did had a problem. One expects that a BIOS upgrade does improve on the one it replaces. Reflashing BIOS is often said to be a risky installation, and known to brick computers. I'm wondering whether another attempt at reflashing the BIOS would be worth a shot. If you could get official support as Alexee pointed to, that would be good. Perhaps search online to see if there have been problems with that particular BIOS and upgrade.

I expect you've reset the BIOS to factory defaults at some point to test that, though it doesn't sound hopeful at this point.
 
Last edited:
Perhaps our member @Brickwizard can trouble shoot this issue?
OK some general thoughts [as its not on my bench,] note I have not ha d time to read the full story so far!

NOT all NVMe's and SSD's are Linux compatible, there are only a few that are not [google your full make/model number with "Linux compatible", and see if anyone else has had the same problem.

Assuming the drive is not at fault, first check the boot order in the BIOS, it should be USB, NVMe,[other storage] [other input eg. optical drive]
next check the SATA settings [also in BIOS]

Have you disabled windows fast boot [quick start] if it came as W8/10/11, as well as secure boot?

I see you used Rufus to burn your ISO, Rufus has not been playing well with Linux for now about 2 years, Try https://www.balena.io/etcher.
Use a good quality, reasonably new branded pen-drive [old one's can developed faults which don't show up with windows or using as a storage extension]

These are my thoughts. at the moment.
 
I have a 2012 Asus laptop that came with w7...If I want to install Mint Cinnamon...I download the ISO and burn it to a Flash Drive with Etcher. It's running Cinnamon 20.3 now but might install 21.1 or maybe 21.2 which comes out soon...Laptop now has a 500GB SSD.

I plug in the Flash Drive...then press the power button...then start tapping the Esc key which brings up the Boot Option Menu...I then select my Flash Drive and hit Enter which Boots to Mint.
m1212.gif
 
ok so I have had a quick read through, some further thoughts
I installed the Linux NVMe into my desktop computer and Linux Mint booted up. So it seems like the problem is pointing at the ASUS laptop.
Can you run Mint live from the pen-drive and use it to get online from the Acer? If yes,make sure the NVMe is connected, then run live, make sure it's connected to the net, then in the terminal run inxi -Fnxxz, and copy/paste back the result
I updated to the latest BIOS
I only update BIOS as a last result, as it often causes more problems than it solves, and then only if I can tell it is at fault, on a 2015 machine that should not be necessary.

When purging the BIOS memory and re-setting the bios, do not remove the ram on that machine you disconnect from mains, remove all accessories [USB's, etc] switch on, the press and hold the power on button down for 60 seconds release and re-boot,[you do not need to remove any batteries]

The next move is a pain. Do you still have the original ssd/hard-drive for that machine? Is it in working order? If you now re-install it, will it boot up normally? If it boots normally and works then the bios should be OK, and we are back to either compatibility or settings errors
NOT all NVMe's and SSD's are Linux compatible,
Finally,
I have just discovered the Zenbook N501** series is not on the NVMe compatibility list.

Are you sure it has an NVMe card and not an SSD [both can have the same pin configuration]

{I Will not edit any of my post in this thread as the general notes may be useful to others}
 
Last edited:
I have just discovered the Zenbook N501** series is not on the NVMe compatibility list.
Are you sure it has an NVMe card and not an SSD [both can have the same pin configuration]
That is interesting. The OEM Drive, which I still have and use, is a Samsung SM951, which is a SSD drive. (I thought it was a NVMe).

Maybe that is why the BIOS does not even show my NVMe drive. That would make sense why the laptop goes straight to BIOS.

Looks like I need to find a SSD drive and try that.

Very interesting. I thought all M.2-type drives were NVMe.

Edit. I just found a sticker on the laptop that says: "2280 M.2 SATAIII SSD only"
 

Attachments

  • SSD Only.jpg
    SSD Only.jpg
    4.6 MB · Views: 163
Last edited:
M2 is the basic pin configuration, this may be worth reading
Thanks again. Picking out a drive is more complicated than I thought.

Samsung doesn't make it easy either. They made two different versions of the OEM SM951.

Distinguishing the AHCI and NVMe version from each other isn't very simple as the difference lies in a single character in the model number. The AHCI version carries the code MZ-HPVxxx0 (where xxx is the capacity in gigabytes), whereas the NVMe version is called MZ-VPVxxx0.

I made sure to buy the MZ-HPV2560 which is the AHCI version. It is not as popular as the NVMe version so I had to order it from China.
 
Update.

I bought and received a used OEM Samsung SM951 MZ-HPV2560 AHCI SSD.

BIOS recognized the drive and Linux Mint installed! That is a major success!

I do get this following error each time I boot up: "failure writing sector 0x149db800 to 'hd0'"

After I get past that error Mint loads and I can use it without problems. I have reinstalled Mint a few times along with Ubuntu, but the error persists.

Does this point to a bad SSD? It is an original drive from around 2015.
 
Does this point to a bad SSD? It is an original drive from around 2015
Possibly, it could also be a hidden partition at the beginning of the drive if previously used for windows where Linux likes to install grub
use Smartctl to test the hard=drive [it may be installed, if not it will be in the software manager]
 
I think I ran Smartctl correctly. Here is the result I got:

== START OF INFORMATION SECTION ===
Model Family: Samsung based SSDs
Device Model: SAMSUNG MZHPV256HDGL-000L1
Serial Number: S1WTNYAFC04638
LU WWN Device Id: 5 002538 900000000
Firmware Version: BXW22L0Q
User Capacity: 256,060,514,304 bytes [256 GB]
Sector Size: 512 bytes logical/physical
Rotation Rate: Solid State Device
TRIM Command: Available
Device is: In smartctl database [for details use: -P show]
ATA Version is: ACS-2, ATA8-ACS T13/1699-D revision 4c
SATA Version is: SATA 3.1, 6.0 Gb/s (current: 6.0 Gb/s)
Local Time is: Wed Jun 7 20:30:43 2023 EDT
SMART support is: Available - device has SMART capability.
SMART support is: Enabled

=== START OF READ SMART DATA SECTION ===
SMART overall-health self-assessment test result: PASSED

General SMART Values:
Offline data collection status: (0x00) Offline data collection activity
was never started.
Auto Offline Data Collection: Disabled.
Self-test execution status: ( 0) The previous self-test routine completed
without error or no self-test has ever
been run.
Total time to complete Offline
data collection: ( 0) seconds.
Offline data collection
capabilities: (0x53) SMART execute Offline immediate.
Auto Offline data collection on/off support.
Suspend Offline collection upon new
command.
No Offline surface scan supported.
Self-test supported.
No Conveyance Self-test supported.
Selective Self-test supported.
SMART capabilities: (0x0003) Saves SMART data before entering
power-saving mode.
Supports SMART auto save timer.
Error logging capability: (0x01) Error logging supported.
General Purpose Logging supported.
Short self-test routine
recommended polling time: ( 2) minutes.
Extended self-test routine
recommended polling time: ( 20) minutes.
SCT capabilities: (0x003d) SCT Status supported.
SCT Error Recovery Control supported.
SCT Feature Control supported.
SCT Data Table supported.

SMART Attributes Data Structure revision number: 1
Vendor Specific SMART Attributes with Thresholds:
ID# ATTRIBUTE_NAME FLAG VALUE WORST THRESH TYPE UPDATED WHEN_FAILED RAW_VALUE
5 Reallocated_Sector_Ct 0x0033 100 100 010 Pre-fail Always - 0
9 Power_On_Hours 0x0032 097 097 000 Old_age Always - 13975
12 Power_Cycle_Count 0x0032 090 090 000 Old_age Always - 9751
170 Unused_Rsvd_Blk_Ct_Chip 0x0032 100 100 010 Old_age Always - 0
171 Program_Fail_Count_Chip 0x0032 100 100 010 Old_age Always - 0
172 Erase_Fail_Count_Chip 0x0032 100 100 010 Old_age Always - 0
173 Wear_Leveling_Count 0x0033 071 071 005 Pre-fail Always - 907
174 Unexpect_Power_Loss_Ct 0x0032 099 099 000 Old_age Always - 96
178 Used_Rsvd_Blk_Cnt_Chip 0x0013 100 100 010 Pre-fail Always - 0
180 Unused_Rsvd_Blk_Cnt_Tot 0x0013 100 100 010 Pre-fail Always - 767
184 End-to-End_Error 0x0033 100 100 097 Pre-fail Always - 0
187 Uncorrectable_Error_Cnt 0x0032 100 100 000 Old_age Always - 0
194 Temperature_Celsius 0x0032 063 039 000 Old_age Always - 37
199 CRC_Error_Count 0x003e 100 100 000 Old_age Always - 0
233 Media_Wearout_Indicator 0x0032 099 099 000 Old_age Always - 232304
241 Total_LBAs_Written 0x0032 099 099 000 Old_age Always - 22937
242 Total_LBAs_Read 0x0032 099 099 000 Old_age Always - 32858

SMART Error Log Version: 1
No Errors Logged

Warning! SMART Self-Test Log Structure error: invalid SMART checksum.
SMART Self-test log structure revision number 1
Num Test_Description Status Remaining LifeTime(hours) LBA_of_first_error
# 1 Short offline Completed without error 00% 13975 -

Warning! SMART Selective Self-Test Log Structure error: invalid SMART checksum.
SMART Selective self-test log data structure revision number 1
SPAN MIN_LBA MAX_LBA CURRENT_TEST_STATUS
1 0 0 Not_testing
2 0 0 Not_testing
3 0 0 Not_testing
4 0 0 Not_testing
5 0 0 Not_testing
255 0 65535 Read_scanning was never started
Selective self-test flags (0x0):
After scanning selected spans, do NOT read-scan remainder of disk.
If Selective self-test is pending on power-up, resume after 0 minute delay.
 
Reading through the output I didn't see any input/output errors or any mention of bad sectors.

In post #35 you explained that your system shows:
Code:
"failure writing sector 0x149db800 to 'hd0'"

Is there more to that message?
Maybe "failure writing sector 0x149db800 to 'hd0'" Bad sectors?

I believe @Brickwizard is right, that it's more likely a hidden partition that's Windows related.

Maybe give fsck a spin. If fsck find's any problems it will fix it or at the very least show what problems it finds marking sectors as bad. Your system eventually boots tho so you may not need to run fsck. See the article/link below.

How to Use ‘fsck’ to Repair Linux File System Errors


 
Is there more to that message?
Maybe "failure writing sector 0x149db800 to 'hd0'" Bad sectors?
That is the exact error I get when I boot up.

I believe @Brickwizard is right, that it's more likely a hidden partition that's Windows related.
Would it still be there after I erased the drive when I installed Mint? My intention is to single boot Linux via this drive.

I ran fsck and this is what I got:

fsck from util-linux 2.37.2
e2fsck 1.46.5 (30-Dec-2021)
ext2fs_open2: Bad magic number in super-block
fsck.ext2: Superblock invalid, trying backup blocks...
fsck.ext2: Bad magic number in super-block while trying to open /dev/sdb

The superblock could not be read or does not describe a valid ext2/ext3/ext4
filesystem. If the device is valid and it really contains an ext2/ext3/ext4
filesystem (and not swap or ufs or something else), then the superblock
is corrupt, and you might try running e2fsck with an alternate superblock:
e2fsck -b 8193 <device>
or
e2fsck -b 32768 <device>

Found a dos partition table in /dev/sdb


Thanks again for any and all help.
 

Attachments

  • Error.jpeg
    Error.jpeg
    492 KB · Views: 152


Top