Linux Mint Install Failure on older ASUS Zenbook N501JW

Jerry-Linux

New Member
Joined
May 20, 2023
Messages
22
Reaction score
8
Credits
204
Linux Noob here.

I am trying to install Linux Mint 21.1, Cinnamon Edition on my older ASUS Zenbook N501JW laptop. After I load and install Linux Mint via USB my laptop boots straight to BIOS. Every time.

The process I have followed thus far:

Prep for Install
  1. I have a brand new NVMe drive installed in the ASUS laptop
  2. I have disabled "Secure Boot" in BIOS.

Installation process
  1. I used RUFUS 4.0 to create a bootable version of Linux Mint 21.1 on a USB Drive.
  2. I have tried both Partition Schemes of MBR and GPT. But in the current version I am trying MBR.
  3. In my BIOS I have disabled "Secure Boot"
  4. I connect my USB drive in my ASUS laptop and boot to the GNU GRUB --> and click Start Linux Mint 21.1 Cinnamon 64-bit
  5. I double click "Install Linux Mint" --> "Erase disk and install Linux Mint"

After Installation and reboot my ASUS laptop goes straight to BIOS.

Troubleshooting
I am able to put the NVMe drive into a modern desktop computer and Linux boots fine
, so the problem seems to point to the ASUS laptop.
When I place the USB drive back in and load Linux Live and load "Boot Repair" and click "Recommended repair" I get the following error: "Error: NVram is locked (Linuxmint not found in efibootmgr)."

I have updated my BIOS. I have disconnected my laptop battery and the small watch-type battery from the ASUS laptop in order to reset the BIOS.

Unfortunately, I cannot get past the BIOS in my ASUS laptop.

Any help or ideas would be appreciated.

(Attached is the boot info document for the error I get)
 

Attachments

  • Boot-Info_20230520_1820.txt
    11.3 KB · Views: 234


Linux Noob here.
....
Any help or ideas would be appreciated.

(Attached is the boot info document for the error I get)
Being "Noob" I guess will have its challenges.

It's worth noting that the clearing of the CMOS to clear the NVRAM has worked for some online, but unfortunately not here apparently. You need to be sure that the battery was out of the computer for a long enough time for the data to clear. Five minutes is almost certainly enough, if not overkill, but it's on the safe side of such things.

In some BIOS/UEFIs there is a setting for the type of installation, maybe characterised as "legacy" versus "windows", or even "unix" in some. Not being familiar with your particular BIOS/UEFI version, I can't say more other than perhaps have a look to see if there is such a setting and change it away from "windows" if it's not already so.

The trouble seems to be the BIOS/UEFI not seeing the operating system. There's a chance something in the bootloader that may be amiss preventing ID. So what comes to mind is using a linux live disk on a usb and see if it can see the installation, which I would expect it could. A Mint live disk would suffice. Then I'd consider re-installing grub. I realise as a "Noob" there is a learning curve to this, which I would leave to you at the moment. There are some ideas here for such an installation on debian: https://wiki.debian.org/GrubEFIReinstall, but you may find something else directly for your Mint.

Another idea is look into the Boot Repair tool here: https://sourceforge.net/p/boot-repair/home/Home/. It's known to work with Mint.
 
Last edited:
Reading through the file you attached I see that:
Code:
 => No boot loader is installed in the MBR of /dev/nvme0n1.

So there is that. Did you verify the integrity of the .iso file before you instructed Rufus to make it bootable on your usb thumb drive?

And from the reading I did NVRAM Locked is associated with the BIOS.
You may need to go to the manufacturer's website and download the latest for your machine.

IF and when you upgrade/flash your BIOS....make absolutely certain (check twice) that you have the "exact" update/upgrade for your "exact machine" and "exact BIOS" or it could turn your machine into a brick.
 
Last edited:
I ran the boot information script so you can see. Grub was installed to my /dev/sda/ HDD-

Boot Script.png
 
You need to be sure that the battery was out of the computer for a long enough time for the data to clear. Five minutes is almost certainly enough, if not overkill, but it's on the safe side of such things.
I updated to the latest BIOS plus I disconnected the battery plus the "watch battery" and waited for over 10 minutes. The BIOS reset at that point.
 

Attachments

  • ASUS.jpg
    ASUS.jpg
    6.4 MB · Views: 132
In some BIOS/UEFIs there is a setting for the type of installation, maybe characterised as "legacy" versus "windows", or even "unix" in some. Not being familiar with your particular BIOS/UEFI version, I can't say more other than perhaps have a look to see if there is such a setting and change it away from "windows" if it's not already so.
I don't see that in the BIOS. It seems like a pretty simple BIOS compared to other computers I owned in the past.
 

Attachments

  • BIOS 1.jpg
    BIOS 1.jpg
    945.3 KB · Views: 188
  • BIOS 2.jpg
    BIOS 2.jpg
    921.5 KB · Views: 162
  • BIOS 3.jpg
    BIOS 3.jpg
    860.3 KB · Views: 178
  • BIOS 4.jpg
    BIOS 4.jpg
    1.1 MB · Views: 212
  • BIOS 5.jpg
    BIOS 5.jpg
    902.3 KB · Views: 254
I updated to the latest BIOS plus I disconnected the battery plus the "watch battery" and waited for over 10 minutes. The BIOS reset at that point.
Congratulations ... that's pleasing. But did it work to get a boot?
 
So there is that. Did you verify the integrity of the .iso file before you instructed Rufus to make it bootable on your usb thumb drive?

And from the reading I did NVRAM Locked is associated with the BIOS.
You may need to go to the manufacturer's website and download the latest for your machine.
I can put the NVMe drive in another computer and it boots Linux Mint fine. I think the issue has to do with my ASUS laptop unless I am missing something.

I did go to ASUS website and update the BIOS to the latest version. I also reset BIOS too.
 
I don't see that in the BIOS. It seems like a pretty simple BIOS compared to other computers I owned in the past.
It's not looking present in the pics, but maybe consider going through the whole BIOS/UEFI and check every single setting. I know I've had to do that in the past, not being a BIOS aficionado.

Very perplexing.
Yes.
 
I ran the boot information script so you can see. Grub was installed to my /dev/sda/ HDD-
I am not sure what this means. Do you mean that the installation of Linux Mint was fine? I can take out the NVMe with the Linux install on it and get it working in my desktop computer. But not my ASUS laptop.
 
I am not sure what this means. Do you mean that the installation of Linux Mint was fine? I can take out the NVMe with the Linux install on it and get it working in my desktop computer. But not my ASUS laptop.
If it boots elsewhere, as you mention, then the installation does look fine.

Apart from the other suggestions, it may be informing to look at the factory specifications of the BIOSs and the changes made to each version as they upgraded, if that information is available and accessible. One shouldn't have to delve this deep, but it's a thought.
 
Screenshot #3 that you posted shows the Boot section of your BIOS.
Click on 'Boot Option Priorities' and see if you have any options to tell the BIOS to boot directly to your NVME drive.

And to answer your question in post #13 at the very top of the boot information script that you posted it didn't look like Grub was installed to your NVME drive. However, as you said, and as osprey said, also it boots elsewhere the install is good.
Perplexing indeed!

The SSD capacity on your Asus lapto is 128 GB's. Is your NVME more than 128 GB's?
 
Last edited:
@osprey
OP screenshot #3 of the BIOS Boot Menu shows that CSM (compatibility support module) is 'enabled'.

CSM offers backward compatibility by booting the machine as if you were running a legacy BIOS system.
Could this be why that Asus laptop doesn't want to boot?
 
Click on 'Boot Option Priorities' and see if you have any options to tell the BIOS to boot directly to your NVME drive.

And to answer your question in post #13 at the very top of the boot information script that you posted it didn't look like Grub was installed to your NVME drive. However, as you said, and as osprey said, also it boots elsewhere the install is good.
Perplexing indeed!

The SSD capacity on your Asus lapto is 128 GB's. Is your NVME more than 128 GB's?
I unfortunately can not click on 'Boot Option Priorities.' However, when I reinstall the Windows NVMe, I get the option of 'Boot Option #1 [Windows Boot Manager]' Interestingly enough, there is not a Boot Option with the Linex NVMe installed. Not sure what that means. Maybe it can't find the drive?

The OEM NVMe that came with the ASUS was/is a 512GB which works fine.
 

Attachments

  • BIOS with Windows Drive.jpg
    BIOS with Windows Drive.jpg
    909.3 KB · Views: 109
OP screenshot #3 of the BIOS Boot Menu shows that CSM (compatibility support module) is 'enabled'.

CSM offers backward compatibility by booting the machine as if you were running a legacy BIOS system.
Could this be why that Asus laptop doesn't want to boot?
I have disabled and enabled 'Launch CSM' and my ASUS laptop enters the BIOS either way.
 
I unfortunately can not click on 'Boot Option Priorities.' However, when I reinstall the Windows NVMe, I get the option of 'Boot Option #1 [Windows Boot Manager]' Interestingly enough, there is not a Boot Option with the Linex NVMe installed. Not sure what that means. Maybe it can't find the drive?

The OEM NVMe that came with the ASUS was/is a 512GB which works fine.
Perhaps our member @Brickwizard can trouble shoot this issue?
 

Members online


Latest posts

Top