Issue with Bang & Olufsen speakers

Lord Boltar

Well-Known Member
Joined
Nov 24, 2020
Messages
978
Reaction score
630
Credits
7,255
We have to do some manual settings editing on pulse audio config. The path is /etc/pulse/daemon.conf. Open a terminal by pressing ctrl+alt+t. First of all, backup the configuration file:

Code:
sudo cp /etc/pulse/daemon.conf /etc/pulse/daemon.conf.backup

Then type
Code:
sudo gedit /etc/pulse/daemon.conf
- you may have to replace gedit with your text editor

(If your file is empty, it means the file you are looking for is not in this directory. In this case, try to locate it:
Code:
sudo updatedb
, this will update your files database index. Then type
Code:
locate daemon.conf
to find the file location. Replace /etc/pulse/ with the path to your daemon.conf file)

Find the following lines (ctrl+w to find text in file) and replace your values with the following (lines might be in a different order in your system):

default-sample-format = float32ne
default-sample-rate = 48000
alternate-sample-rate = 44100
default-sample-channels = 2
default-channel-map = front-left,front-right

default-fragments = 2
default-fragment-size-msec = 125
resample-method = speex-float-5
enable-lfe-remixing = no
high-priority = yes
nice-level = -11
realtime-scheduling = yes
realtime-priority = 9
rlimit-rtprio = 9
rlimit-rttime = -1
daemonize = no

Press ctrl+o to save changes, then press ctrl+x to quit

now type
Code:
gedit ~/.asoundrc
in terminal and paste the following code:

pcm.!default {
type plug
slave.pcm hw
}

This will bypass dmix for pulseaudio increasing sound quality by a lot. You can’t have more than one resampler because if you do it gets resampled twice and some sound quality is lost
 


wizardfromoz

Administrator
Staff member
Gold Supporter
Joined
Apr 30, 2017
Messages
6,611
Reaction score
5,369
Credits
19,514
$100 Digital Ocean Credit
Get a free VM to test out Linux!

Members online


Top