Installing a USB wifi unit in Ubuntu 20.04

I connected and now it appeared different

It shows, indeed, that it is an RTL8812AU.

You have that driver installed.

You possibly cannot hot-boot it. That is, you cannot start your computer and then plug it in, You must instead plug it in first and then switch on your computer. That way it is detected,
I have the same problem, and typed the command ubuntu-drivers devices, what appeared to me was the following:View attachment 6881
can anybody help me? please explain as if it were for a 5 year old child
Look at what it is telling you.

Now run:
sudo apt install rtl8812au-dkms
I am a newbie here. I have tried installing Ubuntu 16.4 18.04LTE and 20.04 and Linux-Mint on a Dell Tower 790 i7 and a Dell Workstation Gamer T3610 Xeon E5 2650 8 core 16 thread Geforce GTX 1070 (built sub £500). But the wifi does not work with Linux on either machine, as per the original opening question here.
I was looking to move from Win 10 on which wifi works fine or create a dual boot system.
On all my Rpi p4 thr wifi is on board so any command sudo apt update instantly works but on Dell only failed failed, reported.
I hope this is pretty clear that any commands to upgrade, or 'get' visit sites Https WWW Fails. There is no wifi connection.
Trying say isusb shows no wifi dongle. A network search shows only ethernet available.
it would be VERY strange to use a Rpi P4 to link to the WWW by cable.

Following advice here I've ordered Linux approved usb dongle. Thanks. I'll try it out and report back.
Reporting back after two days and about 8.5 hours. On my Linux Mint installed the new Bros Trend AC 1200 wifi usb as recommended as fully Linux compatible from Amazon $45 usb wifi. Copied THE Linux files various into C;\ drive while under win10 though not needed as Linux all variations unbutu zorin debian Lunbutu raspian Xunbutu etc plus 22 recognise this Bros Trend wifi guaranteed (nearly).
After reIoading I mean they the usb's are in the PC but no wifi is found!!! Checking usb list and list network nothing found except Wired. OK so I loaded latest Mint v20 No joy again!! no wifi found (though windows does find it). OK tried Linux Zorin its suggested will find any Wifi but that stalls on final load up page, another 2 trys failed so I moved on.
It is highly recommended to go Wired then sudo apt-get update/upload everything Wifi then works but my isp is through my phone Hotspot which used 347gb of data last month thats unlimited Data in my $30 phone package. I mention this only as I'd willingly download all and every variant of Linux to find one that fixed this Wifi "no found problem".
I'll continue trying but as I mentioned my RPI P4 v2 with 4 meg ram on board wifi bluetooth (ethernet if required) and its brill No problems. An old Dell laptop win 10 to type here on a Linux site does fine.
After the OP and three more similar, but not the same questions I think everyone is confused. This should have been 4 different posts.

The bottom line is this, Ubuntu has tools built in to at least try to detect drivers and to then either install directly or indicate what to install. These questions always come down to finding/having/installing the correct driver.
For Cudy WU700 AC650 on Ubuntu 20.04 I just used this driver installing as .deb and worked fine

on page

Just bought it and had your same problems, then searching I found a BrosTrend stick that's almost the same and its driver works fine
Sorry, It is AM3, but why you need the rest , I last since 2013, with few hardware upgrades he he he.
remote login not authorased. My target is GNU UBUNTU.


our page at internet, anandamargario . com

there is the ONG bank and data.
i was also having same problem with wifi and installed software for ID 0bda:f179 Realtek , but it was useless. why these software are not working?i am still surfing internet by ethernet. can anyone help me in finding wifi software?

raman@raman:~$ lsusb
Bus 002 Device 004: ID 1c4f:0c07 SiGma Micro
Bus 002 Device 003: ID 275d:0ba6
Bus 002 Device 002: ID 8087:0024 Intel Corp. Integrated Rate Matching Hub
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 001 Device 005: ID 05c6:aaff Qualcomm, Inc.
Bus 001 Device 003: ID 0bda:f179 Realtek Semiconductor Corp.
Bus 001 Device 002: ID 8087:0024 Intel Corp. Integrated Rate Matching Hub
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Once you are able to see the device using lsusb, you MUST add the user to the dialout group and then reboot. Had problem installing mine, but remembered a similar issue with a USB serial adaptor for programming a two-way radio in the past. Added my user to the dialout group, rebooted, And my network manager then was able to see the device and list the visible connections.

Also there was a thread on another group regarding the drivers. Look for "cudy_wu700_ac650-master" for drivers that fix a known compatibility issue with later versions of ubuntu/linux.
Hey I‘m trying to get my usb Cudy ac1300, and I did the lsusb in terminal and one of the things was bus 002 device 002: ID 0bda:b812 realtek semiconductor Corp. RTL88x2bu [ac1200 techkey].
what does this mean, and is this the usb device. Also the other things on the list were Linux things, my keyboard, the mouse, and more Linux stuff. Is the Cudy
adapter just realtek.
hi welcome to the forums @Fippy
you do not tell us which distribution you are running... try in a terminal type inxi -fnxz copy and past the output for the whole section labeled network
The thread is almost a year old. You'd likely do better starting your own thread @Fippy

Staff online

Members online