Solved I'm back and again, no sound...

Solved issue


Jul 1, 2023
Reaction score
Hi folks! I recently had a problem concerning ubuntu 22.10 and pipewire, switching back to pulse audio.

I accidentally revived an old thread with my issue:

Update: I got pipewire working now. It's no longer a linux problem but a audacity problem. What helped me was this:
sudo apt install pipewire-audio-client-libraries libspa-0.2-bluetooth libspa-0.2-jack systemctl --user mask pulseaudio systemctl --user --now enable pipewire{,-pulse}.{socket,service}

Now I pretty much have the opposite problem:
  • Have upgraded to Ubuntu 23.04
  • Couldn't get my microphone working (for hours)
  • Figured I'd revert the changes and try pipewire since in 23.04 it should be more stable
  • Was reminded how many changes I had to make to disable pipewire and enable pulse audio
  • Reverted some changes using a guide, quickly destroyed my desktop gui
  • reinstall ubuntu desktop from the command line helped
  • now I have no sound at all
  • pipewire wont start
  • xdg-desktop-portal and xdg-desktop-portal-gnome are installed and I think they're running
  • but pipewire cant find them

systemctl --user status pipewire.service
shows the following output:

● pipewire.service - PipeWire Multimedia Service Loaded: loaded (/usr/lib/systemd/user/pipewire.service; enabled; preset: enabled) Active: active (running) since Tue 2023-09-19 13:09:44 CEST; 2min 23s ago TriggeredBy: ● pipewire.socket Main PID: 3218 (pipewire) Tasks: 2 (limit: 38029) Memory: 2.3M CPU: 45ms CGroup: /user.slice/user-1000.slice/[email protected]/session.slice/pipewire.service └─3218 /usr/bin/pipewire Sep 19 13:09:44 haui-TowerPC systemd[3211]: Started pipewire.service - PipeWire Multimedia Service. Sep 19 13:09:44 haui-TowerPC pipewire[3218]: mod.rt: Can't find org.freedesktop.portal.Desktop. Is xdg-desktop-portal running? Sep 19 13:09:44 haui-TowerPC pipewire[3218]: mod.rt: found session bus but no portal

inxi -xxz --audio

Audio: Device-1: Intel 200 Series PCH HD Audio vendor: ASUSTeK driver: snd_hda_intel bus-ID: 1-2:3 v: kernel bus-ID: 00:1f.3 chip-ID: 1686:033f chip-ID: 8086:a2f0 Device-2: NVIDIA GA104 High Definition Audio vendor: PNY driver: snd_hda_intel v: kernel pcie: speed: 2.5 GT/s lanes: 16 bus-ID: 65:00.1 chip-ID: 10de:228b Device-3: ZOOM U-22 type: USB driver: snd-usb-audio Sound API: ALSA v: k6.2.0-33-generic running: yes Sound Server-1: PulseAudio v: 16.1 running: no Sound Server-2: PipeWire v: 0.3.65 running: yes

It looks somewhat promising but I only have dummy outputs and no sound option on the top right menu. It worked well with pulse audio but somehow pipewire is back to catastrophe now.

TL;DR: My mic didnt work with my pulse audio mod and I (hastily) reverted back to pipewire and now my sound is dead and buried. :(

Thanks for reading. Have a good one.
Last edited:

Thanks for the suggestion. I don’t think changing the whole OS is the solution for me. But I might try mint some time down the road just to know more.
I don't suppose you have any backups that you can restore.
I don't suppose you have any backups that you can restore.
Not from that particular time. But it works now so its not necessary anyway.
You should probably use this as an indicator that it's time to make a backup.
You should probably use this as an indicator that it's time to make a backup.
You‘re right. Since I‘m not reinstalling at this time it is probably best to back the machine up now. Thanks for the reminder. :)

Members online