Useless icons on screen following installation

LinuxLifer

New Member
Credits
192
Nice try Vrai, but unfortunately not. I tried several themes before settling on one and the problem icons persisted through all.

G'day Wiz. And it is another beautiful day in my part of Oz.
Synaptic is usually just about the first package I install and the History shows many installs.
I don't find your approach in any way patronizing or condescending. You don't know what I know or don't, so you have to ask -- no worries. There are smart asses with sarcastic or cryptic replies, but overall the comments I read in various Linux forums when searching for help are positive in nature. In fact, I very rarely need to ask for help because it's almost always possible to find a solution from helpful Linux users by googling.
 


LinuxLifer

New Member
Credits
192
Nice try Vrai, but I tried various themes before settling on one and the icon problem persisted.

G'day Wiz, and it is another beaut day in my part of Oz.
Synaptic is one of the first applications I install and History shows many installed packages.
I don't consider your posts in any way condescending or patronizing. You don't know what I know or don't, so you need to ask. No worries. Some smart asses post sarcastic or overly cryptic comments, but overall the replies I've read on various Linux forums are much more positive and repectful.
 

LinuxLifer

New Member
Credits
192
I tried uploading twice earlier today, but it didn’t work. Here goes again.
Nice try Vrai, but I tried several themes before settling on one and the problem icons persisted.
G’day Wiz, and it is another beaut day in my part of Oz. Synaptic is one of the first applications I install and History shows a lot of installed packages. I don’t consider your posts in any way condescending or patronizing. You don’t know what I know or don’t know, so asking appropriate questions is reasonable. So no worries! Some smart-ass posts I’ve read on Linux forums are sarcastic and overly cryptic, but overall I find them to be patient, respectful, and helpful.
 

wizardfromoz

Super Moderator
Staff member
Gold Supporter
Credits
6,052
Knew you were a bloody Aussie :), we can start a Commonwealth Club here, lol.

shows a lot of installed packages
Yeah, mine came down to about 63 in the end. I've put on GParted but not Synaptic yet, wanted to run updates and establish where they went. No miscreant panel appeared, though.

I typically run about 60 - 80 Linux, and my protocol for most after install is to

1. Install Timeshift and configure it
2. Take a full, on demand snapshot
3. Clear the cache of (in Debian-based, and equivalent with RPM-based and Arch-based) .deb files with sudo apt-get clean
4. Run updates, reboot and see that all is well
5. Run Timeshift
6. Populate the install and panels with my fave apps
7. Run Timeshift

Under that regime, if I lose a Distro, or changes are not to my satisfaction, I can be back in business in as little as 10 to 15 minutes by running a Timeshift Restore.

If you follow something like that, you can identify the updates through

/var/cache/apt/archives

as well as other means.

The fact that, if I read you correctly, the unasked for panel appeared at first launch following a clean install tends to rule out many options we'd normally pursue, and makes some of what I am saying superfluous or irrelevant.

I'd put on Synaptic, but I will leave it until after I restore, because as part of the updates, Xubuntu installed the Snap Store and took away access to the perfectly adequate Gnome Software, who knows why?

I'll restore and do some further research and come back to this Thread if I have something relevant or illuminating.

Before I close

1. haven't forgotten your question on Mint Xfce and Xubuntu, will address elsewhere and link to there from here so as to not go off-topic

2. If you get a chance, swing over to Member Introductions and say hi and tell us some of the LinuxLifer story - there you'll meet a few of The Gang, more Aussies and includes my mate Brian, who is from NSW, and is your age or very close.

Cheers

Chris
 

LinuxLifer

New Member
Credits
192
Timeshift is one of those meaning-to-do things that I will get around to soon. I do back up to a NAS though.
I don't recall the weird panel/icons being there immediately after the install but think they appeared after updates but before installing most apps. That's vague and makes diagnosing difficult.
Now that you mention snap, the icons may have appeared after I installed it (which is the only way I was eventually able to get a functioning Foobar2000 after unsuccessful attempts with Wine and PlayOnLinux). I've done a File System Catfish search and in addition to the various cairo-related packages I mentioned earlier, there are also cairo items in the snap directory and many cairo .png and .svg files in /snap and /usr/share. But these image files are all cairo-clock and aren't anything like the problem icons, so another dead end.
It's a difficult one to google but before joining this forum and opening this thread I tried a bunch of different keyword/phrase combinations with no luck. So it appears that this issue may be unique to my computer and seems to suggest that some ghosts from the past have appeared to haunt it.
 

LinuxLifer

New Member
Credits
192
Sorry for misunderstanding. Searching Synaptic with "dock" shows no installed applications. Searching the File System shows some dock packages associated with snap. None of the icon images are those of the problem icons.
 

LinuxLifer

New Member
Credits
192
Problem solved. In Session and Startup I saw something called Warlock Bar, which Google revealed to be wbar -- a launch bar. Synaptic showed that it was installed. I had previously searched Synaptic for "dock", "panel" and all the apps linked to by Loren, but hadn't thought of "bar". Uninstalling and rebooting removed the problem.
Thanks wizardfromoz for your help and info about Timeshift, which I'm now using.
 

wizardfromoz

Super Moderator
Staff member
Gold Supporter
Credits
6,052
Hey that's great news, "LL" :)

I LOVE it when Members solve their own problems - you'll make us Helpers redundant and I can get on with brewing my home brew and tinkering with my Linux.

Any probs/questions with Timeshift, see me at my TS Thread mentioned in I think #13.

Stay safe

Wiz
 

LinuxLifer

New Member
Credits
192
Wiz, your comment about Linux Helpers becoming redundant was good for a laugh. Although stability and reliability have improved considerably over the years, you’d well know that Linux OSs continue to be riddled with problems. The situation I faced illustrates one of the countless issues: there is no easy way of discovering exactly what Applications are installed on the system. The Application Menu is unreliable. Wbar was installed, but not in the Menu. Nemo was in the Menu, but had been successfully uninstalled — among other such anomalies. Synaptic reliably lists what’s installed, but try finding the actual Applications among the thousands of other packages. In macOS you open the Applications directory and see precisely what’s installed. If it’s not installed, it’s not there. To create a shortcut, you simply pin it to the panel.
Linux developers who promote their OSs as user-friendly replacements for Windows and macOS are having themselves on and not doing any favors for potential users or Linux. Sure, Linux has many advantages over the other OSs (which is why some of us use it) and promoters should emphasize these. However, they should also point out that users should expect to encounter far more malfunctions and be prepared to put in considerably more time and effort into maintaining a functioning computer system.
Linux developers keep churning out what are largely clones of existing OSs and Applications. I have a huge music collection, mostly classical and organized based on Composer. I’ve tried most of the numerous Music Players available for Linux, and almost none recognize the Composer tag (though no one ever tell you this). Several are touted as being like Foobar2000, yet none come remotely close to it in terms of functionality and customizability. I’d been using it under a Wine installation without any problems for several years. After the install, it was impossible to get it to produce sound, despite installing using Wine, and PlayOnLinux, and WineTricks. Eventually, installing using Snap solved the mysterious problem that no one on the Foobar forum could help resolve. At least following this OS install it was easy to get audio from other apps. Following most previous fresh OS installs, getting audio to work has been a nightmare.
Pity there isn’t more focus on improving what already exists in Linux. It seems a forlorn hope that there will ever be an OS that combines the customizability, flexibility, Workspaces, choice, no fee, and other virtues of Linux with the stability, reliability, simplicity, and low maintenance of macOS. So I’m resigned to having Linux on one computer and macOS on another. The best, and worst, of both worlds.
Apologies for the rant, but as a long-suffering Linux user I feel justified.
Cheers
LL
 

wizardfromoz

Super Moderator
Staff member
Gold Supporter
Credits
6,052
Wow, nice rant ;)

I love it, as I have shown.

Apologies for the rant
No need to apologise old son, we enjoy a good rant here, keeps us on our toes, and promotes deep thought :)

I have to jump around a bit in the 50 mins or so I have left before I start to cook tea for us.

I really think you should consider pasting most of the above either in General Linux and I'll pin it, to keep it current for feedback and not disappear off into the boonies, or else in Off Topic and we can gasbag about it to our heart's content.

If you're NSW, you'll be on silly time, now, I expect, and I'll cater to that if I can.

Hey Brian @Condobloke have a read of this one? :D

Chris
 

LinuxLifer

New Member
Credits
192
Do whatever you think is most appropriate. I'm fairly critical by nature, but I think in a logical, evidence-based, hopefully not too biased way. I'm prepared to participate in such a general discussion of Linux when I think I may have something worthwhile to contribute. However, I doubt anything I've written hasn't been said before by others much more knowledgeable than I.
Yes, I currently live in Port Macquarie but I keep unusual hours since I trade shares on the Toronto Stock Exchange during our night. That's my main hobby/occupation these days, but have done some home brewing in the past and might get into it in the future. Tinkering with Linux is pretty much inevitable if you have a Linux OS but it's something I'd prefer to avoid once my system is set up as I want. But dealing with Linux problems (and trading shares) is definitely good for the brain.
 


Members online


Latest posts

Top