Useless icons on screen following installation


New Member
Sep 12, 2020
Reaction score
Following a fresh install of Xubuntu 20.04.1, a strange vertical panel of 8 icons appears on the right-hand edge of the screen (screenshot attached). When I hover the cursor over any of them, it enlarges the icon and displays a label. From top to bottom they are: Config, Web Browser, E-Mail, Image Viewer, Audacious, Leafpad, File Manager, and Terminal. Left or right clicking on them does nothing except for Web Browser, which opens Firefox. I don’t have Leafpad or Audacious installed and it seems that the other 5 icons also refer to applications my system doesn’t have. I’ve been using Xubuntu for several years and the icons aren’t like any I’ve seen on XFCE before. They can’t be moved and there’s no context menu.
I’ve performed a bunch of cleaning and have been unable to get rid of them. Any help on how I can remove the useless things would be much appreciated.


  • problem_icons_screenshot.png
    489.6 KB · Views: 519

Try running sudo apt info cairo-dock and see if the program is installed.

I know that there are other dock programs available, but I can't think of any right now.
What happens if you RIGHT-click on the items you don't want? Does that allow you to remove them?
G'day @LinuxLifer and welcome to :)

If that screenshot is your entire desktop, then what is showing at right is your xfce panel.

Do you have access to Synaptic Package Manager? If so, you can check there to see that the package


is installed, there should be a check mark or a highlight colour in the box at the left of the pane.

Also look at bottom left of the Synaptic window for any reference to broken packages.

If you want to try reinstalling the panel to a working state, best option is at Terminal

sudo apt-get install --reinstall xfce4-panel

# That's a double dash before reinstall ... Wizard

Let us know how you go


Chris Turner
The screenshot is only part of my desktop. I do have XFCE panels on the bottom and left of the desktop. The problem icons are something different. Synaptic shows no broken packages.
I appreciate the responses, but this problem appears to be something deeper. I've been using computers for 25 years and various Linux distros and DEs for over a decade, so obviously have encountered many issues. But this is a new and particularly strange one. Fortunately it isn't serious and doesn't impact functionality. Merely annoying and a puzzle I'd like to solve.
In your Home folder/partition, under


... does the number of launcher folders match what is on your 2 preferred panels or are there extra?

No extras. Another thing that suggests they aren't XFCE panel launchers is that they appear to be animations in that they enlarge when the cursor hovers over them, which I seem to recall cairo-dock icons doing when I tried it out years ago. My XFCE panel icons don't do that but show a pop-up window naming the app and giving a brief description. I very much like the XFCE panel and it's a major reason I use that DE.
What about a search in Synaptic for anything under "cairo" that's installed and shouldn't be?

Do you use Timeshift?

That's interesting and could be a clue to solving the puzzle. Although cairo-dock itself isn't installed, there are a number of other cairo-related packages: gtkk2-engines-murrine, libcairo-gobject-perl, libcairo-gobject2, libcairo-gobject2:i386, libcairo-perl, libcairo2, libcairo2:i386, libcairomm-1.0-1v5, libpangocairo-1.0-0, libpangocairo-1.0-0:i386, libpixman-1-0, libpixman-1-0:i386, python3-cairo, python3-gi-cairo. Any idea why they might be installed and if it's safe to remove them? I have no intention of ever using cairo-dock.
I just installed Timeshift a few days ago -- after the appearance of the problem icons -- but haven't used it yet.
I'll have to sign out soon to cook tea and now I'm getting my missus a cuppa - haven't got an Xubuntu in my stable at the moment, writing this from Linux Mint 20 'Ulyana' Xfce, I'll take a look in Synaptic and see if I come up with any goodies.

Suggest wait until the unwanted dock issue is solved, then run Timeshift.


Looks like we might be onto something.

Nah, looks like a Red Herring :(. Those same packages are also installed in both of my Linux Mint Xfce's 19.3 and 20 (which is based on Ubuntu 20.04), and also they appear in my Manjaro Xfce, so they are there either in anticipation of an install of Cairo, or as dependencies for something else.

If you are going to delete them, then I would advocate running a full, on-demand snapshot of Timeshift, so that if something goes pear-shaped, then at least you can roll back to where you are now.

On Timeshift, Linux Lite have a short tutorial here, and ItsFOSS here.

There is also my Thread on Timeshift

and you can ask any Timeshift questions there.

With Xubuntu are you using 20.04 or 20.04.1?

I have just downloaded the former, and am preparing to install to see if I can gain any knowledge there.


Using 20.04.1. Should have a chance to familiarize myself with Timeshift this evening and consider whether to delete those packages.
Using 20.04.1.

Ta, I've put the right one on, now.

Below is my desktop a few minutes after completing the install.



As soon as I established the install was successful, I installed Timeshift for the Software Centre and took a snapshot, and then put a couple of icons on the default Panel, Panel 0, including my browser of choice, Waterfox, to communicate here.

No unusual panel/dock appears, but I noted when I first entered the Desktop Software Updater had something like 123 updates to install. Took a quick browse through them, but did not immediately identify a potential culprit. I have not installed them yet.

Do you remember if you installed them when prompted?

Last edited:
Thanks Wiz. I don't recall having to install that many updates, but could be wrong. The install didn't go very smoothly mainly due to boot/grub problems, so I was preoccupied with fixing those. However, once I resolved the issues I would have updated more or less automatically as a matter of course.
For some reason my OS wouldn't upgrade from Xubuntu 18.04 to 20.04.1, and the clean install was more messy than clean. Now that everything's working well and set up as I like, I'm a bit hesitant to risk further hassles to try to eliminate the problem icons. Maybe Timeshift will prevent problems but I'm yet to look into that.
So I'm still undecided what to do. Might give it a few more days to recover from the install problems and see if someone might shed further light on the issue at hand.
Changing the subject, how would you compare Xubuntu with Mint Xfce? A few years ago I used Mint for a couple of years and liked it, but that was with Cinnamon which I don't like nearly as much as Xfce. Seem to recall that the newest versions of some apps didn't work with Mint, probably because of its time lag. Though I might be confusing it with Debian, where it was a definite problem. After experimenting with many distros, Xubuntu and Mint Xfce are the only ones I'd use, predominantly because of their relative user-friendliness and the amount of help available due to their popularity.
Those same packages are also installed in both of my Linux Mint Xfce's 19.3 and 20 (which is based on Ubuntu 20.04), and also they appear in my Manjaro Xfce, so they are there either in anticipation of an install of Cairo, or as dependencies for something else
There is an unrelated library called Cairo IIRC.
:)Lol, you caught an old fellow by surprise, Loren, I was googling it up

Cairo IIRC

Then I thought outside the box - If I Recall Correctly?
@wizardfromoz @LinuxLifer
After re-reading this thread and looking at the OP's first screenshot I got to wondering;
you don't suppose that is just a "Theme" do you?

It should be easy enough to go into the 'Appearances' app and change the theme as a test.

Just a thought. ¯\_(ツ)_/¯
Lifer, G'day

However, once I resolved the issues I would have updated more or less automatically as a matter of course.

As we do :)

Testing your memory again

1. Synaptic you have ... now ... but Synaptic and GParted are not installed by default, it seems.

So would you know if you installed Synaptic, then ran updates, or vice versa?

If Synaptic was installed first - are you aware of its History function?

(As an aside, and for other Members with Linux experience - don't ever think I am dumbing down or treating you as silly - to me, the journey to Linux knowledge is like a freeway with many lanes. Some of us travel in the same lane every day and others in a different lane every day. If we do not change lanes, we may never encounter a pothole or bump in the road, nor encounter what is following on ramps and off ramps. So I try to make myself acquainted with what you know, and don't know :)).

While writing this, I note friend Vrai's input, and certainly worth a thought :cool:

More soon


Members online