Trying to install Linux Mint 20.2 Cinnamon (64bit) on Dell Latitude 7480 (on internal M.2)


New Member
Dec 22, 2021
Reaction score
Trying to install Linux Mint 20.2 Cinnamon (64bit) on Dell Latitude 7480 (on internal M.2) and it fails shortly after starting the installation process with: Cannot create file system on partition #2 /dev/nvme0n1

This is with all default options, including completely erase the whole hard drive.

I also tried to manually wipe the hard drive using GPARTED prior to launching the installer and the exact same thing happens.

Help please?

Last edited:

G'day marc, Welcome to

Did the M.2 actually have any info on it to erase ?

Did you format the M2?......(ext4)

In normal circumstances, the Linux installer will wipe the target drive for you, without you having to do anything at all.

How sure are you that the installer is targeting the M2 ?

Sorry...lots of questions !...not much in the way of answers yet.
Hi, thanks for trying to help me switch to Linux.

The M.2 used to have Windows 10 on it before, but like I said, I removed all partitions with GPARTED and the installer still fails shortly after starting. Also, the Linux installer asks if I want to completely erase and reformat the drive and that option was checked on another try, but both tries failed with the same error after the same amount of time.

The installer is indeed targeting the M.2 as you can see in my OP ("/dev/nvme0n1"). There is no mechanical hard drive or any other hard drive attached to that laptop, it only has a single NVMe (M.2) drive and yes, the installer is targeting that drive.

After the error occurs, it only gives you an option to reboot the computer and after a reboot (still from the live USB stick) I can see that the installer indeed partitioned the M.2 so I know it targeted the correct drive and began the installation process.
Am i understanding you gives an option to reboot after the error ?

If so......reboot......but take the usb stick out....
OK but the installation failed 5 seconds after it started. Of course, it's looking for a boot disk and doesn't boot. I may be a Linux newbie, but I'm not computer illiterate. I've used computers for over 30 years.

In your BIOS, before you select the boot device for example, look for an "Intel RST" or "AHCI". Which ever one it is on, change it. (I always forget which one is which - but whichever setting it is on, change it.)

Try that before going too much further. You may also want to switch to legacy boot while you're in there, unless you need it for something.
SATA operation is already on AHCI. You want me to put it in RAID mode? (For this post, I have not set it to RAID mode)

Alright, so I changed UEFI to LEGACY in the BIOS and now the Mint boot options menu is different, it has graphics in it. Before, in UEFI mode it only had a black and white text menu. After booting in LEGACY mode, I launched the installer and everything is absolutely the same, the same error happens shortly after the installation process started:

Cannot create file system on partition #5 /dev/nvme0n1

I then rebooted and tried LEGACY again but WITH COMPATIBILITY MODE. I've been sitting on a kernel debugging screen that doesn't move for at least 5 minutes. Is it supposed to go to the desktop at some point? I figure if the non-compatibility mode has zero issue booting to the desktop, the compatibility mode surely won't have any trouble either... or is it?
Last edited:
No, don't switch to RAID mode. I'm pretty sure. I mean, you can try it and see if it works and then change it back if it doesn't. It's worth testing as I can never remember which is which. I'm at the wrong device to check my own settings, but I can if the thread gets deep enough.

The error you're giving is vaguely familiar. There was a fairly recent bug that had something to do with this, but I think it was only in testing versions.

Can you manually partition (GParted or Gnome Disks should be on the live USB) the NVMe to a single Ext4 partition?
It doesn't look like Mint Linux can install the file system, but it can create the empty partition and set the partition type, but it just cannot create the file system on it. Make sure to check out all screenshots.


  • IMG_4675.JPG
    357.2 KB · Views: 440
  • IMG_4676.JPG
    614.7 KB · Views: 444
  • IMG_4677.JPG
    559.9 KB · Views: 407
I have two thoughts on this, a corrupt download/bad burn of install medium [did it all work OK when it ran live for testing]
the other is the NVMe is not being correctly identified [a moderately common but varied problem]
Had a very similar problem with Linux Mint Cinnamon install as well. Actually the same with the exception of CODECS error. I did all the the changes in BIOS as well + RAID. And it failed as well. My Fedora 35 workstation had complete failure earlier yesterday. and Im a Newb as well. But ive not had any issues with previous distros ive tried on. Im on a Dell Vostro 5402 1TB, 32Gb RAM,i7, NVidia MX330.
Of course, it's looking for a boot disk
this would lend credence to @brickwizard's suggestion that perhaps a bad burn of the install medium is responsible.....Does it run ok as 'Live'..?

A corrupt download is quite possible...did you verify the download ?

Check the installation medium in another computer to see if it is the download or burn of your live usb that is at fault rather than the hard disk on your pc

Just a late thought.... instead of choosing to erase win10,etc etc.... choose the "Something Else" option. This will allow you to manually partition the disk.
Last edited:
I am under the impression that some people do not bother to read the thread before replying. It does run perfectly fine from the USB live stick and there is no Windows on the hard drive. It was erased using multiple options, including from within the installer, plus manually using GPARTED and as you would see if you took the time to read the thread, it removes the partitions and creates new ones correctly, but then fails at writing the file system (take a look at the screenshots that I posted yesterday).

To me, it seems like Debian does not like the NVMe controller or something like that. Windows 10 had no problem with it and just to prove it, I went ahead and reformatted the M.2 and reinstalled Windows 10 from scratch and it just works flawlessly.

Looking for another Linux distribution that has a better NMVe driver, any suggestions? [inb4 somebody shouts Ubuntu, which obviously would make zero sense here]
Ok your download is ok, then the problem is with the NVMe , no point in suggesting another distribution as if you google NVMe won't install linux ... you will find the problem is across the board,

as you have ubuntu based distribution , try this..

In order for the Ubuntu Installer to see a internal NVMe SSD on some machines you may need to make the following change in the system BIOS.

  1. Boot into the BIOS Setup on your machine.
  2. Find the System Configuration in the BIOS Setup.
  3. Find SATA Operation and select AHCI.
  4. Restart the computer and the Ubuntu installer should now detect the NVMe SSD.
Again, I'm sorry, but can you please read the thread before replying? The SATA operation is already set to AHCI and the NVMe M.2 is seen and formated by the installer, no problem. The problem is that it then cannot write the file system to the partitions it created. This is all written above, we're repeating ourselves here.

I am interested in this sentence tough: "no point in suggesting another distribution". Are you implying that there is NO Linux distribution that reliably supports NVMe at all?

I came across this, BUT it is only for changing to a single NVMe and removing any sata drives on a Dell laptop.

Solved it. Disabling "SATA Operations" in BIOS fixed it.
In BIOS (F2)
System Configuration --> SATA Operation
change "RAID On" to "Disabled"
(Disable =The SATA controllers are hidden).
After you change your bios/uefi settings and save/exit your system automatically reboots?
Alright, so since Debian distributions are seemingly useless on NVMe Dell motherboards, I am now trying another Linux branch (Manjaro xfce 21.2rc1, which is an Arch based distribution). The USB live stick not only booted faster than Mint and Ubuntu but it also installed flawlessly in just under 4 minutes. So I guess if anybody has trouble with Dell NVMe controllers, then go for Arch?

Problem solved.
Huh... I have Lubuntu installed on an NVMe and, like you, it installed in just a few minutes. (I'll never buy anything but NVMe until the next big thing comes along. The results were that dramatic.)

But, it's not a Dell...

Good to know that you got something installed. It's something to note for future questions.

Members online