Trying to create Ubuntu Server install on USB, GRUB is opened, OS will not run.


Oct 23, 2020
Reaction score
I am trying to create an Ubuntu Server install on my PC but every time I run the USB after entering the BIOS it does not start the chosen OS like it used to, now GRUB pops up instead. I tried wiping the USB multiple times then flashing the OS to it and running it again and the same issue happens each time. Not sure what to do here...

Any help is appreciated, thanks.

Well, let's start with the basics.

Did you verify the ISO and what did you use to write the image to a USB drive?
I just used the Pop OS default USB flash tool. I was not asked to verify the OS. It worked once, then I uninstalled and wiped the drive, tried it again and now it does not work.
when you wiped the drive, did you reformat it as any particular file fat32, ext4, etc etc ?
If it worked once and didn't work a second time, that's unusual. I'd download the image, verify the image (it'll tell you how to do that where you get the image from - usually), and write the image anew with Balena Etcher.

I looked and the SHA256 Sum is listed on the download page.
Apparently it is nothing to do with the USB drive. I tried a different OS from a different USB drive and it did the same thing. Still not sure why this would be happening.
Why did you wipe the drive ?

Something has happened in the 'wiping' of the drive

What did you use to wipe it?

What shows on the Grub screen ?

At first I thought it was something to do with the drive so I tried deleting and flashing It again. The other drive already had Ubuntu Desktop ISO on it so I decided to see if it would work but it did the same thing.

I just used the Disk Utility and Gparted in PopOS.

Members online