Tablet PC: Pen-Monitor & Remote Mapping, WINE Pen Pressure & More <partially solved>

Sasha-Jen

Member
Thread summary:

Problem: Output Digital Audio Workstation audio into a virtual input/output to input into other programs
Problem: Working tablet has not way of mapping only to its own screen
solution:
In terminal:
'xrandr' to identify the tablet monitor (for me, 'HDMI-0')
'xinput list' to get the pen device id ('xinput' lists some but not all input devices -- the pen was absent from that command result!) ( for me the pen id was 23)
'xinput map-to-output 23 HDMI-0' and the pen was set to only the tablet monitor.

Problem: need to remap shortcut remote keys
solution: pending
Problem: Medibang install through WINE but a) has no pen pressure and b) pop-ups and drop-down menus come up on the wrong screen no matter where the main window is
Problem: UI elements (e.g. firefox) have their bottom go behind the panel when maximised rather than bordering with the panel.
Solution: Pending
Problem: Glitchy mouse buttons
Solution: Pending​

Problem: some solutions are temporary and are scrubbed on ending the current session
solution: pending​
----------------------------------------------------------------------------------------------------------------------------------------------
Hey, second time posting here.

So after preparing to switch to linux for the past months I just can't tolerate windows anymore so I created a Linux Mint 19(.1?) MATE USB. I then proceeded to test and play around in a live boot.

Long story short: all hardware works great! All of it! :D

But there's one (er, 2 I guess) things: You can read what the 2 pieces of hardware are in the thread title, and its the fact I don't know how to change the settings on them. I need to change the tablet to only use its own screen when using the stylus (rather than all 4 monitors being part of stylus use on this 15.6 inch space), and I need to change what each button on the shortcut remote corresponds to so that can be the way I like/use it in windows.

In windows installing the drivers from XP-Pen's website will also give you a GUI each for settings. I've gone on youtube and seen videos on graphic tablets on linux mint from previous versions (17 etc rather than 19) and they have a "graphics tablet" GUI in the linux mint setting. 19 doesn't seem to have that (at the very least, not on a live USB session)?

The youtube videos show that mint GUI is the place to change all the settings I would need. Also, even if I had that GUI, there is still the question of the shortcut remote?

XP-Pen is working on their own tablet driver for linux but a) it is currently in beta and b) not yet for my tablet model. So I can't download their propriety driver not for the driver itself but only to give me the GUI like they do in windows. That would also just be the tablet settings too, not the remote.

I NEED to be able to change the graphic tablet settings at least before I replace windows with linux on my boot drive (I can use my actual keyboard for shortcuts over the remote, less ergonomic though).

Any advice? Kinda annoying to see these youtube videos with previous mint versions with this "graphic tablet" GUI in the mint settings menu. Did they really remove it?

I can almost taste dumping windows forever for a better Linux mint, but it is such a tease; especially when my tablet is working fine in linux mint, pen pressure and all. I was more expecting a driver issue to stop me if I was to be stopped -- but the removal of a mint setting GUI? Really?
 
Last edited:


Sasha-Jen

Member
So, by watching a few more youtube videos I spotted that an installed Linux Mint 19 had the graphics tablet icon for the settings menu under preferences. I am aware that when you install it there is a 3rd party check box to accept that will install further default apps and such; I didn't expect the live boot to include things like display settings without graphic tablet settings tbh.

Is my conclusion true that more options open up on an installed Linux mint than a live boot? Would options for the key remote also open up on an installed system? I still don't want to install without confirmation.

Unrelated to the exact issue, but still absolutely to do with my adoption of Linux, I'm glad to say I only have 3 programs I will be needing that aren't in the repository (idk for sure, but that sounds low to me for a windows user switching to linux for the first time?)

One is NordVPN which has a native linux manual download and I have managed to install and get working in the live USB boot no problem. The next is Medibang paint which will go through WINE (I have tried Krita and I don't like the UI. Like REALLY do not like it!). Is it similar to what I've said about the graphic tablet settings in that it is usual to have WINE problems in a live USB boot but be fine once the OS is actually installed? I know medibang works through WINE as there are videos out there showing it.

The third is Reaper media DAW which claims to work fine through WINE and also has experimental linux builds. I managed to get the experimental version working easily without needing to try through WINE. The issue is I use V-B virtual audio cable in windows to put the Reaper output into and then any in-game, discord, teamspeak etc mic input the other end. Alternativeto.net has 3 options that got my eye:

  1. Vsound Virtual audio loopback cable: this sounds like a direct replacement no strings attached. The problem is despite download links on the website, there seems to be no actual download?
  2. Jack audio connection kit: It sounds like it would do the job. "audio connection kit". It's even described as connecting programs to programs with audio. But it comes across as more for professional audio work and I do not see any option or anything despite several youtube videos for the simple thing I want: to output my DAW audio and input as a mic into other apps' comms.
  3. Pulseaudio: Exact same problem as Jack: it sounds like it would do what I need, but it seems to be for way more complex and professional audio work. Again, even after several youtube videos I can't see any way to make my Reaper output turn into an input for comms like windows' V-B Virtual audio cable does.
 
Last edited:

Sasha-Jen

Member
Alright, so I've got closer to getting a virtual audio input to work by a combination of information on two webpages:

https://www.onetransistor.eu/2017/10/virtual-audio-cable-in-linux-ubuntu.html
&
https://unix.stackexchange.com/questions/174379/how-can-i-create-a-virtual-output-in-pulseaudio

I took from the first the commands to successfully create the Virtual_Sink input/output device that shows up in sounds settings on the live USB boot of Linux Mint. The second successfully gave me a virtual "loop" device. Reaper media successfully has my microphone as input and the virtual loop as output (the virtual sink doesn't appear in Reaper despite if it did cutting out the need for the loop I would think).

Unfortunately, that is all I've done so far despite trying. I've attempted both the PulseAudio and JACK programs and I see no way to connect/redirect the loop output into the virtual sink input/output. Even if I did, the virtual sink isn't coming up as a microphone input in Reaper or teamspeak (guinea pig testing app). Although my physical microphone also didn't come up in teamspeak despite it doing so in Reaper.

Haven't got any closer to getting WINE to work in the live USB boot to test Medibang, nor any new info found on why the live USB boot lacks the graphic tablet settings menu while videos of installed Linux Mint has it.
 

wizardfromoz

Super Moderator
Staff member
Gold Supporter
I'm just watching this with interest, as you systematically research and solve your own problems :)

G'day Sasha, seems like I get you on weekends (well, mine).

Did you give any thought to what I suggested elsewhere about VMs, or did you just want to be rid of The Dozer entirely? (wouldn't blame you :p)

Is my conclusion true that more options open up on an installed Linux mint than a live boot?
Yes and no, or perhaps "How long is a piece of string?".

Live testing is only as good, in some ways, as the currency of the software incorporated into the .iso burned. That can include older kernels in place at that time, having less support for drivers.

Being LM 19.1 that you are looking at, that may not be such an issue.

Given that you are obviously exploring capabilities, and for the larger part being pleased with the outcomes, then you could go the step further and install, or you can explore an in-between option, which is Persistence on a stick. Persistence enables changes to be saved to the stick, which changes will survive a reboot. Persistence does not support kernel upgrades, but other than that, it is pretty good.

If you wish to explore Persistence (have a search under "linux persistence" and you'll get the idea), Unetbootin is a logical choice and cross-platform, to burn your LM .iso.

Under ordinary methods, you can add 4GB of persistence to the stick (a limitation of MSDOS, not Linux), but we have ways and means of "cheating" on that and adding more, if you need.

Be aware, as always, that USB testing is not as quick as a full install, in terms of performance.

Cheers and

Avagudweegend

Wizard
 

Sasha-Jen

Member
I am currently writing this on an installed Linux HDD. But don't congratulate me yet!!!

You see, several weeks ago I spring cleaned and I had the idea of taking the HDDs out of the 2 old desktops that are in storage (just a bit of unimportant trivia: One of them was a Windows XP 00's era desktop! Both HDDs work fine.) and putting them in this desktop for extra storage;I didn't need them, but extra storage is extra storage and I know what folders I'd like to separate from my SSD.

I formatted them in windows 10 but since I knew I was switching to Linux soon I didn't store anything in them. So this install is in a spare, unused HDD. I didn't want to dual boot so I am being very careful here.

Anywho, I can confirm that I have no settings menu for graphics tablet despite seeing it in Linux mint youtube videos. That's terrible news and I don't know where next to go.

I've yet to try the HDD boot WINE medibang install (simply because I installed before dinner, and guess what else I am doing while typing this), so I guess I may edit this post in a while with that update.

At this point, as I have already gone out my comfort zone by installing Mint on the HDD when that was not my plan nor desire, even if I will wipe this HDD and actually replace windows 10 on the SSD for the true install, I'd now like advice on the graphics tablet, shortcut remote, and virtual audio issues.

I understand the thought of "they've started figuring it out themselves so leave them to learn" as that is better than just being told "put these commands in the terminal and hey-presto you don't even have to know what I told you to do!". But let's not leave me to trail and error everything in my first exploration of Linux :p
 

Sasha-Jen

Member
I've got Medibang installed through WINE. I don't think it was a USB boot vs install issue. Before I was following youtube tutorials while this time I went to winehq and followed the direct instructions there. When I installed Medibang it came up with needed packages which I think installed them from winehq but recommend to use my distros package manager? I let it install automatically as searching for these in the package manager gave tonnes of results and I didn't know what specifically wine needed. All wine said was it needed "mono" and "gecko" (gecko was asked for twice for some reason).

So, great right? Well, the pen pressure doesn't work in Medibang. It works in Krita so it seems to be a WINE issue. Which is annoying since youtube videos show it working just from WINE install. While it is obviously a WINE issue, can it be to do with my graphic tablet model? Like, do some graphics tablets work through WINE art programs better than others? Or if pen pressure doesn't work for one tablet in a particular WINE'd program, it won't work for all tablets? Knowing the answer to this would make it so much easier to find the solution.

In other non-news, The virtual audio and tablet/remote settings are no closer to being solved. This is all getting to get a bit complex that as a first-time Linux user this is where I'd like advice to point me to helpful places.

There's also very small issues cropping up that are tolerable (for now) and can wait. E.g I can't press/hold the MMB to scroll up and down, nor does the 2-click button work in my mouse in Linux either. Yet, the 2 side buttons do. These are so insignificant (for now) that I haven't even searched for the problem, but I'm just pointing out they are there.
 

wizardfromoz

Super Moderator
Staff member
Gold Supporter
But let's not leave me to trail and error everything in my first exploration of Linux :p
Don't worry Sasha, I am sure someone here will have your back :)

I performed a search here under "tablet", and previous Threads were mostly divided between Getting Started and Hardware, with one Linux Other.

I am inclined to move this to Hardware, as a Thread by Member @yogib33r (Stephane) actually featured an older, I think, xp-pen.

I regret that tablets, and the operations you wish to perform, are currently beyond my paygrade.

If you agree with Hardware as a venue, I'll make it so.

Cheers

Wizard
 

Sasha-Jen

Member
Edit: @wizardfromoz I see you posted while I was typing this post, haha. Moving to hardware sounds fine since, as I just typed (but readers of this post are yet to read) that only the graphic tablet + Medibang WINE pressure sensitivity is left before I make the switch permanently.

I got the virtual audio working. With virtual_sink, Reaper DAW & PulseAudio. I re-read the 2 linked guides above over and over and it dawned on me how to do it. Seems I had the right info and it just needed to click in my head.

Now, I know I've already said "I'm not sure where to go from here" already then turned around and said "oh yeah I done it", and I think I will be able to find something on getting pen pressure to work in Medibang through WINE; but I do not think I will find anything on the tablet/remote settings.

Every piece of info on how to change graphic tablet settings in Linux mint points me to Settings -> preferences (or hardware in earlier mint versions I think) -> graphics tablet. And that opens up a settings window. I simply do not have that. I found info on installing all libwacom packages (wacom ofc being the grand-daddy of the tablet marketplace) and I installed every-single-one of the packages with that prefix. I also came across xsetwacom commands for the terminal starting with xsetwacom --list devices. As you can imagine it is about controlling wacom device settings in the terminal; but not XP-Pen devices.

I am legit thinking about looking through Linux mint changelogs to find when they took out the "graphics tablet" settings menu, since it seems that they did. maybe beside it they have a "x inclusion replaces it" or something. I did verify the ISO file too before putting it on the USB so I know I have 19.1 MATE for sure. I literally lack a settings menu that I need before I permanently switch to Linux which I'm finding info for and being pointed to from everywhere.

FYI the last 3 posts have been from the HDD Linux boot, just thought to say.
 
Last edited:

Condobloke

Well-Known Member
https://forums.linuxmint.com/viewtopic.php?t=259576

Driver does not support Artist 16
https://www.xp-pen.com/download/index/cid/36.html
+++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++
CONVERSATION with XP-PEN




12 messages
Today


English tech support - we are here to help!
10am-6pm (PST) / 6pm-2am (PST)
Monday-Friday
I am in south east asia...I have no idea what time it is for you
Thank you for contacting us! Please add your name, email, and tablet model in the following fields to send your message.

Thanks! If you are able, please provide any further details that might help us with your inquiry. As soon as an agent is available you will receive a reply here or by email.
I am attempting to use my tablet with Linux. Not much success. Is there a particular distro of Linux that will support me ?
Ann

XP-Pen English Support

joined



Hi, are you trying to use artist 16 on linux? It's not compatible.

not at all ?....no workup happening to provide a driver ??


https://www.xp-pen.com/download/index/cid/36.html


The driver doesn't support artist 16
oh dear....that has screwed that idea !!
So...i really need to have .. Artist Display 12/15.6/13.3
Deco 01/02/03
Star 03/04/05/06/G430/G540/G640/G430S
Star03 Pro/G540 Pro/06C
...to be able to use the beta driver....and I need to be running Centos, Mint, Ubuntu Linux....to get any joy


Yes, the driver we have can only support the listed tablet models. Sorry about the inconvenience.
ok....thanks Ann.
1 minute ago, seen


You are welcome. Have a nice day.
+++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++


So......not going to happen.

I thought you may have approached them first.

I do wonder if you can run windows 10 in a Virtual Machine and attach the XP to that ?...Someone with more virtual machine experience than me should be able to answer that.
 
Last edited:

Condobloke

Well-Known Member
Just to clarify the above.....

I would theorize that you would have whatever Linux installed......doesnt matter which one.

Then install a VM (virtual machine) ....install win 10 in that VM (you would need plenty of space...win 10 is a space hog)

Enable the use of usb ports in that win 10 (I dont know how to do this....but i believe it is quite common to do that....someone here will know how)

Run the tablet by plugging into the usb while you have the VM running.

That is rough....but it is the gist of it
 

Sasha-Jen

Member
Thanks for the info @Condobloke . Several forum posts came up in my searches but that specific one didn't. I'll do a proper read through of it tomorrow (first post today from windows here) but the one that says that MATE doesn't have the graphics tablet menu is right. I thought the difference between cinnamon and MATE were minimal and purely aesthetic, but here I am wrong. That's why I don't have the button to take me to the settings, and cinnamon 100% does.

As to there not being a driver for the artist 16, I knew their propriety beta linux driver wasn't for it. In fact, I thought I had to wait for it until one day someone let me know that the drivers are built into the linux kernal which made me realise you don't always have to wait for the manufacturer's propriety driver.

To be clear, the tablet does in fact work perfectly in Linux mint. The problem is I had no way to change the settings so that it wouldn't be mapped to all 4 monitors I have (including itself) but just correspond to its own screen. Same with the shortcut key remote: it worked, I can tell you that the bottom-middle button defaults to "p". It's just that there was no way to change the settings to make the keys correspond to... more useful shortcuts.

Unfortunately, the graphics tablet menu in cinnamon does not recognise the artist 16. Having gone through this learning experience I'm not too surprised as it seems the packages for graphic tablets are built for wacom; which also isn't a surprise as (stated before) they have the biggest market share, and XP-Pen is pretty unheard of.

Skimming through the forum link you posted as well as others I've read, it seems it is still possible for a kernal update to allow the menu to recognise the artist 16. Particularly that I read one thread where updating the kernal actually stopped their Linux from recognising their tablet as a tablet and removed the settings from the menu. I'm sure XP-Pen tablets aren't a high priority though.

As to why I attempted this without approaching them first is due that one advice that drivers were built into the kernal and "you don't have to wait for propriety drivers". Even if I knew I wouldn't have access to settings (and even if I was on cinnamon from the start to have the menu... let's assume) I've still learnt and confirmed a lot about switching to and using Linux mint:

  • I can work the repository and package manager (the former proved very easy, but it took a little bit of experience to understand what all these "packages" are and how to read through and understand them etc... the "libwacom" experience was when it clicked to me how to go about identifying what you would need when etc)
  • I can work WINE (rather than just be aware of what it does which was the extent of my knowledge on it before), a bit more complex than the repository, and the fact I struggled with youtube tutorials first and then succeeded by going straight to the website and its instructions showed me something.
  • While I've only touched a few commands, the terminal is easy. I've heard many people are intimidated by it. Now I have the experience of it. It's like the rumour of a mad dog turning out to be a tiny borking fluff ball in reality.
and probably more, even if small. Although the biggest probably is: I NEED to use cinnamon over MATE for the menu.

In fact, there's still something probably worth trying to figure out still: the pen pressure of Medibang through WINE. Krita proved that pen pressure works. There are 3 possibles I think:
  1. The lack of WINE'd medibang pen pressure is related to the non-identifying of the tablet as a tablet, as in, when the graphics tablet menu works with the artist 16, the pen pressure will work through WINE on medibang.
  2. It is about WINE, as in, even if the tablet settings were possible, the pen pressure would never work through WINE. I doubt this as I have seen videos of pen pressure working through wine on multiple art programs. But who knows, maybe there is a certain wine package for pen pressure that I don't have installed.
  3. It's about medibang through WINE specifically. Again, I doubt it due to seeing videos of pen pressure working. But this is also the most easy to test right now. I just need to install a few more windows-only art programs through WINE and see if pen pressure works in them.
Even for the two I doubt, it's still valuable to test just in case.
 

wizardfromoz

Super Moderator
Staff member
Gold Supporter
WOW, Brian (@Condobloke ), you really went the extra yards ... goodonyer. :D

one advice that drivers were built into the kernal and "you don't have to wait for propriety drivers".
Sasha, again, yes and no.

More and more drivers are being incorporated into the kernels all the time, but the migration process, if I can call it that, is by no means complete, and it may not be complete for a long time, when you grasp the magnitude of devices such as tablets, smart phones, PS3 and the like - being lined up waiting to be accommodated.

We have a large army of largely unseen and unpraised geeks and nerds (I categorise as being a dork, according to my daughter) whose mission in life, it seems, is to bring us more and more drivers, or to build drivers where no help is supplied by manufacturers, and I for one bend down and praise them for their efforts.

But the IoT (Internet of Things) seems to grow faster than ever.

Now I know you are 19.1 MATE, I will scout around and see if I learn anything, and if so, will report back here.

Good luck

Wizard
 

Sasha-Jen

Member
Hello again! Got back to looking at linux today.

Against my expectations, I think I've managed to find some info on my tablet not being recoginsed as such. I have three links here (the latter 2 comes from the first):

https://www.reddit.com/r/linux4noobs/comments/8r4fth/how_can_i_get_my_xppen_g640_to_work_with_linux/

https://blog.thepoon.fr/XPPenLinux/

https://ubuntuforums.org/showthread.php?t=2326961

I've skimmed through all 3 and the latter 2 seem to go through the same steps (relatively if not absolute). I'm taking it very slowly to make sure I understand a step before I do it. So far I've only done the "dmesg" command in my terminal and I think I have identified the same (relative) lines as the second link mentions in the " The issue, out-of-the-box" part.

[ 1.448129] usb 1-4: new full-speed USB device number 3 using xhci_hcd
[ 1.597802] usb 1-4: New USB device found, idVendor=5543, idProduct=004d
[ 1.597803] usb 1-4: New USB device strings: Mfr=5, Product=6, SerialNumber=0
[ 1.597803] usb 1-4: Product: TABLET MONITOR
[ 1.597804] usb 1-4: Manufacturer: UGEE
and lower down

[ 29.263638] input: UGEE TABLET MONITOR Pen as /devices/pci0000:00/0000:00:14.0/usb1/1-4/1-4:1.0/0003:5543:004D.0002/input/input27
[ 29.263823] input: UGEE TABLET MONITOR Pad as /devices/pci0000:00/0000:00:14.0/usb1/1-4/1-4:1.0/0003:5543:004D.0002/input/input28
[ 29.264008] uclogic 0003:5543:004D.0002: input,hidraw7: USB HID v1.11 Keypad [UGEE TABLET MONITOR] on usb-0000:00:14.0-4/input0
[ 29.264149] input: UGEE TABLET MONITOR Mouse as /devices/pci0000:00/0000:00:14.0/usb1/1-4/1-4:1.1/0003:5543:004D.0003/input/input29
[ 29.264344] uclogic 0003:5543:004D.0003: input,hiddev2,hidraw8: USB HID v1.11 Mouse [UGEE TABLET MONITOR] on usb-0000:00:14.0-4/input1
[ 29.264498] input: UGEE TABLET MONITOR Keyboard as /devices/pci0000:00/0000:00:14.0/usb1/1-4/1-4:1.2/0003:5543:004D.0004/input/input31
[ 29.324253] input: UGEE TABLET MONITOR Consumer Control as /devices/pci0000:00/0000:00:14.0/usb1/1-4/1-4:1.2/0003:5543:004D.0004/input/input32
[ 29.324433] input: UGEE TABLET MONITOR System Control as /devices/pci0000:00/0000:00:14.0/usb1/1-4/1-4:1.2/0003:5543:004D.0004/input/input33
I know it says UGEE tablet, but it is the XP-Pen Artist 16 model. I guess the Artist 16 is based off UGEE? Either way it's saying UGEE but it is XP-Pen. Maybe this is why it isn't recoginsed as a graphics tablet? I'm rambling speculations now so I'll get with the next point.

Both the 2nd and 3rd link then talk about "wizard pen" driver(s). I've yet to do this part but it sounds simple to install I think. I'll see. After that, the links diverge a bit by what file they refer to change/add; I'd guess that's to do with both being for different models despite both being XP-PEN?

These 2 links are getting into the most complex stuff I've had to read in Linux so far. As I said, I'm going slowly and not doing a step until I understand it, so idk if it will be later today I try and can update on results. Particularly since my tablet isn't either model they are referring to, advice at this point would be the most valuable so far. Anything from a confirmation that "these links are what you are needing, I'll leave you to figure them out" to "I've went through the links and can tell you that you specifically need to do <step 1, step 2 etc>. Or ya know, "No, you're completely going off in the wrong direction for your problem". :)
 

Sasha-Jen

Member
I'm not sure if I should attempt making a custom config file with the wizard pen driver that's linked within the previous links. Not because I couldn't understand each step of instructions, but because I am unsure about the fact that my tablet does work as a tablet.

It comes across to me as people do a custom wizardpen config when they have nothing about their tablet working beyond only being another monitor (if it is a display tablet like the artist 16). The fact that my tablet is functioning 100% testing out in krita makes me uncertain about meddling with this stuff. Although, from the research I have done it does come across as a driver issue to why it isn't recognised as a tablet to come up in the cinnamon tablet menu.

Maybe I'm being too cautious; but I seem to have reason to both do and not do it. If I got no response with the tablet pen this would be more straightforward. Why does my tablet work without being recognised to change settings? Is that a 'partial' driver issue? I don't know, I'm not well versed in the technicalities of device drivers. I can only take it one question at a time and not act until I'm certain.
 

Sasha-Jen

Member
I took a step back and looked over the reddit link 2 posts up. I decided to do the xinput and xinput test for the tablet.

xinput results:

[email protected]:~$ xinput
⎡ Virtual core pointer id=2 [master pointer (3)]
⎜ ↳ Virtual core XTEST pointer id=4 [slave pointer (2)]
⎜ ↳ SIGMACH1P USB Keyboard id=10 [slave pointer (2)]
⎜ ↳ LXD Gaming Mouse id=12 [slave pointer (2)]
⎜ ↳ UGEE TABLET MONITOR Mouse id=15 [slave pointer (2)]
⎜ ↳ UGEE TABLET MONITOR Consumer Control id=17 [slave pointer (2)]
⎜ ↳ UGEE TABLET MONITOR Pen Pen (0) id=23 [slave pointer (2)]
⎣ Virtual core keyboard id=3 [master keyboard (2)]
↳ Virtual core XTEST keyboard id=5 [slave keyboard (3)]
↳ Power Button id=6 [slave keyboard (3)]
↳ Power Button id=7 [slave keyboard (3)]
↳ Sleep Button id=8 [slave keyboard (3)]
↳ SIGMACH1P USB Keyboard id=9 [slave keyboard (3)]
↳ LXD Gaming Mouse id=11 [slave keyboard (3)]
↳ Blue Microphones Yeti Stereo Microphone id=13 [slave keyboard (3)]
↳ UGEE TABLET MONITOR Pen id=14 [slave keyboard (3)]
↳ UGEE TABLET MONITOR Keyboard id=16 [slave keyboard (3)]
↳ UGEE TABLET MONITOR System Control id=18 [slave keyboard (3)]
↳ Polostar 2.4GRF Keyboard id=19 [slave keyboard (3)]
↳ SIGMACH1P USB Keyboard id=20 [slave keyboard (3)]
↳ LXD Gaming Mouse id=21 [slave keyboard (
For xinput test [x] I first tested my actual mouse [12] just to see what it looks like when I move it around. It gave me output as expected with relative mouse postioning. I then attempted the tablet mouse [15] and no results came as I moved the pen around the tablet screen; I finally tested out the tablet pen with success outputting absolute positoning (as far as I understand it):

...
motion a[0]=8658908 a[1]=5833028 a[2]=0
motion a[0]=8658908 a[1]=5841694 a[2]=0
motion a[0]=8658908 a[1]=5850360 a[2]=0
motion a[0]=8658908 a[1]=5859892 a[2]=0
motion a[0]=8658908 a[1]=5868558 a[2]=0
motion a[0]=8658908 a[1]=5878957 a[2]=0
motion a[0]=8658908 a[1]=5889357 a[2]=0
motion a[0]=8658908 a[1]=5900622 a[2]=0
motion a[0]=8658908 a[1]=5913621 a[2]=0
motion a[0]=8658908 a[1]=5928353 a[2]=0
motion a[0]=8658908 a[1]=5943952 a[2]=0
motion a[0]=8660371 a[1]=5961284 a[2]=0
motion a[0]=8662321 a[1]=5980349 a[2]=0
motion a[0]=8666221 a[1]=6002014 a[2]=0
motion a[0]=8670120 a[1]=6026278 a[2]=0
motion a[0]=8674020 a[1]=6051409 a[2]=0
motion a[0]=8680357 a[1]=6079140 a[2]=0
motion a[0]=8684744 a[1]=6106871 a[2]=0
motion a[0]=8692056 a[1]=6133735 a[2]=0
motion a[0]=8696931 a[1]=6160600 a[2]=0
motion a[0]=8702293 a[1]=6186598 a[2]=0
motion a[0]=8710580 a[1]=6212595 a[2]=0
motion a[0]=8718380 a[1]=6236860 a[2]=0
...
It's the fact that the tablet pen is recognised as a pen and not a mouse when it is moved around makes me uncertain. The 2nd link 2 posts up talks about how their tablet was only recognised as a mouse and no more. To me, this reinforces as proof that the tablet does work absolutely fine, but it simply isn't recognised as a tablet within cinamon's graphics tablet menu (I know I'm on MATE which doesn't have that menu).

On the same 2nd link, it also talks about configuring the tablet "area". Am I right in thinking that is what I need? That configuring the area is the same as mapping the tablet pen from all 4 of my monitors to only the tablet itself? This makes me wonder if there is a way to identify what driver it's using right now and change area configuration in that. This will only leave the pen pressure through WINE'd Medibang to solve.

Also: is this topic still in getting started or has it been moved to hardware?
 
Last edited:

Sasha-Jen

Member
Big breakthrough. I'm going to make a post after each thing is completed, but I think I've found the solution to all vital problems. How? By re-framing my problem.

So far, I've thought about it as "My XP-Pen tablet needs the remapped through tablet settings" and "My XP-Pen shortcut remote needs to be remapped through remote settings". It's too narrow. I realised that the shortcut remote is just a 2nd, smaller keyboard (helped by the experience of using 'xinput' in the terminal previously). Same with the tablet: It is a) a monitor and b) a "special" mouse (pen ofc, but pens can be thought as mouses with special features).

So, I searched for "how to remap keyboard keys" and "how to limit a mouse to one screen". The answers came on the first page.

I've done the pen remapping and am on the keybinding, so the rest of this post shall be the pen solution.

link to tutorial I used: https://askubuntu.com/questions/839161/limit-a-graphics-tablet-to-one-monitor

In essence, through the terminal:
'xrandr' to identify the tablet monitor (for me, 'HDMI-0')
'xinput list' to get the pen device id ('xinput' lists some but not all input devices -- the pen was absent from that command result!) ( for me the pen id was 23)
'xinput map-to-output 23 HDMI-0' and the pen was set to only the tablet monitor.
 

Sasha-Jen

Member
What the previous post says is only temporary and is scrubbed on system restart. Either a start-up or login script needs to happen so there is no need to manually change the tablet mapping every restart.

I've created /usr/local/sbin/device-configurations.sh with the final command previously:

xinput map-to-output 23 HDMI-0
(This file will also have added the key shortcuts once I've finished that)

I then created /etc/systemd/system/device-configurations.service which holds:

[unit]
Description=To make sure all devices have proper settings on system start-up

[Service]
ExecStart=/bin/bash -c /usr/local/bin/device-configurations.sh

[Install]
WantedBy=multi-user.target
Both files were created as root user, yet it is failing:

● device-configurations.service
Loaded: loaded (/etc/systemd/system/device-configurations.service; enabled; vendor preset: enabled)
Active: failed (Result: exit-code) since Thu 2019-03-14 09:28:36 GMT; 18min ago
Process: 1011 ExecStart=/bin/bash -c /usr/local/bin/device-configurations.sh (code=exited, status=126)
Main PID: 1011 (code=exited, status=126)

Mar 14 09:28:35 owner-MS-7976 bash[1011]: /bin/bash: /usr/local/bin/device-configurations.sh: Permission denied
Mar 14 09:28:35 owner-MS-7976 systemd[1]: Started device-configurations.service.
Mar 14 09:28:36 owner-MS-7976 systemd[1]: device-configurations.service: Main process exited, code=exited, status=126/n/a
Mar 14 09:28:36 owner-MS-7976 systemd[1]: device-configurations.service: Failed with result 'exit-code'
Is there something obvious that I'm not understanding or have I missed something vital yet complex?

Edited Addition:

I've hit a wall with mapping the shortcut remote too. I've been following this guide:

https://askubuntu.com/questions/254424/how-can-i-change-what-keys-on-my-keyboard-do-how-can-i-create-custom-keyboard

Primarily, when the use the command:

xbindkeys -k
Which gives you the key and what it relates to. To show the bottom-middle key of the shortcut remote as example:

"(Scheme function)"
m:0x0 + c:33
p
This shows that this physical key results in a "p". The problem? The "p" on my actual physical keyboard gives the same output. Which would mean that the shortcut remote is not recognised as a seperate device with its own keys different to the actual keyboard.

That's wrong. Going back to 'xinput list' gives both devices separately:

↳ Polostar 2.4GRF Keyboard id=19 [slave keyboard (3)]
↳ SIGMACH1P USB Keyboard id=20 [slave keyboard (3)]
(Like the tablet came up as UGEE despite being XP-Pen, the XP-PEN shortcut remote is coming up as Polostar)

So, if they are recognised as different devices, how are the 9 remote keys not recognised as separate buttons? Am I misunderstanding the 'xbindkeys -k' command? If the remote wasn't coming up as a separate keyboard device then t would be easy to conclude that is why this is happening, but the recognition as a separate device really makes this confusing.
 
Last edited:

wizardfromoz

Super Moderator
Staff member
Gold Supporter
Also: is this topic still in getting started or has it been moved to hardware?
My extreme bad, and humble apologies - I have been busy, but no excuse :(... remedied now.

on xinput and changes being for session only -

Take a look at the contents of /usr/share/X11/xorg.conf.d/

My Debian has a file for wacom.conf , yours may have similar.

I'll come back with a little more detail a little later in my day, have to fly.

Wizard
 

Sasha-Jen

Member
I do have that file, Seems to do with wacom drivers. Not sure if it is relevant or useful.

I've attempted to proceed with all 3 problems I have today and for the first time I've hit a wall with all 3. The situation currently stands at:
  1. Tablet mapping successful but needs to be done at start-up to save doing it manually every single session (that will get annoying real fast).
  2. Remap remote keys. For some reason keys are recognised as same keys as the actual keyboard despite recognised as a different device. I need a way to [physical key] -> [virtual output]. Once done the mapping commands should be able to be put in the same script as the tablet mapping command for start-up.
  3. pen pressure through WINE (for medibang). This is the one I've only been looking at when I've been stuck on everything else. Today, I can say I have not progressed at all with it. I have attempted Krita several times since this temporary HDD install and unfortunately it only frustrates me. I need an art program like the medibang UI, if not medibang itself. And it needs to work.
Advice on any of these three issues are appreciated and being sought for at this time. Whenever I was stuck before I either jumped to another problem and managed to progress, or I came back the next day and progressed. This is the first time I am stuck on all 3 issues despite spending hours trying to find new useful info and failing to do so.
 

wizardfromoz

Super Moderator
Staff member
Gold Supporter

Members online


Top