[SOLVED]Connecting AOC monitor to Manjaro Lenovo T4390s laptop


New Member
Apr 30, 2023
Reaction score
I will post whatever info is needed, if someone can help me connect my usb AOC 24G2 monitor to my Lenovo T430s laptop for recording studio use. I am running Manjaro 6.1.
The monitor is shown as either a Microsoft or Apple img. Thanks all.
Last edited:

Your laptop should have a VGA socket, just plug a cable in between the laptop & monitor, (you may need to have it attached when booting up), & there may be a function key you can use to have it as only, or dual display.
It does have the vga socket, but when it is plugged in, I get 3-4 screen blinks from the laptop screen, but the external monitor only stays "on" being the power light, about 5 seconds. That is not long enough to try to move the input signal on the monitor.
I think that the one id:2, is the laptop screen?
sudo lshw -C video
[sudo] password for xxxx
description: VGA compatible controller
product: 3rd Gen Core processor Graphics Controller
vendor: Intel Corporation
physical id: 2
bus info: pci@0000:00:02.0
logical name: /dev/fb0
version: 09
width: 64 bits
clock: 33MHz
capabilities: msi pm vga_controller bus_master cap_list rom fb
configuration: depth=32 driver=i915 latency=0 resolution=1366,768
resources: irq:30 memory:f0000000-f03fffff memory:e0000000-efffffff ioport:5000(size=64) memory:c0000-dffff
You may have an Fn button with a picture of a monitor on it. Have you tried toggling that?
I found an interesting site for Manjaro and Displaylink, and I installed Displaylink via terminal. I ran the script, and got as far as the following;
yay -S evdi displaylink
AUR Explicit (1): displaylink-5.7-1
AUR Dependency (1): evdi-1.14.1-0
:: (1/2) Downloaded PKGBUILD: displaylink
:: (2/2) Downloaded PKGBUILD: evdi
2 displaylink (Installed) (Build Files Exist)
1 evdi (Installed) (Build Files Exist)
==> Packages to cleanBuild?
==> [N]one [A]ll [Ab]ort nstalled [No]tInstalled or (1 2 3, 1-3, ^4)
==> A
:: Deleting (1/2): /home/dirk/.cache/yay/displaylink
HEAD is now at eff2179 Updated to 5.7
:: Deleting (2/2): /home/dirk/.cache/yay/evdi
HEAD is now at 61c1328 Update to v1.14.1
2 displaylink (Installed) (Build Files Exist)
1 evdi (Installed) (Build Files Exist)
==> Diffs to show?
==> [N]one [A]ll [Ab]ort nstalled [No]tInstalled or (1 2 3, 1-3, ^4)
==> A
diff --git /home/dirk/.cache/yay/displaylink/.gitignore /home/dirk/.cache/yay/displaylink/.gitignore
new file mode 100644
index 0000000..89d2fb5
--- /dev/null
+++ /home/dirk/.cache/yay/displaylink/.gitignore
@@ -0,0 +1,7 @@
diff --git /home/dirk/.cache/yay/displaylink/99-displaylink.rules /home/dirk/.cache/yay/displaylink/99-displaylink.rules
new file mode 100644
index 0000000..3d2cc07
--- /dev/null
+++ /home/dirk/.cache/yay/displaylink/99-displaylink.rules
@@ -0,0 +1,5 @@
+# Copyright (c) 2016 DisplayLink (UK) Ltd.
+# File autogenerated by udev-installer.sh script

Now I'm not sure where to go with it. I got the idea from this site;

Members online

Latest posts