Slow network trasfer rate after boot drive swap.


Jan 20, 2021
Reaction score
Hi so I just received my new boot drive that I changed because I was running out of space.
I am running a server with ubuntu 20.04 on it and I am using 2 2.5gbs nic in both it and my main pc. Before I was getting a steady 280-290MB/s of transfer rate. But after restoring a backup that I had made with dd and also restored it with it I am now getting ~180MB/s
Anyone have any idea why that would be?
I also tried with the old drive but I get the same slower speed.
And if that can have anything to do with it when I do systemctl status NetworkManager I get this in yellow <warn> [1616070451.5519] dhcp4 (enp8s0): request timed out

It reads like a hardware issue to me. Did you knock one of the NICs loose? Pop 'em both out and reseat them.

Ninja Edit:

If that doesn't work, do the process of elimination thing. Remove both, put one in, boot, see if it works properly. If it does, try the same thing with the second one - using the same slot. Then, if needed, try the second slot.
Well in a way that might of helped but idk because prier to that I reinstalled the drivers on both the linux and windows side. Now im getting ~200-240MB/s which is better but still not stable or as fast as before. Before I had both nic's mtu set to 9k but now turning that on actually slows down the transfer rate even more why? I also had some other settings set but I dont remember which
If your backup was current then your settings *should* have transferred with it. Should have...
Yeah id assume that but even with my old boot drive the error still occurs. And now for some reason even changing the transmit and receive buffers which before would give me a bit better result now hurts my result so tbh idk anymore
Let me know when you've gone through the above hardware tests.
I did I also tried switching cable but still get the same result with a huge drop ion speed at 3/5 and back up and its always happening no matter the size of the file
Hmm... No, switch the hardware around just to make sure nothing is knocked loose or whatever - as mentioned in my first post.

Alas, this is a horrible time for me. I need to spend some time with the wife and then go to bed - and then be a bit occupied for a couple of days. I'll be in and out tomorrow.
No worrys and yeah I had tried some hardware swap in and out and switching nics from a pc to the other nothing helped. So now im gonna go back to my old boot drive and see how that does
Nothing helped so imma try making a new backup and idk restoring it again I wish I could use clonezilla to clone my drive but I dont have 2 m.2 slot so imma have to use dd but oh well lets hope it helps tho I doubt it since my original boot drive gives me the same error
Well I just noticed something. The kernel drivers loaded on my 2.5gb nics are the r8169 instead of the r8125 would you happen to know a way to resolve that?
I searched online but I wasnt able to find anything
I have actually its where I downloaded the driver because the one on the Realtek website dont work. But when I do lspci -v I see

Kernel driver in use: r8169
Kernel modules: r8169, r8125

but the one in use should be the r8125 since the r8169 is the one use for my integrated eth port

Members online

Latest posts