Solved Removing "Suspend" from Mate shutdown dialog box

Solved issue

ron.alan

Member
Joined
Dec 24, 2023
Messages
49
Reaction score
31
Credits
373
I have some instructions on how to remove the suspend option from Mate's shutodown dialog box (see image below), but it doesn't work on my new install with Mate 1.26. It worked on previous versions. The instructions were to create a text file named "enable-shutdown-reboot.pkla" (text of file in code block below) and place it in /etc/polkit-1/localauthority/50-local.d. The problem is 1) both the folders "localauthority" and "50-local.d" don't exit in this install; and 2) so I created them, and placed the file in it, but it doesn't work. Does anybody have any ideas what I can to do to fix this? Thanks.

Text of file:
Code:
[Disable suspend (upower)]
Identity=unix-user:*
Action=org.freedesktop.upower.suspend
ResultActive=no
ResultInactive=no
ResultAny=no

[Disable suspend (logind)]
Identity=unix-user:*
Action=org.freedesktop.login1.suspend
ResultActive=no
ResultInactive=no
ResultAny=no

[Disable suspend when others are logged in (logind)]
Identity=unix-user:*
Action=org.freedesktop.login1.suspend-multiple-sessions
ResultActive=no
ResultInactive=no
ResultAny=no

[Disable hibernate (upower)]
Identity=unix-user:*
Action=org.freedesktop.upower.hibernate
ResultActive=no
ResultInactive=no
ResultAny=no

[Disable hibernate (logind)]
Identity=unix-user:*
Action=org.freedesktop.login1.hibernate
ResultActive=no
ResultInactive=no
ResultAny=no

[Disable hibernate when others are logged in (logind)]
Identity=unix-user:*
Action=org.freedesktop.login1.hibernate-multiple-sessions
ResultActive=no
ResultInactive=no
ResultAny=no

shutdownoptions.jpg
 


Wish I could help.

If this was 'Puppy', I could sort you out very quickly. I can do summat like this in 'our Pup' in less than 5 minutes - a decade of experience with her will do that for you! - but she's a law unto herself, and does a lot of stuff rather differently to just about any other distro you care to name.

(I quit distro-hopping many years ago; I found the "one for me" quite early on, and settled down very happily with it. I create all sorts of packages for the community, including a whole range of 'portable' apps, along with a number of utilities developed from scratch (many with GUIs). I like to help out with the newbies in the community forum, and also moderate there, too).

Hence, I don't have very much experience with the "mainstream".....and what experience I DO have is years out of date.

(shrug...)


Mike. :(
 
Which Linux Mint distro and version, Ron?
 
Maybe @camtaf has an idea.

Either that, or you may need to get in touch with the developer, Zephyr.

Good luck.

Wizard
 
Something indeed did change. I found the answer here, in the middle of the page, adding a file in /etc/polkit-1/rules.d/10-disable-suspend.rules. Hope this can help someone else out there.

No.suspend.jpg
 
Asked 10 years, 11 months ago
Modified 8 years, 6 months ago
Viewed 5k times

it just shows that even the oldest info can be invaluable
 
I didn't even notice that. That's older than the time I've been on Linux. Strange.
 
Linux has been around for quite a long time
 
@ron.alan - goodonyer. :)

Glad you got it sorted. I did not know that one, so I will bookmark the link and this thread for future use.

I don't ever use Suspend, so it may prove useful.

Cheers and Avagudweegend

Chris Turner
wizardfromoz
 
Linux has been around for quite a long time
Yeah, I know that. Not sure what you mean by that. What I meant was somebody else had the same problem as me 10 years ago; I only started having this issue right now. But the contents of our original files were different/not exactly the same, so maybe that has something to do with it.
 

Members online


Top