Solved Pleroma doesn't listen on any port

Solved issue

tinfoil-hat

Active Member
Joined
Oct 24, 2021
Messages
342
Reaction score
170
Credits
2,379
Hi,

I installed Pleroma on a LXC Container inside a Proxmox VPS. I installed it on Debian using these instructions:
https://docs-develop.pleroma.social/backend/installation/debian_based_en/

I want to run it inside the LXC and connect to it via nginx reverse proxy on Proxmox host, which is public. That's the reason I want it to listen on 0.0.0.0

As you can see, it's running

Code:
root@pleroma:/opt/pleroma# systemctl status pleroma
● pleroma.service - Pleroma social network
     Loaded: loaded (/etc/systemd/system/pleroma.service; enabled; preset: enabled)
     Active: active (running) since Fri 2024-02-09 01:57:31 UTC; 1s ago
   Main PID: 14403 (beam.smp)
      Tasks: 29 (limit: 19112)
     Memory: 60.8M
        CPU: 1.500s
     CGroup: /system.slice/pleroma.service
             ├─14403 /usr/lib/erlang/erts-13.1.5/bin/beam.smp -- -root /usr/lib/erlang -bindir /usr/lib/erlang/erts-13.1.5/bin -progname erl -- -home /var/lib/pleroma -- -pa /usr/lib/elixir/bin/../lib/eex/ebin /usr/lib/elixir/bin/../lib/elixir/ebin /usr/lib/elixir/bin/../>
             └─14418 erl_child_setup 1024

Feb 09 01:57:31 pleroma systemd[1]: Started pleroma.service - Pleroma social network.

I also made sure, I used
sudo -Hu pleroma mv config/{generated_config.exs,prod.secret.exs}
like it says in the Documentation

It should be listening on 0.0.0.0 port 4000
less config/prod.secret.exs

Code:
# Pleroma instance configuration

# NOTE: This file should not be committed to a repo or otherwise made public
# without removing sensitive information.

import Config

config :pleroma, Pleroma.Web.Endpoint,
   url: [host: "domain.tld", scheme: "https", port: 443],
   http: [ip: {0, 0, 0, 0}, port: 4000],
.
.
.

There is no pleroma listening on any port ... strange

Code:
root@pleroma:/opt/pleroma# netstat -tulpen

Active Internet connections (only servers)

Proto Recv-Q Send-Q Local Address           Foreign Address         State       User       Inode      PID/Program name   

tcp        0      0 127.0.0.1:5432          0.0.0.0:*               LISTEN      103        4074776    143/postgres       

tcp        0      0 127.0.0.1:25            0.0.0.0:*               LISTEN      0          4075966    296/master         

tcp6       0      0 :::22                   :::*                    LISTEN      0          4071416    1/init             

tcp6       0      0 ::1:25                  :::*                    LISTEN      0          4075967    296/master         

tcp6       0      0 ::1:5432                :::*                    LISTEN      103        4074775    143/postgres       

tcp6       0      0 :::4369                 :::*                    LISTEN      0          4071415    1/init             

root@pleroma:/opt/pleroma#
 


Make check the application log file or container log information?
 
it seems like the postgres migration did fail to one of these options

Code:
Would you like to use RUM indices? [y]
Do you want to deduplicate uploaded files? (y/n) [y]

I started over, this time I answered with No.

This time Pleroma starts, but the pages are blank. I used the nginx config from Pleroma documentation. It seems to load something, but it's a blank page :( either with Port or with Ip nor with Domain, like Pic related

Logs are clean this time.
 

Attachments

  • Bildschirmfoto vom 2024-02-09 10-15-55.png
    Bildschirmfoto vom 2024-02-09 10-15-55.png
    14.1 KB · Views: 77
  • Bildschirmfoto vom 2024-02-09 10-15-23.png
    Bildschirmfoto vom 2024-02-09 10-15-23.png
    12.9 KB · Views: 43
  • Bildschirmfoto vom 2024-02-09 10-15-06.png
    Bildschirmfoto vom 2024-02-09 10-15-06.png
    13.7 KB · Views: 48
Last edited:
I would ask in the pleroma official support channel.
 
Got it to work, It serached for a HTTPS connection, after running certbot the Issue is resolved, thanks for your effort
 
So it was looking for your ssl certificates because you configured it to use https, but because those weren't there it wouldn't start listening on that port or something like that? Then after you setup the ssl certificates with cerbot it was able to do that?
 
So it was looking for your ssl certificates because you configured it to use https, but because those weren't there it wouldn't start listening on that port or something like that? Then after you setup the ssl certificates with cerbot it was able to do that?
exactly
 
starting over got me to get it work
 


Top