My laptop Dell Inspiron 3542(i3 4th gen) is not shutting down completely.

darkice

New Member
Joined
Dec 27, 2023
Messages
11
Reaction score
2
Credits
88
Laptop is not shutting down Completely in any linux distro but it shutdown in windows 10.

My laptop is Dell Inspiron 3542, core i3 4th gen. First what happening when I power off by shutdown button in menu or using cli, laptop disconnect every peripheral devices, lcd goes off as normal shutdown but after a while CPU fan spins very fast, then slows down and keep running, until battery goes completely drain or on even charging it keeps running. But sometime it completely shutdown. When I tried switching on after a while it don't on, until I completed pdf by pressing and holding power button for 15 seconds. Then power on.

What I tried so far:

1. puting acpi=force in grub config file
2. Changing quite splash to quite only
3. Changing linux distro, linux mint xfce, cinnamon, mate, Ubuntu, Pop os, manjaro......
4. Changing BIOS setting fast boot to off state.
5. Tried other settings in bios like virtualisation, usb wake off state, restoring the default setting.....
6. When I switch to windows it is completely shutting down as normal.
7. Updating to latest kernel 6.5
8. ALT +PRINTSCR + o to force Shutdown
9. BIOS is updated to latest


I haven't change any hardware.if there is problem with hardware Why windows 10 able to shutdown properly everytime?
I tried to check log files but not successful as I am beginner in linux, and don't know how to correctly display log to my specific problems in that tons of lines of logs.

Temporary solution I found is dual booting, installed windows 10 just for shutting down safely. Or either I have to hold the power button for force shutdown.
 


Last edited:
Laptop is not shutting down Completely in any linux distro

You'd best tell us some more about that. Like do you have a Linux installed, and if so, which, please?

Chris Turner
wizardfromoz
 
Welcome to the forums
If you are multi booting with Windows 10/11 make sure Windows quick start/fast boot is disabled,
 
Welcome to the forums
If you are multi booting with Windows 10/11 make sure Windows quick start/fast boot is disabled,
I have compulsion as this is not shutting down with linux, that's why I have dual booted, so that I can safely shutdown without long press power button. And I also turned off the fast boot, I saw these suggestions and questions answers on other forum before posting here. And thank you so much for your kind reply
 
You'd best tell us some more about that. Like do you have a Linux installed, and if so, which, please?

Chris Turner
wizardfromoz
I installed Linux mint 21.2 and running linux mint for more than a year. Sometime I change it to Ubuntu.
 
Linux mint 21.2 and running Linux mint for more than a year.

Thanks
 
I installed Linux mint 21.2 and running linux mint for more than a year. Sometime I change it to Ubuntu.
Neither of these should be causing any problems, Is it recent that you have been having shut down problems?
If you have done any Windows updates, re-check fast boot and Secure boot are both still disabled [some Windows updates will re-initiate them]
 
Linux mint 21.2 and running Linux mint for more than a year.

Thanks
Actually I used linux mint, pop os, Ubuntu, manjaro.. similar and same to same problem happens. And this is not in the near past, it is happening more 2 years. I ask on reddit but some good guy suggest me to post here. In two year I switch back and forth window10 or Linux, only due to this problem.
 
Neither of these should be causing any problems, Is it recent that you have been having shut down problems?
If you have done any Windows updates, re-check fast boot and Secure boot are both still disabled [some Windows updates will re-initiate them]
I don't have anything installed on windows 10, just installed recently to shutdown safely, because I have to give my laptop for repair due to motherboard issue occur recently, i thought I shutting it down by pressing power button
 
Last edited:
I don't have anything installed on windows 10, just installed recently to shutdown safely, because I have to give my laptop for repair due to motherboard issue occur recently
Neither updating it.
 
Open the Terminal (ctrl+alt+T)

copy and paste this command in , and then hit enter

Code:
sudo shutdown -h now
 
i tried 3 times 1st time shutdown completely, 2nd time after opening tried again but this time not, like mentioned in the post. and again i tried 3rd time this time also not shutdown completely, fan are running
 
log.png

and i found this below line :

Dec 26 10:42:30 aarav-Inspiron-3542 kernel: ACPI: [Firmware Bug]: BIOS _OSI(Linux) query ignored
is there any problem happening with this?
 
In bios, try disabling hyper-threading.......by setting the Logical Processor setting to Disabled.

make sure to Save the settings before exiting the bios

If this has no effect, it can easily be set back to the way it was
 
I have to give my laptop for repair due to motherboard issue occur recently,
After you have done the above...tell us about the motherboard issue. Was the failure to shut down happening before the motherboard issue ?
 
7. Updating to latest kernel 6.5

There may be some connection with that step, current kernel for Victoria is

5.15.0-91-generic

Osprey is online, he may have some clues.

But this Aussie has to bugger off to cook tea, I'll check back tomorrow.

Wiz
 
Dec 26 10:42:30 aarav-Inspiron-3542 kernel: ACPI: [Firmware Bug]: BIOS _OSI(Linux) query ignored
is there any problem happening with this?
There's a reasonable chance that the problem of failure to shutdown fully is related to the ACPI power management system since the linux distros that are mentioned have apparently shut themselves down properly, but the message isn't being conveyed to the machine's firmware or software.

Since the problem appears to be intermittent, a reasonable approach to get more information on what is happening is to read (and record) the logs which occur before a successful full shutdown, and read (and record) the logs which occur before a failed full shutdown. The differences in the information may throw some light on the matter.

Logs appear in files such as /var/log/messages, /var/log/syslog, /var/log/kern.log, and are also accessible through using the command: journalctl.

Unfortunately there is a problem with ACPI implementations that companies put into their BIOS/UEFI because they often do not fully apply the ACPI standards which linux does follow, hence the linux kernel will identify as errors the shortcomings it finds in the ACPI implementations.
 

Staff online

Members online


Top