Mint on my imac

noelw

Member
Joined
Jun 24, 2023
Messages
57
Reaction score
72
Credits
494
Hi all and thanks for the add. I have been using Linux Mint for about 10 years now and to me there is nothing like it. I recently got hold of a 2012 27 inch imac and i thought why not so i installed mint on it and it does everything right.
System:
Kernel: 5.15.0-75-generic x86_64 bits: 64 compiler: gcc v: 11.3.0 Desktop: Cinnamon 5.6.8
tk: GTK 3.24.33 wm: muffin dm: LightDM Distro: Linux Mint 21.1 Vera base: Ubuntu 22.04 jammy
Machine:
Type: Desktop System: Apple product: iMac13,2 v: 1.0 serial: <superuser required> Chassis:
type: 13 v: Mac-FC02E91DDD3FA6A4 serial: <superuser required>
Mobo: Apple model: Mac-FC02E91DDD3FA6A4 v: iMac13,2 serial: <superuser required> UEFI: Apple
v: 429.0.0.0.0 date: 03/18/2022
CPU:
Info: quad core model: Intel Core i5-3470S bits: 64 type: MCP arch: Ivy Bridge rev: 9 cache:
L1: 256 KiB L2: 1024 KiB L3: 6 MiB
Speed (MHz): avg: 1912 high: 2191 min/max: 1600/3600 cores: 1: 1944 2: 1919 3: 1596 4: 2191
bogomips: 23147
Flags: avx ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
Graphics:
Device-1: NVIDIA GK107M [GeForce GTX 660M Mac Edition] vendor: Apple driver: nvidia v: 390.157
pcie: speed: 2.5 GT/s lanes: 16 bus-ID: 01:00.0 chip-ID: 10de:0fe0
Device-2: Apple FaceTime HD Camera (Built-in) type: USB driver: uvcvideo bus-ID: 1-1.1:3
chip-ID: 05ac:8511
Display: x11 server: X.Org v: 1.21.1.4 driver: X: loaded: nvidia
unloaded: fbdev,modesetting,nouveau,vesa gpu: nvidia display-ID: :0 screens: 1
Screen-1: 0 s-res: 2560x1440 s-dpi: 108
Monitor-1: DP-2 res: 2560x1440 dpi: 109 diag: 685mm (27")
OpenGL: renderer: GeForce GTX 660M/PCIe/SSE2 v: 4.6.0 NVIDIA 390.157 direct render: Yes
Audio:
Device-1: Intel 7 Series/C216 Family High Definition Audio driver: snd_hda_intel v: kernel
bus-ID: 00:1b.0 chip-ID: 8086:1e20
Device-2: NVIDIA GK107 HDMI Audio vendor: Apple driver: snd_hda_intel v: kernel pcie:
speed: 8 GT/s lanes: 16 bus-ID: 01:00.1 chip-ID: 10de:0e1b
Sound Server-1: ALSA v: k5.15.0-75-generic running: yes
Sound Server-2: PulseAudio v: 15.99.1 running: yes
Sound Server-3: PipeWire v: 0.3.48 running: yes
Network:
Device-1: Broadcom NetXtreme BCM57766 Gigabit Ethernet PCIe vendor: Apple driver: tg3 v: kernel
pcie: speed: 2.5 GT/s lanes: 1 port: N/A bus-ID: 03:00.0 chip-ID: 14e4:1686
IF: enp3s0f0 state: down mac: <filter>
Device-2: Broadcom BCM4331 802.11a/b/g/n vendor: Apple AirPort Extreme driver: wl v: kernel
pcie: speed: 2.5 GT/s lanes: 1 bus-ID: 04:00.0 chip-ID: 14e4:4331
IF: wlp4s0 state: up mac: <filter>
Bluetooth:
Device-1: Apple Bluetooth USB Host Controller type: USB driver: btusb v: 0.8 bus-ID: 2-1.8.1.3:7
chip-ID: 05ac:828b
Report: hciconfig ID: hci0 rfk-id: 2 state: up address: <filter> bt-v: 2.1 lmp-v: 4.0
sub-v: 4196
Drives:
Local Storage: total: 931.51 GiB used: 197.09 GiB (21.2%)
ID-1: /dev/sda vendor: Apple model: HDD ST1000DM003 size: 931.51 GiB speed: 3.0 Gb/s
serial: <filter>
Partition:
ID-1: / size: 915.32 GiB used: 197.09 GiB (21.5%) fs: ext4 dev: /dev/sda2
ID-2: /boot/efi size: 511 MiB used: 6.1 MiB (1.2%) fs: vfat dev: /dev/sda1
Swap:
ID-1: swap-1 type: file size: 2 GiB used: 0 KiB (0.0%) priority: -2 file: /swapfile
Sensors:
System Temperatures: cpu: 48.0 C mobo: N/A gpu: nvidia temp: 46 C
Fan Speeds (RPM): N/A
Repos:
Packages: apt: 2401
No active apt repos in: /etc/apt/sources.list
Active apt repos in: /etc/apt/sources.list.d/official-package-repositories.list
1: deb http: //mirror.lagoon.nc/pub/linuxmint-packages vera main upstream import backport
2: deb http: //ubuntu.mirror.serversaustralia.com.au/ubuntu jammy main restricted universe multiverse
3: deb http: //ubuntu.mirror.serversaustralia.com.au/ubuntu jammy-updates main restricted universe multiverse
4: deb http: //ubuntu.mirror.serversaustralia.com.au/ubuntu jammy-backports main restricted universe multiverse
5: deb http: //security.ubuntu.com/ubuntu/ jammy-security main restricted universe multiverse
Info:
Processes: 238 Uptime: 2h 26m Memory: 31.28 GiB used: 2.47 GiB (7.9%) Init: systemd v: 249
runlevel: 5 Compilers: gcc: 11.3.0 alt: 11/12 Client: Unknown python3.10 client inxi: 3.3.13
I am going to install a ssd in it next week. It has the old type in it now and it does run ok but as i said i will replace it. Thanks again. ps i am a 67 year old Aussie.
 


Hi all and thanks for the add. I have been using Linux Mint for about 10 years now and to me there is nothing like it. I recently got hold of a 2012 27 inch imac and i thought why not so i installed mint on it and it does everything right.
System:
Kernel: 5.15.0-75-generic x86_64 bits: 64 compiler: gcc v: 11.3.0 Desktop: Cinnamon 5.6.8
tk: GTK 3.24.33 wm: muffin dm: LightDM Distro: Linux Mint 21.1 Vera base: Ubuntu 22.04 jammy
Machine:
Type: Desktop System: Apple product: iMac13,2 v: 1.0 serial: <superuser required> Chassis:
type: 13 v: Mac-FC02E91DDD3FA6A4 serial: <superuser required>
Mobo: Apple model: Mac-FC02E91DDD3FA6A4 v: iMac13,2 serial: <superuser required> UEFI: Apple
v: 429.0.0.0.0 date: 03/18/2022
CPU:
Info: quad core model: Intel Core i5-3470S bits: 64 type: MCP arch: Ivy Bridge rev: 9 cache:
L1: 256 KiB L2: 1024 KiB L3: 6 MiB
Speed (MHz): avg: 1912 high: 2191 min/max: 1600/3600 cores: 1: 1944 2: 1919 3: 1596 4: 2191
bogomips: 23147
Flags: avx ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
Graphics:
Device-1: NVIDIA GK107M [GeForce GTX 660M Mac Edition] vendor: Apple driver: nvidia v: 390.157
pcie: speed: 2.5 GT/s lanes: 16 bus-ID: 01:00.0 chip-ID: 10de:0fe0
Device-2: Apple FaceTime HD Camera (Built-in) type: USB driver: uvcvideo bus-ID: 1-1.1:3
chip-ID: 05ac:8511
Display: x11 server: X.Org v: 1.21.1.4 driver: X: loaded: nvidia
unloaded: fbdev,modesetting,nouveau,vesa gpu: nvidia display-ID: :0 screens: 1
Screen-1: 0 s-res: 2560x1440 s-dpi: 108
Monitor-1: DP-2 res: 2560x1440 dpi: 109 diag: 685mm (27")
OpenGL: renderer: GeForce GTX 660M/PCIe/SSE2 v: 4.6.0 NVIDIA 390.157 direct render: Yes
Audio:
Device-1: Intel 7 Series/C216 Family High Definition Audio driver: snd_hda_intel v: kernel
bus-ID: 00:1b.0 chip-ID: 8086:1e20
Device-2: NVIDIA GK107 HDMI Audio vendor: Apple driver: snd_hda_intel v: kernel pcie:
speed: 8 GT/s lanes: 16 bus-ID: 01:00.1 chip-ID: 10de:0e1b
Sound Server-1: ALSA v: k5.15.0-75-generic running: yes
Sound Server-2: PulseAudio v: 15.99.1 running: yes
Sound Server-3: PipeWire v: 0.3.48 running: yes
Network:
Device-1: Broadcom NetXtreme BCM57766 Gigabit Ethernet PCIe vendor: Apple driver: tg3 v: kernel
pcie: speed: 2.5 GT/s lanes: 1 port: N/A bus-ID: 03:00.0 chip-ID: 14e4:1686
IF: enp3s0f0 state: down mac: <filter>
Device-2: Broadcom BCM4331 802.11a/b/g/n vendor: Apple AirPort Extreme driver: wl v: kernel
pcie: speed: 2.5 GT/s lanes: 1 bus-ID: 04:00.0 chip-ID: 14e4:4331
IF: wlp4s0 state: up mac: <filter>
Bluetooth:
Device-1: Apple Bluetooth USB Host Controller type: USB driver: btusb v: 0.8 bus-ID: 2-1.8.1.3:7
chip-ID: 05ac:828b
Report: hciconfig ID: hci0 rfk-id: 2 state: up address: <filter> bt-v: 2.1 lmp-v: 4.0
sub-v: 4196
Drives:
Local Storage: total: 931.51 GiB used: 197.09 GiB (21.2%)
ID-1: /dev/sda vendor: Apple model: HDD ST1000DM003 size: 931.51 GiB speed: 3.0 Gb/s
serial: <filter>
Partition:
ID-1: / size: 915.32 GiB used: 197.09 GiB (21.5%) fs: ext4 dev: /dev/sda2
ID-2: /boot/efi size: 511 MiB used: 6.1 MiB (1.2%) fs: vfat dev: /dev/sda1
Swap:
ID-1: swap-1 type: file size: 2 GiB used: 0 KiB (0.0%) priority: -2 file: /swapfile
Sensors:
System Temperatures: cpu: 48.0 C mobo: N/A gpu: nvidia temp: 46 C
Fan Speeds (RPM): N/A
Repos:
Packages: apt: 2401
No active apt repos in: /etc/apt/sources.list
Active apt repos in: /etc/apt/sources.list.d/official-package-repositories.list
1: deb http: //mirror.lagoon.nc/pub/linuxmint-packages vera main upstream import backport
2: deb http: //ubuntu.mirror.serversaustralia.com.au/ubuntu jammy main restricted universe multiverse
3: deb http: //ubuntu.mirror.serversaustralia.com.au/ubuntu jammy-updates main restricted universe multiverse
4: deb http: //ubuntu.mirror.serversaustralia.com.au/ubuntu jammy-backports main restricted universe multiverse
5: deb http: //security.ubuntu.com/ubuntu/ jammy-security main restricted universe multiverse
Info:
Processes: 238 Uptime: 2h 26m Memory: 31.28 GiB used: 2.47 GiB (7.9%) Init: systemd v: 249
runlevel: 5 Compilers: gcc: 11.3.0 alt: 11/12 Client: Unknown python3.10 client inxi: 3.3.13
I am going to install a ssd in it next week. It has the old type in it now and it does run ok but as i said i will replace it. Thanks again. ps i am a 67 year old Aussie.
Welcome to the forum! Keep us posted on your project.
 
I am confused. This is in Member Introductions.

Maybe one cup of coffee wasn't enough.
 
Hi all and thanks for the add. I have been using Linux Mint for about 10 years now and to me there is nothing like it. I recently got hold of a 2012 27 inch imac and i thought why not so i installed mint on it and it does everything right.
System:
Kernel: 5.15.0-75-generic x86_64 bits: 64 compiler: gcc v: 11.3.0 Desktop: Cinnamon 5.6.8
tk: GTK 3.24.33 wm: muffin dm: LightDM Distro: Linux Mint 21.1 Vera base: Ubuntu 22.04 jammy
Machine:
Type: Desktop System: Apple product: iMac13,2 v: 1.0 serial: <superuser required> Chassis:
type: 13 v: Mac-FC02E91DDD3FA6A4 serial: <superuser required>
Mobo: Apple model: Mac-FC02E91DDD3FA6A4 v: iMac13,2 serial: <superuser required> UEFI: Apple
v: 429.0.0.0.0 date: 03/18/2022
CPU:
Info: quad core model: Intel Core i5-3470S bits: 64 type: MCP arch: Ivy Bridge rev: 9 cache:
L1: 256 KiB L2: 1024 KiB L3: 6 MiB
Speed (MHz): avg: 1912 high: 2191 min/max: 1600/3600 cores: 1: 1944 2: 1919 3: 1596 4: 2191
bogomips: 23147
Flags: avx ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
Graphics:
Device-1: NVIDIA GK107M [GeForce GTX 660M Mac Edition] vendor: Apple driver: nvidia v: 390.157
pcie: speed: 2.5 GT/s lanes: 16 bus-ID: 01:00.0 chip-ID: 10de:0fe0
Device-2: Apple FaceTime HD Camera (Built-in) type: USB driver: uvcvideo bus-ID: 1-1.1:3
chip-ID: 05ac:8511
Display: x11 server: X.Org v: 1.21.1.4 driver: X: loaded: nvidia
unloaded: fbdev,modesetting,nouveau,vesa gpu: nvidia display-ID: :0 screens: 1
Screen-1: 0 s-res: 2560x1440 s-dpi: 108
Monitor-1: DP-2 res: 2560x1440 dpi: 109 diag: 685mm (27")
OpenGL: renderer: GeForce GTX 660M/PCIe/SSE2 v: 4.6.0 NVIDIA 390.157 direct render: Yes
Audio:
Device-1: Intel 7 Series/C216 Family High Definition Audio driver: snd_hda_intel v: kernel
bus-ID: 00:1b.0 chip-ID: 8086:1e20
Device-2: NVIDIA GK107 HDMI Audio vendor: Apple driver: snd_hda_intel v: kernel pcie:
speed: 8 GT/s lanes: 16 bus-ID: 01:00.1 chip-ID: 10de:0e1b
Sound Server-1: ALSA v: k5.15.0-75-generic running: yes
Sound Server-2: PulseAudio v: 15.99.1 running: yes
Sound Server-3: PipeWire v: 0.3.48 running: yes
Network:
Device-1: Broadcom NetXtreme BCM57766 Gigabit Ethernet PCIe vendor: Apple driver: tg3 v: kernel
pcie: speed: 2.5 GT/s lanes: 1 port: N/A bus-ID: 03:00.0 chip-ID: 14e4:1686
IF: enp3s0f0 state: down mac: <filter>
Device-2: Broadcom BCM4331 802.11a/b/g/n vendor: Apple AirPort Extreme driver: wl v: kernel
pcie: speed: 2.5 GT/s lanes: 1 bus-ID: 04:00.0 chip-ID: 14e4:4331
IF: wlp4s0 state: up mac: <filter>
Bluetooth:
Device-1: Apple Bluetooth USB Host Controller type: USB driver: btusb v: 0.8 bus-ID: 2-1.8.1.3:7
chip-ID: 05ac:828b
Report: hciconfig ID: hci0 rfk-id: 2 state: up address: <filter> bt-v: 2.1 lmp-v: 4.0
sub-v: 4196
Drives:
Local Storage: total: 931.51 GiB used: 197.09 GiB (21.2%)
ID-1: /dev/sda vendor: Apple model: HDD ST1000DM003 size: 931.51 GiB speed: 3.0 Gb/s
serial: <filter>
Partition:
ID-1: / size: 915.32 GiB used: 197.09 GiB (21.5%) fs: ext4 dev: /dev/sda2
ID-2: /boot/efi size: 511 MiB used: 6.1 MiB (1.2%) fs: vfat dev: /dev/sda1
Swap:
ID-1: swap-1 type: file size: 2 GiB used: 0 KiB (0.0%) priority: -2 file: /swapfile
Sensors:
System Temperatures: cpu: 48.0 C mobo: N/A gpu: nvidia temp: 46 C
Fan Speeds (RPM): N/A
Repos:
Packages: apt: 2401
No active apt repos in: /etc/apt/sources.list
Active apt repos in: /etc/apt/sources.list.d/official-package-repositories.list
1: deb http: //mirror.lagoon.nc/pub/linuxmint-packages vera main upstream import backport
2: deb http: //ubuntu.mirror.serversaustralia.com.au/ubuntu jammy main restricted universe multiverse
3: deb http: //ubuntu.mirror.serversaustralia.com.au/ubuntu jammy-updates main restricted universe multiverse
4: deb http: //ubuntu.mirror.serversaustralia.com.au/ubuntu jammy-backports main restricted universe multiverse
5: deb http: //security.ubuntu.com/ubuntu/ jammy-security main restricted universe multiverse
Info:
Processes: 238 Uptime: 2h 26m Memory: 31.28 GiB used: 2.47 GiB (7.9%) Init: systemd v: 249
runlevel: 5 Compilers: gcc: 11.3.0 alt: 11/12 Client: Unknown python3.10 client inxi: 3.3.13
I am going to install a ssd in it next week. It has the old type in it now and it does run ok but as i said i will replace it. Thanks again. ps i am a 67 year old Aussie.
That's cool. :D macOS is Unix-based, so putting Linux on it, especially since you'd need to basically play with a Ouija Board to get even Catalina on that iMac, is a good move. I love Peppermint OS myself. :D
 
I am confused. This is in Member Introductions.

Glitch in the software, David, from my initial attempts to move welcoming comments to MI.

Moving this to Mint.

Wizard
 


Top