Linux Mint 20.2 Cinnamon HP Device Manager Not Seeing Printer / Dependencies Missing SOLVED



OP
Alexzee

Alexzee

Well-Known Member
Joined
Jun 1, 2019
Messages
2,003
Reaction score
966
Credits
9,874
it is under Administration then click Add Printer
I added the printer via the ppd file and it worked.
Sadly it's still not working. The printer shows in the HP MGR but it has a red X on the device.
HP MGR.png


Error.png


I can print from the CUPS website but the HP Manager isn't responding.
I'm sitting here scratching my head:-

I have to take a break, got a really nasty migraine.
Be back later:-
 
Last edited:
OP
Alexzee

Alexzee

Well-Known Member
Joined
Jun 1, 2019
Messages
2,003
Reaction score
966
Credits
9,874
Looks like it is seen lets now fix missing dependencies -
Code:
sudo dpkg --configure -a
then reboot
I ran that command and it didn't return anything.

Rebooted like you told me to and quit the HP Device Mgr and re-launched it.
There is still an error and I'm not able to do a scan or print.

Error Still.png
 

brickwizard

Well-Known Member
Joined
Apr 28, 2021
Messages
1,253
Reaction score
957
Credits
9,458
I have 2 HP printers a photosmart and an envy in Linux the scan dosn't work on either HP, you have to use simple scan [in your menu]
 

kc1di

Well-Known Member
Joined
May 14, 2021
Messages
486
Reaction score
438
Credits
3,422
I would suggest you uninstall all printers and the hplip-gui and then reboot and reinstall them all. see if it clears the problem.
I have an hp Envy 500 series that works just fine and scanner works well.
 
OP
Alexzee

Alexzee

Well-Known Member
Joined
Jun 1, 2019
Messages
2,003
Reaction score
966
Credits
9,874
I have 2 HP printers a photosmart and an envy in Linux the scan dosn't work on either HP, you have to use simple scan [in your menu]
Simple Scan does not show up in the menu at all, sadly:-
 
OP
Alexzee

Alexzee

Well-Known Member
Joined
Jun 1, 2019
Messages
2,003
Reaction score
966
Credits
9,874
I would suggest you uninstall all printers and the hplip-gui and then reboot and reinstall them all. see if it clears the problem.
I have an hp Envy 500 series that works just fine and scanner works well.
I think I'm going to have to try that.

This printer has worked under Slackware, Ubuntu, Mint 19.1, and other Linux distro's for the last 10 years.
I'll try your suggestion and see what happens.
 

Lord Boltar

Well-Known Member
Joined
Nov 24, 2020
Messages
996
Reaction score
646
Credits
7,385
I would agree with kc1di on this - time to dump the old drivers and put in some new ones
Code:
sudo apt remove hplip hplip-data hplip-doc hplip-gui hpijs-ppds \
libsane-hpaio printer-driver-hpcups printer-driver-hpijs
sudo rm -rf /usr/share/hplip/
Code:
sudo apt autoremove
Download the Automatic Installer (.run file) from official link - https://developers.hp.com/hp-linux-imaging-and-printing/gethplip
open a terminal where you saved the download and run - sh hplip-3.21.10.run
 
OP
Alexzee

Alexzee

Well-Known Member
Joined
Jun 1, 2019
Messages
2,003
Reaction score
966
Credits
9,874
I'll start all over again in a few minutes.
Be back to let you guys know how things went.
 

kc1di

Well-Known Member
Joined
May 14, 2021
Messages
486
Reaction score
438
Credits
3,422
Simple Scan does not show up in the menu at all, sadly:-
in mint 20.x It called document scanner instead of simple-scan.
 
OP
Alexzee

Alexzee

Well-Known Member
Joined
Jun 1, 2019
Messages
2,003
Reaction score
966
Credits
9,874
OP
Alexzee

Alexzee

Well-Known Member
Joined
Jun 1, 2019
Messages
2,003
Reaction score
966
Credits
9,874
After running the hplip-3.21....run the installer did it's job and now it can not detect the printer.

Fresh Install.png


I went to the page in the message and the page is not found.

Should I go to CUPS and try installing the printer that way?
 
OP
Alexzee

Alexzee

Well-Known Member
Joined
Jun 1, 2019
Messages
2,003
Reaction score
966
Credits
9,874
Code:
/usr/bin/hp-check:685: SyntaxWarning: "is not" with a literal. Did you mean "!="?
  if 'getfacl' not in g and '' is not g and 'file' not in g:
Saving output in log file: /home/cora/hp-check.log

HP Linux Imaging and Printing System (ver. 3.21.10)
Dependency/Version Check Utility ver. 15.1

Copyright (c) 2001-18 HP Development Company, LP
This software comes with ABSOLUTELY NO WARRANTY.
This is free software, and you are welcome to distribute it
under certain conditions. See COPYING file for more details.

Note: hp-check can be run in three modes:
1. Compile-time check mode (-c or --compile): Use this mode before compiling the
HPLIP supplied tarball (.tar.gz or .run) to determine if the proper dependencies
are installed to successfully compile HPLIP.                                   
2. Run-time check mode (-r or --run): Use this mode to determine if a distro   
supplied package (.deb, .rpm, etc) or an already built HPLIP supplied tarball   
has the proper dependencies installed to successfully run.                     
3. Both compile- and run-time check mode (-b or --both) (Default): This mode   
will check both of the above cases (both compile- and run-time dependencies).   

Check types:                                                                   
a. EXTERNALDEP - External Dependencies                                         
b. GENERALDEP - General Dependencies (required both at compile and run time)   
c. COMPILEDEP - Compile time Dependencies                                       
d. [All are run-time checks]                                                   
PYEXT SCANCONF QUEUES PERMISSION                                               

Status Types:
    OK
    MISSING       - Missing Dependency or Permission or Plug-in
    INCOMPAT      - Incompatible dependency-version or Plugin-version

 
---------------
| SYSTEM INFO |
---------------

 Kernel: 5.4.0-88-generic #99-Ubuntu SMP Thu Sep 23 17:29:00 UTC 2021 GNU/Linux
 Host: cora-System-Product-Name
 Proc: 5.4.0-88-generic #99-Ubuntu SMP Thu Sep 23 17:29:00 UTC 2021 GNU/Linux
 Distribution: 22 20.2
 Bitness: 64 bit


-----------------------
| HPLIP CONFIGURATION |
-----------------------

HPLIP-Version: HPLIP 3.21.10
HPLIP-Home: /usr/share/hplip
HPLIP-Installation: Auto installation is supported for linuxmint distro  20.2 version

Current contents of '/etc/hp/hplip.conf' file:
# hplip.conf.  Generated from hplip.conf.in by configure.

[hplip]
version=3.21.10

[dirs]
home=/usr/share/hplip
run=/var/run
ppd=/usr/share/ppd/HP
ppdbase=/usr/share/ppd
doc=/usr/share/doc/hplip-3.21.10
html=/usr/share/doc/hplip-3.21.10
icon=/usr/share/applications
cupsbackend=/usr/lib/cups/backend
cupsfilter=/usr/lib/cups/filter
drv=/usr/share/cups/drv/hp
bin=/usr/bin
apparmor=/etc/apparmor.d
# Following values are determined at configure time and cannot be changed.
[configure]
network-build=yes
libusb01-build=no
pp-build=no
gui-build=yes
scanner-build=yes
fax-build=yes
dbus-build=yes
cups11-build=no
doc-build=yes
shadow-build=no
hpijs-install=no
foomatic-drv-install=no
foomatic-ppd-install=no
foomatic-rip-hplip-install=no
hpcups-install=yes
cups-drv-install=yes
cups-ppd-install=no
internal-tag=3.21.10
restricted-build=no
ui-toolkit=qt5
qt3=no
qt4=no
qt5=yes
policy-kit=no
lite-build=no
udev_sysfs_rules=no
hpcups-only-build=no
hpijs-only-build=no
apparmor_build=yes
class-driver=no


Current contents of '/var/lib/hp/hplip.state' file:
Plugins are not installed. Could not access file: No such file or directory

Current contents of '~/.hplip/hplip.conf' file:
[upgrade]
notify_upgrade = true
last_upgraded_time = 1637250996
pending_upgrade_time = 0

[installation]
date_time = 11/18/21 11:29:34
version = 3.21.10


 <Package-name>        <Package-Desc>      <Required/Optional> <Min-Version> <Installed-Version> <Status>   <Comment>

-------------------------
| External Dependencies |
-------------------------

 cups                 CUPS - Common Unix Printing System                           REQUIRED        1.1             2.3.1           OK         'CUPS Scheduler is running'
 gs                   GhostScript - PostScript and PDF language interpreter and previewer REQUIRED        7.05            9.50            OK         -
 xsane                xsane - Graphical scanner frontend for SANE                  OPTIONAL        0.9             0.999           OK         -
 scanimage            scanimage - Shell scanning program                           OPTIONAL        1.0             1.0.29          OK         -
 dbus                 DBus - Message bus system                                    REQUIRED        -               1.12.16         OK         -
 policykit            PolicyKit - Administrative policy framework                  OPTIONAL        -               0.105           OK         -
 network              network -wget                                                OPTIONAL        -               1.20.3          OK         -
 avahi-utils          avahi-utils                                                  OPTIONAL        -               0.7             OK         -

------------------------
| General Dependencies |
------------------------

 libjpeg              libjpeg - JPEG library                                       REQUIRED        -               -               OK         -
 cups-devel           CUPS devel- Common Unix Printing System development files    REQUIRED        -               2.3.1           OK         -
 cups-image           CUPS image - CUPS image development files                    REQUIRED        -               2.3.1           OK         -
 libpthread           libpthread - POSIX threads library                           REQUIRED        -               b'2.31'         OK         -
 libusb               libusb - USB library                                         REQUIRED        -               1.0             OK         -
 sane                 SANE - Scanning library                                      REQUIRED        -               -               OK         -
 sane-devel           SANE - Scanning library development files                    REQUIRED        -               -               OK         -
 libavahi-dev         libavahi-dev                                                 REQUIRED        -               -               OK         -
 libnetsnmp-devel     libnetsnmp-devel - SNMP networking library development files REQUIRED        5.0.9           5.8             OK         -
 libcrypto            libcrypto - OpenSSL cryptographic library                    REQUIRED        -               1.1.1           OK         -
 python3X             Python 2.2 or greater - Python programming language          REQUIRED        2.2             3.8.10          OK         -
 python3-notify2      Python libnotify - Python bindings for the libnotify Desktop notifications OPTIONAL        -               -               OK         -
 python3-pyqt5-dbus   PyQt 5 DBus - DBus Support for PyQt5                         OPTIONAL        5.0             5.14.1          OK         -
 python3-pyqt5        PyQt 5- Qt interface for Python (for Qt version 4.x)         REQUIRED        5.0             5.14.1          OK         -
 python3-dbus         Python DBus - Python bindings for DBus                       REQUIRED        0.80.0          1.2.16          OK         -
 python3-xml          Python XML libraries                                         REQUIRED        -               2.2.9           OK         -
 python3-devel        Python devel - Python development files                      REQUIRED        2.2             3.8.10          OK         -
 python3-pil          PIL - Python Imaging Library (required for commandline scanning with hp-scan) OPTIONAL        -               8.4.0           OK         -
 python3-reportlab    Reportlab - PDF library for Python                           OPTIONAL        2.0             3.6.2           OK         -

--------------
| COMPILEDEP |
--------------

 libtool              libtool - Library building support services                  REQUIRED        -               2.4.6           OK         -
 gcc                  gcc - GNU Project C and C++ Compiler                         REQUIRED        -               9.3.0           OK         -
 make                 make - GNU make utility to maintain groups of programs       REQUIRED        3.0             4.2.1           OK         -

---------------------
| Python Extentions |
---------------------

 cupsext              CUPS-Extension                                               REQUIRED        -               3.21.10         OK         -
 hpmudext             IO-Extension                                                 REQUIRED        -               3.21.10         OK         -

----------------------
| Scan Configuration |
----------------------

 hpaio                HPLIP-SANE-Backend                                           REQUIRED        -               3.21.10         OK         'hpaio found in /etc/sane.d/dll.conf'
 scanext              Scan-SANE-Extension                                          REQUIRED        -               3.21.10         OK         -

------------------------------
| DISCOVERED SCANNER DEVICES |
------------------------------

device `hpaio:/net/envy_110_series?ip=192.168.0.17&queue=false' is a Hewlett-Packard envy_110_series all-in-one


--------------------------
| DISCOVERED USB DEVICES |
--------------------------

No devices found.

---------------------------------
| INSTALLED CUPS PRINTER QUEUES |
---------------------------------

 
ENVY_110_series_21F106_
-----------------------
Type: Unknown
Device URI: implicitclass://ENVY_110_series_21F106_/
PPD: /etc/cups/ppd/ENVY_110_series_21F106_.ppd
PPD Description: HP ENVY 110 series, driverless, cups-filters 1.27.4
Printer status: printer ENVY_110_series_21F106_ is idle.  enabled since Thu 18 Nov 2021 10:39:27 AM EST
warning: Printer is not HPLIP installed. Printers must use the hp: or hpfax: CUPS backend for HP-Devices.


--------------
| PERMISSION |
--------------

 
-----------
| SUMMARY |
-----------

Missing Required Dependencies
-----------------------------
None

Missing Optional Dependencies
-----------------------------
None

The HPLIP Toolbox is in the system tray.
 
OP
Alexzee

Alexzee

Well-Known Member
Joined
Jun 1, 2019
Messages
2,003
Reaction score
966
Credits
9,874
I shut down the pc and turned off the printer.
Rebooted and turned the printer on still no dice. I've got the same message as in post # 54.

BTW, I went to the website in the error message for help. The page is not found.

Taking a break for a while--
 

Lord Boltar

Well-Known Member
Joined
Nov 24, 2020
Messages
996
Reaction score
646
Credits
7,385
I see 2 things wrong
1) Current contents of '/var/lib/hp/hplip.state' file: Plugins are not installed. Could not access file: No such file or directory
2) warning: Printer is not HPLIP installed. Printers must use the hp: or hpfax: CUPS backend for HP-Devices
 
OP
Alexzee

Alexzee

Well-Known Member
Joined
Jun 1, 2019
Messages
2,003
Reaction score
966
Credits
9,874
I see 2 things wrong
1) Current contents of '/var/lib/hp/hplip.state' file: Plugins are not installed. Could not access file: No such file or directory
2) warning: Printer is not HPLIP installed. Printers must use the hp: or hpfax: CUPS backend for HP-Devices
How would I installed the plugins?

I don't understand why the warning is saying that HPLIP is not intalled it's in my system tray.
 
$100 Digital Ocean Credit
Get a free VM to test out Linux!


Top