Laptop audio not working (Everest ESSX8336/AMD Renoir/Kernel 5.15)

adorable.koala

New Member
Joined
Nov 28, 2021
Messages
2
Reaction score
1
Credits
31
Update 3 Dec: I've returned the Huawei so even though the issue still exits, I'll be unable to contribute to this issue. I'm leaving this post for other users facing the same issue.

Hi,

I got a new Huawei Matebook 14 (4800H, integrated graphics, touch screen).

Everything seemed to work besides the fingerprint reader (that I expected not to work) until I noticed that audio wasn't working.

I cannot see any entry in "Gnome Settings". The mic is also not detected so it appears that the internal sound card is not detected/recognized.

Audio via bluetooth works fine and connecting an external display works as well. When the external display is connected, something like "Radeon Renoir Digital Audio" is displayed.

My googling led to similar threads on here, reddit and SO. I've tried several "options snd_hda_intel" in modprobe but it's either worse or it doesn't change anything.

The unresolved issues are all mostly related to 4600H/4800H chips.

What I gathered was that these chipsets are relatively new, it'll take sometime to fix it, hopefully by 5.16 release. However, I am interested in helping out and tracking this issue as I've found multiple people facing the exact same issue.

I have tried booting into various live environments and testing but unsuccessfully. Currently, I'm waiting on another SSD and a few other things so I'm unable to clean install any distros but it feels like it's something that needs fixed in either the kernel/drivers.

Audio device on linux-hardware.org

uname -a
Bash:
Linux 5.15.4-201.fc35.x86_64 #1 SMP Tue Nov 23 18:54:50 UTC 2021 x86_64 x86_64 x86_64 GNU/Linux
## Fedora 35 uses pipewire and wireplumber

dmesg | grep snd
Bash:
[   13.477112] snd_rn_pci_acp3x 0000:04:00.5: enabling device (0000 -> 0002)
[   13.830198] snd_hda_intel 0000:04:00.1: enabling device (0000 -> 0002)
[   13.830287] snd_hda_intel 0000:04:00.1: Handle vga_switcheroo audio client
[   13.878847] snd_hda_intel 0000:04:00.1: bound 0000:04:00.0 (ops amdgpu_dm_audio_component_bind_ops [amdgpu])

lspci | grep Audio
Bash:
04:00.1 Audio device: Advanced Micro Devices, Inc. [AMD/ATI] Renoir Radeon High Definition Audio Controller
04:00.5 Multimedia controller: Advanced Micro Devices, Inc. [AMD] Raven/Raven2/FireFlight/Renoir Audio Processor (rev 01)

hwinfo --sound
Bash:
15: PCI 400.1: 0403 Audio device                            
  [Created at pci.386]
  Unique ID: P5_H.i47yftH9Mn3
  Parent ID: JZZT.e+TNXSUNut3
  SysFS ID: /devices/pci0000:00/0000:00:08.1/0000:04:00.1
  SysFS BusID: 0000:04:00.1
  Hardware Class: sound
  Model: "ATI Audio device"
  Vendor: pci 0x1002 "ATI Technologies Inc"
  Device: pci 0x1637
  SubVendor: pci 0x1e83
  SubDevice: pci 0x3e33
  Driver: "snd_hda_intel"
  Driver Modules: "snd_hda_intel"
  Memory Range: 0xd03c0000-0xd03c3fff (rw,non-prefetchable)
  IRQ: 73 (131 events)
  Module Alias: "pci:v00001002d00001637sv00001E83sd00003E33bc04sc03i00"

  Driver Info #0:
    Driver Status: snd_hda_intel is active
    Driver Activation Cmd: "modprobe snd_hda_intel"

  Config Status: cfg=new, avail=yes, need=no, active=unknown
  Attached to: #20 (PCI bridge)

ls /proc/asound/card0
Bash:
codec#0  eld#0.0  eld#0.1  id  pcm3p  pcm7p

ls /proc/asound/card1
Bash:
id  pcm0c

lsmod | grep -i snd
Bash:
snd_seq_dummy          16384  0
snd_hrtimer            16384  1
snd_soc_dmic           16384  1
snd_acp3x_pdm_dma      16384  1
snd_acp3x_rn           16384  3
snd_hda_codec_hdmi     73728  1
snd_soc_core          339968  3 snd_acp3x_rn,snd_soc_dmic,snd_acp3x_pdm_dma
snd_hda_intel          57344  5
snd_compress           28672  1 snd_soc_core
snd_intel_dspcfg       28672  1 snd_hda_intel
snd_intel_sdw_acpi     20480  1 snd_intel_dspcfg
ac97_bus               16384  1 snd_soc_core
snd_pcm_dmaengine      16384  1 snd_soc_core
snd_hda_codec         172032  2 snd_hda_codec_hdmi,snd_hda_intel
snd_hda_core          110592  3 snd_hda_codec_hdmi,snd_hda_intel,snd_hda_codec
snd_hwdep              16384  1 snd_hda_codec
snd_seq                90112  7 snd_seq_dummy
snd_seq_device         16384  1 snd_seq
snd_pcm               139264  8 snd_hda_codec_hdmi,snd_hda_intel,snd_hda_codec,snd_compress,snd_soc_core,snd_hda_core,snd_acp3x_pdm_dma,snd_pcm_dmaengine
snd_pci_acp5x          20480  0
snd_timer              49152  3 snd_seq,snd_hrtimer,snd_pcm
snd                   114688  28 snd_seq,snd_seq_device,snd_hda_codec_hdmi,snd_hwdep,snd_hda_intel,snd_hda_codec,snd_timer,snd_compress,snd_soc_core,snd_pcm
snd_rn_pci_acp3x       20480  0
soundcore              16384  1 snd
snd_pci_acp3x          20480  0

cat /sys/module/snd_hda_intel/parameters/model
Bash:
(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null)

cat /proc/asound/pcm
Bash:
00-03: HDMI 0 : HDMI 0 : playback 1
00-07: HDMI 1 : HDMI 1 : playback 1
01-00: DMIC capture dmic-hifi-0 :  : capture 1
 
Last edited:


Alexzee

Well-Known Member
Joined
Jun 1, 2019
Messages
2,077
Reaction score
1,012
Credits
10,380
It looks like you are running Fedora with Gnome. Is that correct?

Maybe try Pulse Audio to control the volume if you haven't already.
For that you would install 'pavucontrol'.

Another thing you could try is open the terminal and type: alsamixer.
Go through each column and make sure it's not muted. Raise up all of the colums with your upper arrow key.
To go through each column use the right and left arrow keys.

Hope that helps.
 
OP
A

adorable.koala

New Member
Joined
Nov 28, 2021
Messages
2
Reaction score
1
Credits
31
It looks like you are running Fedora with Gnome. Is that correct?

Maybe try Pulse Audio to control the volume if you haven't already.
For that you would install 'pavucontrol'.

Another thing you could try is open the terminal and type: alsamixer.
Go through each column and make sure it's not muted. Raise up all of the colums with your upper arrow key.
To go through each column use the right and left arrow keys.

Hope that helps.
Yep, Fedora with Gnome.

I had pulseaudio on Fedora 33 before I upgraded to Fedora 35 and it didn't help.

Pavucontrol doesn't list the internal cards just like Gnome settings. Same thing with alsamixer, just one bar and no choices in sound cards.
 

Alexzee

Well-Known Member
Joined
Jun 1, 2019
Messages
2,077
Reaction score
1,012
Credits
10,380
Yep, Fedora with Gnome.

I had pulseaudio on Fedora 33 before I upgraded to Fedora 35 and it didn't help.

Pavucontrol doesn't list the internal cards just like Gnome settings. Same thing with alsamixer, just one bar and no choices in sound cards.
Bummer:-

The only other thing I can think of is rolling back to a kernel that the sound did work.
 
$100 Digital Ocean Credit
Get a free VM to test out Linux!


Latest posts

Top