Help needed.


New Member
Apr 18, 2022
Reaction score

I have installed a copy of Linux mint onto an external 1tb hard drive. Made by Seagate. I can boot into the hard drive on the pc I used to install it to the external hard drive.

But I plugged the hard drive into another computer but it does not show up on my boot list. I disabled secure boot and it still did not show. I plugged in the USB I used to run the live boot environment and that showed up.

Can someone possibly help me get the external drive to show on my boot list.


Have you tried accessing the temporary boot menu and then selecting the external device? It'll vary, based on the OEM. You can try looking here:

Otherwise, you'll need a bootloader like GRUB installed. The software doesn't know that there's a working Linux on your external drive - it doesn't even know to look there 'cause (I'm assuming) Windows is controlling the boot process once you get past POST/BIOS/UEFI.
Yeah windows is controlling it on my other machine. The grub bootloader is installed on the external drive. Should i try to install it to my windows install?
I'd try to boot to it by picking it in the temporary boot menu - where you can (often) select a different drive to boot to. Once in there, you can install GRUB on the internal drive so that it'll let you boot to Linux when you choose to.
I am accessing my boot menu. F12 is the button. The only thing that shows is my windows boot manager
Hmm... Then you'll need to boot to a live instance, with the Linux hard drive plugged in, and install GRUB.

Be sure to backup any important data first.
Wait. Grub is installed on the external hard drive. Just not on the system im trying to run the hard drive on. I installed this as a to go installation hoping i wouldn't have to install anything else to the system im using to run it.
Hmm... And you can't pick it in the temporary boot menu? The same menu where you'd pick 'boot to usb' to install Linux in the first place. There's no other options there?

I'd maybe look in the BIOS to see if there's an option to change the boot order.

If it's not recognized, I'm not sure how to proceed - without installing GRUB on the Windows drive, that is.
The boot to usb shows up when i have the live env plugged in. Just not the hard drive. I already checked my bios and yet again the only thing that shows up is my windows boot manager. I have tried booting into it through the windows advanced start-up menu but just tells me there is no usb device plugged in to boot from and boots back into windows
Imma try and install linux mint to the hard drive through a vm instead as the hard drive as the only drive in the vm. And see if that works
I'm a bit VM fan, so there's that. VirualBox is easy and free. VMware Player is free for personal use, but not open source.
Still did not work. It still won't detect my hard drive. But now trying to boot with the hard drive in the vm causes my system to blue screen with PAGE_FAULT error
Hmm... I don't know enough about Windows to offer an opinion.

We do have some folks who still use Windows, so maybe one of them can chime in?
OK, thoughts,
Did you disable Windows fast boot in the BIOS if not windows will always have priority boot,

You haven't given us any information on your machine, please state full make & model number [and any modifications]

How are you connecting the Seagate hard drive, [if it's a full size 31/2" for desktops, or 21/2" for laptops] If it's a full size you will need a powered adaptor, if it's from a laptop then you will need either twin usb2 to SATA, or single usb3 to SATA connector to give it enough power,

sorry, can't help with VM
When you boot into Windows does it see the external drive?
does it see the Live Usb stick?
Last edited:
2 answer both questions.
Yes windows fast boot has been disabled in the bios.
My machine is a Acer aspire 5 11th gen intel i 5 8gb of ram with a 512gb nvme ssd.
The hard drive is connected through a usb to sata cable.
Yes when i boot into windows the drive is shown in device manager as partitioned.
Model number is: N20C4
Can you see it in bios? that is is there an option to boot from USB?