Accessing Turnkey Linux Fileshares from other Turnkey Linux containers


New Member
Aug 12, 2023
Reaction score
Hey there, fellow Linux explorers! I'm diving headfirst into the world of Linux, but I'm not looking to wait around until my grandkids are all grown up just to get my stuff sorted – you feel me?

1-[ I ventured into the realm of Proxmox (awsesome) to set up a Turnkey Linux (much awesome) Fileserver ]. After an hour or two of flipping through and playing with samba configuration windows trying to get windows filesharing working I was about to raise the white flag. Then from the kingdom of Proxmoxia a knight adorned with penguin armor came forth and showed me the light with
2-[ this awesome tutorial that totally worked easily How to setup Turnkey Linux Fileserver on Proxmox VE ]. Most gracious and splendid day.

Fast forward to the present, I'm basking in the glory of my functional file server. How sweet it is to be able to use it from my Windows machines, smoother than a jazz sax solo – no hiccups detected! This is the point however I could use a legend's guidance:
3-[ I'm now trying to mount one of the fileshares from the Turnkey Fileserver to other Turnkey Linux containers and am not experienced enough to know how to or the best way to go about it ]. I feel like I'm trying to find a unicorn at a cat convention. I am hoping there is a penguin around here somewhere that can lead me back to water. Not only would I very much appreciate understanding the solution to this (it's not the first time I tried and gave up), I figure I can’t be the only beginner stumped on this issue and help here could help others.

So, what do you say mighty administrator of the operations? Can you make history and lend your light to fellow brethren doomed to hours of grasping in the darkness? Your tale of the legend who helped the simpletons successfully connect to Turnkey Linux FileServer shares from other Turnkey containers on Proxmox will be sung far and wide for years to come, and scores of lost baby penguins will be able to return home to salty waters where we all belong. haha ok.

4-[ After confirming filesharing from my Turnkey Linux FileServer works from my Windows computer, below is what I've tried to mount one of the shares to another of my other Turnkey Linux Containers ]
  1. Logged into new Turnkey container and ran the following. It looks like it can authenticate and see the shares:

    root@mediaserver: apt-get install smbclient
    root@mediaserver: smbclient -L // -U myusername%mypassword
    lpcfg_do_global_parameter: WARNING: The "encrypt passwords" option is deprecated
    lpcfg_do_global_parameter: WARNING: The "syslog" option is deprecated
            Sharename       Type      Comment
            ---------       ----      -------
            share2        Disk   
            share1        Disk   
            IPC$            IPC       IPC Service (data node fileserver)
    SMB1 disabled -- no workgroup available

  2. Then I proceeded to create the /mnt/ directory for the share
    root@mediaserver: mkdir /mnt/share1

  3. Then I added the following mount details to fstab
    root@mediaserver: nano /etc/fstab
    // /mnt/share1 cifs username=myusername,password=mypassword,uid=1000,gid=1000 0 0
  4. I was so excited I thought I had it, but when I ran the mount command I got this:
    root@mediaserver:  mount -a
    mount: /mnt/share1: permission denied.

  5. I then tried to manually mount it using this command and got the same result:
    root@mediaserver: mount -t cifs // /mnt/share1 -o username=myusername,password=mypassword,uid=1000,gid=1000
    mount: /mnt/share1: permission denied.

  6. I thought since the error says /mnt/share1: permission denied. I could try temporarily changing the permissions of that folder to see if it that was the issue but it didn't work.
    root@mediaserver: chmod 777 /mnt/share1
    root@mediaserver: ls -l
    total 4
    drwxrwxr-x 2 root root 4096 Aug 12 02:31 share1
    root@mediaserver: mount -t cifs // /mnt/share1 -o username=myusername,password=mypassword,uid=1000,gid=1000
    mount: /mnt/share1: permission denied.

  7. I thought then maybe try changing ownership of the folder to see if that would help, but it didn't
    root@mediaserver: chown transmission:transmission share1/
    root@mediaserver: ls -l
    total 4
    drwxrwxr-x 2 myusername myusername 4096 Aug 12 02:31 share1
    root@mediaserver: mount -t cifs // /mnt/share1 -o username=myusername,password=mypassword,uid=1000,gid=1000
    mount: /mnt/share1: permission denied.

5-[ So I am just stuck for now. Wondering if this is obvious to anyone that could let me know what I'm doing wrong. Many blessings to you. ]
Last edited:

Members online