• We had to restore from a backup today after a failed software update. Backup was from 0000 EDT and restored it at 0800 EDT so we lost about 8hrs. Today is 07/20/2024. More info here.

Yum update error

G

geeks

Guest
I have 3 centos 6.2 servers which will not go online. Recently i have setup a centos 6.4 server which will go online and I have setup yum repo in that
When I gave update command(in 6.2 server) it gave the following error.

Error: Package: curl-7.19.7-37.el6_4.x86_64 (base)
Requires: libcurl = 7.19.7-37.el6_4
Removing: libcurl-7.19.7-26.el6_1.2.x86_64 (@Anaconda-CentOS-201112091719.x86_64/6.2)
libcurl = 7.19.7-26.el6_1.2
Updated By: libcurl-7.19.7-35.el6.x86_64 (base)
libcurl = 7.19.7-35.el6
Error: Package: e2fsprogs-1.41.12-14.el6_4.2.x86_64 (base)
Requires: libss = 1.41.12-14.el6_4.2
Removing: libss-1.41.12-11.el6.x86_64 (@Anaconda-CentOS-201112091719.x86_64/6.2)
libss = 1.41.12-11.el6
Updated By: libss-1.41.12-14.el6.x86_64 (base)
libss = 1.41.12-14.el6
Error: Package: e2fsprogs-1.41.12-14.el6_4.2.x86_64 (base)
Requires: libcom_err = 1.41.12-14.el6_4.2
Removing: libcom_err-1.41.12-11.el6.i686 (@yum)
libcom_err = 1.41.12-11.el6
Updated By: libcom_err-1.41.12-14.el6.i686 (base)
libcom_err = 1.41.12-14.el6
Error: Package: ntsysv-1.3.49.3-2.el6.x86_64 (base)
Requires: chkconfig = 1.3.49.3-2.el6
Removing: chkconfig-1.3.47-1.el6.x86_64 (@Anaconda-CentOS-201112091719.x86_64/6.2)
chkconfig = 1.3.47-1.el6
Updated By: chkconfig-1.3.49.3-2.el6_4.1.x86_64 (base)
chkconfig = 1.3.49.3-2.el6_4.1
Available: chkconfig-1.3.49.3-2.el6.x86_64 (base)
chkconfig = 1.3.49.3-2.el6
Error: Package: e2fsprogs-libs-1.41.12-14.el6_4.2.x86_64 (base)
Requires: libcom_err = 1.41.12-14.el6_4.2
Removing: libcom_err-1.41.12-11.el6.i686 (@yum)
libcom_err = 1.41.12-11.el6
Updated By: libcom_err-1.41.12-14.el6.i686 (base)
libcom_err = 1.41.12-14.el6

You could try using –skip-broken to work around the problem
You could try running: rpm -Va –nofiles –nodigest

How to fix this, Any inputs will be helpful.
 

Members online


Top