Ubuntu boot problem (No choice menu) directly loading win10

wizardfromoz

Super Moderator
Staff member
Gold Supporter
Credits
1,975
@atanere

maybe that wonderful, magical Wizard will steer you better while I go scratch my head for a bit.
Don't look at me, Kimosabe, my experience on Windows is 3 years out of date, and that is with Windows 7. Last thing I touched was Windows 8.1 on this Toshiba laptop, long enough to disable the secure bits, blow away Windows 8.1 and install all Linux.

For now, leave Secure Support enabled unless Wizard wants you to change it. Ubuntu should work with this setting enabled.
Yes, if Secure Support is the same as Secure Boot ... Matthew Garrett's Shim ships with all versions of Ubuntu and should allow it to boot alongside Windows, even if Secure Boot is in place. Note the underline with "should".

@Yara - you are doing very well under difficult circumstances, and thank you for all the information.

For easier viewing by The Viewers, Yara has captured these screenshots:




and





Yara, should you wish to do as I do any time - when you are in Imgur and have your photo uploaded, you can right-click in the photo and choose "copy image location". Then come into your reply pane here where you have started a message.

From the toolbar choose the little icon just right of the smiley face (smart tip shows "image". A small pane will open, press Ctrl-v for Paste and the internet address (URL) for your Imgur shot will appear in it. Press Enter and the picture is embedded into your message reply.

So Yara has the ESP (EFI System Partition) at /dev/sda2, Swap of 8 gig at /dev/sda6, and the Root partition is 100 GiB (102GB) at /dev/sda9. System is GPT formatted.

If I think of anything, I will let you know.

Cheers

Wizard
 


Yara

New Member
Credits
0
So Yara has the ESP (EFI System Partition) at /dev/sda2, Swap of 8 gig at /dev/sda6, and the Root partition is 100 GiB (102GB) at /dev/sda9. System is GPT formatted.
Hello @wizardfromoz Thanks for your help ,advice and support :)
/dev/sda2 this partition created directly by windows OS user didn't have any power to create it also it doesn't appear to user neither in win OS nor Linux it just shows here in this window.As those (/dev/sda1 , /dev/sda3, /dev/sda5 and /dev/sda the free space area (2.6 MB) All created directly by Win OS & doesn't appear to users)

/dev/sda4 created by user and appears for him in it Win OS Files.

Yes Swap of 8 gig at /dev/sda6, and the Root partition is 100 GB (102GB) at /dev/sda9. I create them while i installing Ubuntu. Also it ask me to create another partition at least 1MB so i create it. Its /dev/sda8 BIOS Boot 4.2MB ext4.



"System is GPT formatted" i don't know what is it means?
 

wizardfromoz

Super Moderator
Staff member
Gold Supporter
Credits
1,975
"System is GPT formatted" i don't know what is it means?
Good morning (where I am) Yara.

GPT is good news for Linux users whom may wish to boot more than one Linux.

If you Google "linux gpt msdos mbr" and read a few articles you will get a better understanding, although I know English is not your first language.

Under the MSDOS/MBR system, users are only allowed a maximum of four (4) Primary partitions, or else three (3) Primary and one (1) Extended.

So if you had Windows already on your computer, it might take up two to three of those partitions (I have even seen four just for Windows!), and you would then have to try to "carve back" a fourth, Extended, partition which you could then break into a number of Logical (sub) Partitions to install some Linuxes. And the numbering of the Partitions would be out of order ... very messy.

With GPT, each Partition is treated the same, as a Primary (main) partition, and they are numbered sequentially (in order). Thus you can have 10 partitions, as you have, or thereabouts, or even 50 partitions or more, if you have the space.

It is a much better system, so that is good for you.

Cheers

Wizard
 

atanere

Well-Known Member
Credits
0
Hang in there with us, @Yara... I think we will get it. I've installed Windows 10 and Ubuntu 17.10 now. And right away it was booting straight to Windows 10 with no option for Ubuntu. I have fiddled with the UEFI Secure Boot settings and tried to reinstall Ubuntu over the first Ubuntu.... and I'm now stuck at the grub> prompt. So, now in my best Homer voice.... "Woo hoo!" :D (How weird is that? To be so happy to break something? LOL)

But, I think I have broke it in a similar way as you did. Your screenshots of all the partitions on your hard drive were very helpful to put me on the right track.... or at least I hope I'm on the right track. I will explain in more detail later. But I may not get this complete tonight (my time) and have to carry on tomorrow.

Wizard is totally right (he usually is)... GPT is the better system. And so is UEFI. But I am no expert with it... although I am continuing to learn.

Cheers
 

wizardfromoz

Super Moderator
Staff member
Gold Supporter
Credits
1,975
Stan's (@atanere ) the Man. That is SO cool, Stan. :cool:

I'll leave you to do the voodoo that you do so well, but it makes me wonder whether Matthew Garrett's Shim is somehow not functioning properly with The Artful Aardvark, I might have a search around a little later. Launchpad might be a go.

Keep the faith, Yara, we (he) is/are getting somewhere ;)

Wizard
 

atanere

Well-Known Member
Credits
0
You're welcome, Yara... we are glad to help. But we're still not there yet. I have spent quite a bit of time working on it today, but I did not reach that "Aha!" moment I was hoping for. I have just finished installing Windows 10 and Ubuntu both again from scratch for the 2nd time so that I can try things out a little differently.

In both cases, with a fresh Windows/Ubuntu installation yesterday and again today, it started off by booting straight into Windows, as I mentioned above in post #24. So that seems to be the same issue you're having. I was also able to boot Ubuntu with the F9 boot menu, as you can too. But the first solution I offered to you (the Windows command: bcdedit /set {bootmgr} path \EFI\ubuntu\grubx64.efi) has worked for me both yesterday and today. And it doesn't seem to require the shimx64.efi file that we also considered, but it also works too. (So, Wizard, there is nothing wrong with the shim at all.) Yesterday, however, for unknown reasons, it started going straight back to Windows 10 after awhile. I used the bcdedit command again and it returned to the GRUB boot menu and stayed there (until I reinstalled again).

Yara, all of the info you have provided has been very helpful. But please let me trouble you for a couple more things to looks at. Use the F9 boot menu to get back into Ubuntu, click the Show Applications icon (the 9 dots shaped as a square) and type DISKS (enter). This is the app that you used to create the pictures showing all your partitions. I don't need a picture, but just click on the partition for /dev/sda8 -- I am curious if that still shows "BIOS Boot" as the "Partition Type" as it did in your picture. I think that maybe it doesn't say "BIOS Boot" now (which would be good, but it may not be important anyway).

Next, click on your Show Applications icon and open up Terminal. Enter the command efibootmgr and let us know the results from that. Thanks!

The efibootmgr is another tool that can change the boot order, like bcdedit in Windows. But the output you show us from above will indicate what the boot order currently is. I kind of suspect that it will already show Ubuntu is first... because I think you successfully used the bcdedit command earlier.

One last thing that might help, but I'm not sure. I was reviewing your "pastebin" file that you linked to after running the boot-repair app. That report shows that Windows 10 does not fully shut down when you tell it to. Instead, it goes into a power-saving mode called "hibernation" so that it will boot faster back into Windows 10. Because all of these issues are boot related, I have to wonder about this hibernation status too. So, let's turn off Windows hibernation for now. It is easy to turn back on later if you choose. Boot into Windows 10, and open a Command Prompt as the Administrator like you did for bcdedit... but this time give this command: powercfg -h off and hit enter. (It does not report successful or give any other feedback.) Full instructions to turn off and on are here... plus some additional info on checking your power options if you leave the setting off. (Basically, if you leave hibernate disabled, you don't want any power options to tell the computer to hibernate... so take a look at these options too if you leave it disabled.)

OK, I gotta run... this is probably all for tonight again. Still scratching my head! :D

Cheers,
Stan
 

Yara

New Member
Credits
0
Hello @atanere I've Troubleshoot ( Lunch problems) with win10 now so after i repair it ,I'll do all steps you advice so
please forgive me for being late. Thanks a lot. Also i guess that hibernate is the problem as you saying because when shutdown win10 i always have to tern off the power key by my self that's happened from the first time installed win10

Yes /dev/sda8 Still BIOS Boot
 
Last edited:

atanere

Well-Known Member
Credits
0
Hello @atanere I've Troubleshoot ( Lunch problems) with win10 now so after i repair it ,I'll do all steps you advice so
please forgive me for being late. Thanks a lot. Also i guess that hibernate is the problem as you saying because when shutdown win10 i always have to tern off the power key by my self that's happened from the first time installed win10

Yes /dev/sda8 Still BIOS Boot
Okay... I don't think BIOS Boot is the problem, and we could probably safely delete that partition. But I also don't think it will hurt to leave it. With Secure Boot turned on, you are actually booting from /dev/sda2, which is the EFI partition.

By the way, if you want to download a Windows 10 .iso file so you can make a backup DVD/USB, here is a link from Microsoft: https://www.microsoft.com/en-us/software-download/windows10ISO -- this is fully legal, and because you already have a licensed copy on your computer, if you reinstall Windows it should activate properly. But no need for us to do that, I don't think, unless you want to reinstall it to resolve the other Windows 10 problems you are having. Also, if your computer came with Windows 10, there is probably an app from HP that will make a "System Recovery" set on DVD or USB. The difference between the HP System Recovery and the Microsoft link above is that HP will probably include all of their "bloatware" that they also install on new computers.

Cheers
 

Yara

New Member
Credits
0
command: powercfg -h off and hit enter. (It does not report successful or give any other feedback.) Full instructions to turn off and on are here... plus some additional info on checking your power options if you leave the setting off. (Basically, if you leave hibernate disabled, you don't want any power options to tell the computer to hibernate... so take a look at these options too if you leave it disabled.)
Hello @atanere @wizardfromoz

First i repair win10 boot then in Win command as administrator copy/past the command powercfg -h off hit enter
Also flowed all instructions in link
Retyped command powercfg -h off hit enter
then retyped bcdedit /set {bootmgr} path \EFI\ubuntu\grubx64.efi
Win10 shutdown then turn on the laptop directly lunch win10

2nd
Terminal. Enter the command efibootmgr and let us know the results from that. Thanks!
That what terminal said


i didn't do any thing after that

Please see this link
this is a report from repair boot APP for windows OS i guess it could help.
Thanks.
 

Yara

New Member
Credits
0
I have just finished installing Windows 10 and Ubuntu both again from scratch for the 2nd time so that I can try things out a little differently.
Thanks for your help. But please don't install them again as i know it is bad for your laptop.
now i have win10 cd if you want to try any thing tell me and i'll do it. Thanks
 

atanere

Well-Known Member
Credits
0
Thanks for your help. But please don't install them again as i know it is bad for your laptop.
now i have win10 cd if you want to try any thing tell me and i'll do it. Thanks
Hi @Yara. No, no harm to computer... I will gladly reinstall them again if I think I can gain a better understanding. But I am still stuck scratching my head. But, we can still chat about this and see if we can come up with some more ideas, and maybe Wizard will also find some new magic spell to help. :D

OK on making a Windows install disk. As I mentioned earlier, if we started everything over from scratch, we might cure this problem. But... we might not either. So that is a big step (and a lot of work) for you to take, and we should still hold off on it since it might not even work. (Unless you have other Windows problems that you might want a re-install to fix.)

EasyBCD, the program mentioned in your link, might work... but again, it might not either. There is another similar program called rEFInd that I tried to install and use on my first Windows/Ubuntu install, but it did not work for me. And I'm reluctant to have you install more programs that may further confuse the UEFI boot process unless I can have more comfort in thinking they will work. For me, it was easy enough to re-install both OS'es and then rEFInd was gone, but I don't want to take you closer to reinstalling Windows if not necessary.

I am also finding somewhat conflicting information from efibootmgr on my own system that I can't explain. My efibootmgr reports that it boots the Windows Boot Manager (BootCurrent).... but it actually loads the GRUB to get to Ubuntu. Still, this is worth a try for you to see if it will change the boot order since bcdedit seems not to work. You can review the full instructions for efibootmgr here if you want to better understand this tool. But lets try these (these number are based on your efibootmgr output you gave above, and also note that there are no spaces between the numbers and commas that separate them):

Open a terminal, and enter the following:
sudo efibootmgr -o 2001,0000,0001
(To clarify, the -o is a lowercase letter "O". After entering this command, reboot and see if it starts with GRUB/Ubuntu.)

If the above failed, let's try some other variations of the same thing:
sudo efibootmgr -o 2001,0002,0001
(Again, reboot and see if it boots GRUB/Ubuntu.)

If the above failed, let's try again:
sudo efibootmgr -o 2001,0004,0001
(Again, reboot and see if it boots GRUB/Ubuntu.)

You probably see what we're doing here... we're telling it to make your USB drive the 1st in the boot order, then switching between each of the 3 different Ubuntu listings, while keeping Windows as the last option.

Then, if all of those fail.... let's see if yours is "backwards" as mine seems to be.... and we'll put Windows ahead of Linux and see what happens! Like this:
sudo efibootmgr -o 2001,0001,0000
(And reboot to see what happens. Worst case is it goes to Windows, but nothing should break from these steps.)

OK, will keep scratching my head and see how you do with all these efibootmgr commands. With luck, one will work, but I am not overly hopeful right now. By the way, we can also use efibootmgr to delete some of those excess entries in your boot menu, but I don't think they are hurting anything to be there.

At the rate that we're going... we may find that the only way of getting into Linux will be for you to use the F9 method. At least, so far, that has consistently worked for you.

Cheers
 

Yara

New Member
Credits
0
At the rate that we're going... we may find that the only way of getting into Linux will be for you to use the F9 method. At least, so far, that has consistently worked for you.
Hi @atanere
I tried all of them and failed. But i note something all we done actually did not saved see the bellow photos

1- in this photo what " sudo efibootmgr " said for the first time i use it

You will note That 2002, 2003 Not in the list
And 3001 is HD

This photo after i wrote the code

this time i made usb 1st and other Ubuntu and NO win
to make sure that it saved i rerun " sudo efibootmgr " twice 1st time here and close the terminal and rerun for 2nd time it show exactly as 3rd part in this photo

so i restart Ubuntu it directly lunch win10.
But when i go to Ubuntu using f9 and open terminal and run sudo efibootmgr it show me what in photo No1
Nothing saved
 

atanere

Well-Known Member
Credits
0
This photo after i wrote the code
Hi @Yara, I am not sure that this is saving the changes either (like bcdedit seems not to).... but in your example above I do see that you have the command incorrectly. You need a space on both sides of -o but no spaces between the numbers and commas. The only example you show is in the middle of the screen where you issued a command to change things, but it shows -o2001 all run together with no space (but the numbers and commas are correct).

If you run each command to make the change, and immediately then use just efibootmgr (or sudo efibootmgr) then it will show you the change in boot order that you gave it. The real question is whether is will execute those changes and keep them saved after the reboot process. So, if not too much trouble, please try them again. I would love for one of them to work, but as I said before... I am losing hope. It almost seems like the UEFI boot order is "locked" but I've not read anything that indicates this is possible. These commands, efibootmgr and bcdedit, should make these changes, and they did work on my installations. It is quite confusing, for sure.

Cheers
 

Yara

New Member
Credits
0
Hi @Yara, I am not sure that this is saving the changes either (like bcdedit seems not to).... but in your example above I do see that you have the command incorrectly. You need a space on both sides of -o but no spaces between the numbers and commas. The only example you show is in the middle of the screen where you issued a command to change things, but it shows -o2001 all run together with no space (but the numbers and commas are correct).

If you run each command to make the change, and immediately then use just efibootmgr (or sudo efibootmgr) then it will show you the change in boot order that you gave it. The real question is whether is will execute those changes and keep them saved after the reboot process. So, if not too much trouble, please try them again. I would love for one of them to work, but as I said before... I am losing hope. It almost seems like the UEFI boot order is "locked" but I've not read anything that indicates this is possible. These commands, efibootmgr and bcdedit, should make these changes, and they did work on my installations. It is quite confusing, for sure.

Cheers
This was the only time i removed space


after reboot Ubuntu
 

atanere

Well-Known Member
Credits
0
This was the only time i removed space
Okay. I was afraid it still would not work. I'm not worried about those other number either (2002,2003)... and I don't think they are the solution, although you can try them with the efibootmgr command if you want.

Still scratching my head on this one. o_O And for now, it still seems like your only option is F9 to boot Ubuntu. I will keep thinking about it though and reply again if anything else comes to mind. Tomorrow is my last day off, and when I go back to work I am less active on here since I work 12-hour shifts.

Cheers
 

atanere

Well-Known Member
Credits
0
Hi @Yara. Another thing that has confused me about your hard drive partitions is that you seem to have 2 Windows Recovery partitions, /dev/sda1 and /dev/sda5, and they are different sizes. I can't quite imagine how this happened, but there is no chance that Ubuntu did this. When I re-installed Windows 10, it only created /dev/sda1 for recovery. But I also cannot imagine how this could be the cause of the boot issue that we can't seem to cure.

If you ultimately decide to re-install both Windows 10 and Ubuntu, I think I would follow these steps:

1. Go into the BIOS Setup first, and on the "Exit" screen, choose "Load Setup Defaults" and then "Exit Saving Changes". This should ensure that everything is set properly for UEFI, and Secure Boot will be enabled.

2. Backup any important files first, then run the Windows 10 Setup (or HP Recovery, if you made one). Don't choose any "repair" option, but instead do a full installation (or full HP Recovery). This should use up the entire hard drive and just create one recovery partition like normal (unless HP Recovery would cause something to be different from normal). Run Windows and disable hibernation was you did earlier. (Can't use bcdedit yet because Ubuntu is not installed yet.)

3. Carefully run the Ubuntu installer. When it asks to install third-party software, do not do this because it will require you to turn off Secure Boot. Otherwise let it make the default hard drive decisions, except that you can "drag the dividing line" between the Windows and Ubuntu partitions to resize the partitions to your liking (if you prefer to give Windows more space, for example). Do not encrypt the Home folder unless privacy/security is greatly needed.

4. If, after rebooting, it goes straight into Windows 10 (as mine did)... then it would be necessary to use the bcdedit command in the Administrator Command Prompt of Windows. With that, then mine began to boot up the GRUB menu where I could choose either Ubuntu or Windows. I mentioned before too that at one point, my install reverted back to going straight into WIndows, and I had to use the bcdedit command again.... this could be an ongoing problem with Windows 10, and especially after Windows runs updates.

But, if you still don't yet feel the need to re-install Windows.... then don't do it. As I said before, it may or may not fix this boot issue (although it might clear up any other issues that you may be having). Windows 10 has been very difficult to work with, and so has the BIOS changeover to UEFI. Linux has been making progress, especially with UEFI and Secure Boot, but there still seems to be lots of room for problems.

I am now going to go try that EasyBCD boot manager to see if it will work on my setup. Will let you know later about that. But your link seems to indicate that it may not work with Secure Boot, and it seems to recommend GRUB instead. Oh well, we will see what happens.

Still scratching my head.... :confused:

Cheers,
Stan
 

atanere

Well-Known Member
Credits
0
Well, EasyBCD didn't work. I got the error your link showed... meaning it can't work in UEFI mode, even though it says it is UEFI compatible. It's kind of funny... it blames Microsoft, but then suggests using GRUB2 (or disable UEFI and Secure Boot... which is not necessary to run Ubuntu).

I again tried rEFInd too. It seems to install cleanly, but I can't see that it does anything more than add more entries into the BIOS boot manager. It doesn't provide a boot menu of its own.... and GRUB still launches as it did before installing rEFInd. Maybe it is my own experience with this application.... I have never used it before, so maybe I'm missing something, even though it installs okay.

Still scratching my head.... :confused:

Cheers
 

atanere

Well-Known Member
Credits
0
And, with even more strange Ubuntu news.... at least HP is not (yet) mentioned to have this problem. But it might be a good reason to pause and wait for more information to come out from Canonical since 17.10 is the version that we have been working on. So far, the issues we have been working on do not seem to apply to this new found flaw.
 

Yara

New Member
Credits
0
Hi @Yara. Another thing that has confused me about your hard drive partitions is that you seem to have 2 Windows Recovery partitions, /dev/sda1 and /dev/sda5, and they are different sizes.
Hi @atanere Wow that is really strange. I didn't note that i only focus of Ubuntu partitions i'd made.

f you ultimately decide to re-install both Windows 10 and Ubuntu
Actually i'm going to delete all partition and remake them.

Carefully run the Ubuntu installer. When it asks to install third-party software, do not do this because it will require you to turn off Secure Boot. Otherwise let it make the default hard drive decisions, except that you can "drag the dividing line" between the Windows and Ubuntu partitions to resize the partitions to your liking (if you prefer to give Windows more space, for example).
I used to install Ubuntu from "Allocate drive space" Something else option i'd prefer to but them in separated partitions for more safety you knows if any case happened to OS i don't have to reinstall All OS .Also it always ask to make "third-party" and it don't give me option to do this or not.This "drag the dividing line" option didn't gave to me.So as i understand from you that you want me to chose the in "Allocate drive space" to install "Ubuntu beside Windows" option.What size should do i make for both of them? Also i don't know if it allow me to make swap partition or what?

Do not encrypt the Home folder unless privacy/security is greatly needed.
I don't know where can i found this option?

Also after install Ubuntu do you want me to use repair boot command in terminal or not?
There is an APP called "APTonCD" This tool will allow you to create a media (CD or DVD) to use to install software via APT in a non-connected machine, as well upgrade and install the same set of softwares in several machines with no need to re-download the packages again. So if i use it Is That effect on new Ubuntu i installed or not?

I'll wait for your response before reinstall them.
Thanks and sorry for many questions
 


Members online


Top