Purchase Linux CDs / DVDs / Flash Drives at OSDisc.com

Welcome to Our Community

While Linux.org has been around for a while, we recently changed management and had to purge most of the content (including users). If you signed up before April 23rd, 2017 please sign up again. Thanks!

  1. More ways to get the info! - we shoot all of our new original content out as well as random messages on Twitter and our newsletter!. Twitter | Newsletter
    Dismiss Notice

Store installed LM 18.1, Wish to replace with my original LM 18.3

Discussion in 'General Linux' started by whazzupdoc, Apr 14, 2019.

  1. whazzupdoc

    whazzupdoc Active Member

    Joined:
    Jun 21, 2018
    Messages:
    191
    Likes Received:
    30
    Plain and simple the Sylvia 18.3 download has failed. I put the USB in the #1 Boot priority...and after a really crummy start up involving those messages I've sent to you, it finally comes up in Serena 18.1. It's just not working, Chris.


    (Log in to hide this advertisement)


    Let me go back to a far-out question I asked a week or so ago. Is there a way to backup onto our (T5) the Sylvia 18.3 OS that is currently operating on the split/C of this Win7 desktop? It's already there...and current. Then plug the T5 into the Toshiba and open up TimeShift on the Toshiba and tell it to Restore? Am I crazy or can this be done?...and if so, what steps do we need to take?

    Right now the Toshiba is a bear to get into and I'm not comfortable with what I've done to my notebook. I'll need it in a couple of months to take back to the U.S. since I can't take the desktop...it's got to be working and I can't seem to get out of the starting block. I can't even seem to be able to properly download and burn a bootable 18.3 that by all indicators you've given...should work.

    Sorry I missed you tonight!
    Doc
     
  2. whazzupdoc

    whazzupdoc Active Member

    Joined:
    Jun 21, 2018
    Messages:
    191
    Likes Received:
    30
    Burned18.3ThumbDr.PNG

    This is driving me crazy. I know I told unetbootin to burn...went thru you steps but just put the thumbdrive into the usb port on this desktop and the F Drive shows up with all the files on in but shows 10.8GB as 'Unused'. Didn't you say that tells us the burn did not take place?

    I've taken a Snippet of the F Drive and have tried to upload it so you can see the contents but once again it doesn't appear (prior to me posting this) to have been uploaded. It may show up after I hit the Post Reply.

    Going to bed!
    Doc
     
    #62 whazzupdoc, Apr 26, 2019
    Last edited by a moderator: Apr 26, 2019
  3. wizardfromoz

    wizardfromoz Super Moderator
    Staff Member Gold Supporter

    Joined:
    Apr 30, 2017
    Messages:
    2,982
    Likes Received:
    2,348
    Just a holding Post, Dick, I have fixed that picture above, you chose thumbnail instead of fullsize.

    The burn looks good :), it has everything that is needed.

    Have you tried F12, there are usually 2 key combos associated with Setup, we want just to change the boot order for even one boot?

    No, that was before The Bodgy Brothers got to it in the big smoke ... just burning an iso (even only 2 GB) to eg a 16 GB thumb drive will seem to effectively fill the drive, it's the nature of the burn process to account for all space.

    Once we include Persistence, the ball game changes, and you have Persistence on that burned drive, showing as

    casper-rw 2GB or so (that was the 2048 we put on).


    Maybe, but that won't get you any settings back, updates, &c. That is a pristine install of Sylvia. and you have to have Timeshift working on the Toshiba. Otherwise you have to be able to boot from the bootable stick, which has Timeshift incorporated into it.


    If that is so, we may have a workaround. I will get back to you.

    Wiz
     
  4. atanere

    atanere Moderator
    Gold Supporter

    Joined:
    Apr 6, 2017
    Messages:
    1,838
    Likes Received:
    1,941
    I found a Users Guide for Toshiba Satellite C600-series laptops, and it does indicate F12 is the key to bring up the Boot Menu. But to maybe try to clarify a little... you don't "change the boot order" when you get to this screen (like F5/F6 in BIOS). I think you "arrow down" until the USB is the one that is highlighted (probably blue), then hit Enter. So, of course, the USB has to be plugged in before powering up, so it will be recognized.

    Okay, butting out. Good luck Doc!

    Cheers
     
  5. whazzupdoc

    whazzupdoc Active Member

    Joined:
    Jun 21, 2018
    Messages:
    191
    Likes Received:
    30
    O.K., that did something different. You were right (as usual!). F2 is System Utility; F12 is Setup Boot. I had used the F2 and the f5/f6 arrows and moved USB into the #1 position and that didn't give me the result I wanted.

    Following your above instruction, I went back and changed the USB to #3 position and hit Enter. Up came the screen that says...SYSLINUX 4.03 2010-10-22 EDD Copyright (C) 1994-2010 H. Peter Anvin et al. However the cursor just sits blinking on the next line. No boot. ???
    Doc
     
  6. wizardfromoz

    wizardfromoz Super Moderator
    Staff Member Gold Supporter

    Joined:
    Apr 30, 2017
    Messages:
    2,982
    Likes Received:
    2,348
    Moving onto Plan C (or is it D?) tomorrow, Dick, don't despair. :)

    In the meantime I want you to try 2 things, one is exploring your BIOS setup, the other a little more complex but will buy us more space with

    1. Now that you are familiar with the differences between F2 and F12 keys, I want you to check to see if there are any fields/options on any of the tabs for enabling USB support. Also anything about Secure Boot (unlikely) or something about "Trust" eg Platform Trust Technology (PTT) (unlikely).

    If you have a vertical menu, and it has a "filled" arrowhead pointing right click on it and there may be more options.

    1. b. I think your setup utility may be Insyde H20, rev xx.xx, date. See if you have that at top of page and report back.

    2. Annoying errors/warnings can be eliminated (likely)

    .ICEauthority

    Unplug the thumb drive if it is in place. If you can get into Serena, open a fresh instance of Terminal and enter (note the . period with each command)

    Code:
    sudo rm .ICEauthority
    Always exit Terminal by typing and entering exit, not clicking the X at top-right.

    Exit Terminal and reboot from Menu, or from the small human bust in systray.

    .Iceauthority will regenerate, but should be OK now? :)

    Do the same with .dmrc

    Code:
    sudo rm .dmrc
    Exit Terminal and reboot. Warning should be gone.

    .dmrc is a very small file containing, in your case,

    Code:
    [Desktop]
    Session=cinnamon
    It will not regenerate with the reboot.

    Then there is 3.

    OK, I lied, there are 3 things. Sue me.

    3. We need a little more space on Serena before we can use its Timeshift, thanks to The Dodgy Bros., you cannot even save some screenshots before you are told insufficient space.

    Go to Terminal again, and this time I want you to type in and enter, and follow any prompts

    Code:
    sudo apt-get purge libreoffice*
    Once that is completed

    Code:
    sudo apt-get purge thunderbird*
    Once that is completed, open Nemo File Manager, down left-hand side to Trash, right-click and Empty, if applicable (may all be gone).

    This will free up 485 MB (almost half a gig) of space and allow us to continue.

    4. (Oops lied again)

    Terminal -

    Code:
    sudo apt-get -y install gparted
    Once GParted is installed, go to Menu, start to type in gparted, right click its entry and add to Panel.

    See you my tomorrow.

    Wiz

    Edited - amended typo on .ICEauthority
     
    #66 wizardfromoz, Apr 27, 2019
    Last edited: Apr 28, 2019
  7. whazzupdoc

    whazzupdoc Active Member

    Joined:
    Jun 21, 2018
    Messages:
    191
    Likes Received:
    30
    Hi...sorry but to cover each of your above items I've got to go back and forth between instructions and the Toshiba.

    Re: 1. At the top of the F2 screen: Main--Security--Power Management--Advanced--Boot
    Note: At the very top of this F2 screen is the page title... 'InsydeH20 Setup Utility Rev . 3.5
    I've before given you the choices (and order of choices) under Boot; however under Advanced the
    choices are: Boot Speed: Normal
    Execute-Disable Bit Capability: Available
    Beep Sound: On
    USB Legacy Emulation: Enabled
    ---System Configuration (takes you to sub-config of PCI Lan, Pointing Device, Web
    Camera, SATA Controller Mode and Power On Display
    Of possible interest under Advanced is Boot Speed: Normal (Other choice is Fast) where on a far right panel
    concerning Boot Speed is Item Specific Help where we're told under the 'Fast' choice that this is a setting to
    reduce the time BIOS needs to initialize. Sets the BIOS to boot only from a built-in HDD (SSD), support only
    the internal LCD and keyboard, and not display the boot logo. There are no restrictions when using Windows.
    Normal---Set the BIOS to normal boot.

    When I opened Terminal and entered the .Iceauthority command per above...I was told it does not exist.

    MODERATORS'S NOTE - My bad/booboo... above amended

    However, when I reboot neither does that message show up again!!!!

    2. .dmrc.....done
    3. purged both LibreOffice & TBird ; opened Nemo and verified it was clean
    4. installed gparted from Terminal and added to panel.

    Good job, Wiz...and the 18.1 is acting normal again! I took some screenshots as I worked along but they don't appear to be necessary to send on. Looking forward to tomorrow.
    Doc
     
    #67 whazzupdoc, Apr 27, 2019
    Last edited by a moderator: Apr 28, 2019
    Vrai likes this.
  8. wizardfromoz

    wizardfromoz Super Moderator
    Staff Member Gold Supporter

    Joined:
    Apr 30, 2017
    Messages:
    2,982
    Likes Received:
    2,348
    Good news, so we have chased that recalcitrant angry bear away for now.

    The next step is to prepare, using GParted, the target drive where LInux Mint 18.3 'Sylvia' Cinnamon is going to be restored to using Timeshift.

    We're going to restore Sylvia to the older of the 2 SSDs, that is the 500 GB Samsung 860, NOT to the newer, 1 TB Western Digital.

    Reasons for this include but are not limited to:
    • We want Timeshift to have the easiest job restoring Sylvia, and because The Dodgy Bros. made such a mess of the WD ... we can clean that up after you have a working Sylvia
    • The Samsung has only the two (2) roughly evenly-sized partitions which we are going to blow away and then create new partitions and format them to MSDOS rather than GPT, this will match the structure of the Snapshots Timeshift has stored on the T5
    Let's see if we can stop this running around between the computers?

    On the Toshiba, launch Firefox, and see if you can get linux.org up OK, but don't sign in.

    Press Ctrl-Alt-t to open Terminal.

    Are you familiar with the key combination Alt-Tab? It can be used to move backwards and forwards between open Windows (even if they are fullscreen).

    Either Alt key will do it but it is just as easy to say press and hold your right Alt key, then tap Tab a couple of times and you will see it alternate between the Terminal window and the Firefox window or screen.

    If you are happy with that, then you can sign out of here on the desktop, and take up residence on the Toshiba.

    I'll be back in a bit, have to do some voodoo elsewhere, and then we'll launch GParted and get cracking.

    Wiz
     
  9. whazzupdoc

    whazzupdoc Active Member

    Joined:
    Jun 21, 2018
    Messages:
    191
    Likes Received:
    30
    I understand and have practiced it a couple of times now.
    Doc
     
  10. wizardfromoz

    wizardfromoz Super Moderator
    Staff Member Gold Supporter

    Joined:
    Apr 30, 2017
    Messages:
    2,982
    Likes Received:
    2,348
    #66 I made an error, that should have been .ICEauthority, not .Iceauthority, no wonder no sign of the file :oops:

    I have edited the Post, so if any future probs, follow amended command.

    GParted Steps

    I have as closely as possible duplicated your partition setup on the Samsung SSD, that is your device /dev/sdb.

    Screenshot is as follows, note the similarities and don't mind the differences :)


    [​IMG]

    SCREENSHOT 1 - WIZARD'S GPARTED MOCKUP

    Names and sizes are the same, Used is the same for the first one. Partition numbers yours are /dev/sdb.

    Ignore my unallocated space, it's a 2 TB drive.

    Note where my cursor is pointing. Your first window will likely default to your /dev/sda, so you need to click the down elevator button to get to your /dev/sdb and see your circumstances. Do so. (You can Alt-Tab between the GParted window and linux.org on Firefox, to check instructions).

    We're going to blow these 2 away, one at a time. Unplug the T5, we're taking no chances with those snapshots. :D

    Between your /dev/sdb1 and "Internal Storage B" there may still be a small telephone handset icon, that means it is Mounted, we have to unmount it first. Right-click the line it is on and choose unmount, it will take a few seconds.

    Likewise when we get to the second line, it had a black and white exclamation mark icon, that won't likely need unmounting, but check anyway (likely grayed out).

    One at a time, we are going to right-click the entries and choose to delete. Screenshot shows.


    [​IMG]

    SCREENSHOT 2 - GPARTED - STARTING PARTITION DELETE - REFERS TO DICK'S /DEV/SDB1

    Note that at the bottom of the window, 0 (zero) operations are pending, and that the little curved arrow at the top under Help is grayed out.

    Delete, and then repeat the process with the next line down. Screenshot shows


    [​IMG]

    SCREENSHOT 3 - FINAL SHOT BEFORE DELETING PARTITIONS

    Here we can see the two partitions appear to have been deleted, but now there is a pane at the bottom showing the two pending operations, that needs to be addressed.

    Note that the two curved arrows at top are now black - the one on right shows, with Smart Tip of mouseover as Apply All Operations. The one next to it, if moused over, will show undo last operation, so you get a chance to change your mind.

    Click the right-hand arrow and the operations will show their progress and proceed to completion.

    At the end, we have a whole lot of unallocated space (a little short of 500 GiB for you), which can be made use of.

    Finished with GParted?

    Not quite :). Timeshift is smart, but not that smart. It can't restore into unallocated space, it needs a partition set in place.

    So we will set up a base partition of, say, 40 GiB, and then see what Timeshift requires of us to proceed to restore Sylvia.

    Before we do that, we may need to accommodate a Partition Table that transforms that unallocated space from, eg GPT to MBR (Master Boot Record).

    I have to revisit some of your screenshots in this Thread, and perhaps some from the old 10-pager, and make sure we are on track.

    So go ahead with what I have described above, and report back that all (hopefully) is good, and I will catch you on my " 'morrow" (Bard).

    Don't fret on any of this - we are doing nothing to
    • Jeopardise the contents of the T5, nor
    • Adversely affect the working operations of the less bear-like Serena's operation
    Cheers

    Wizard
     
  11. whazzupdoc

    whazzupdoc Active Member

    Joined:
    Jun 21, 2018
    Messages:
    191
    Likes Received:
    30
    Upper right down to dev/sdb.../dev/sdb1 and /dev/sdb2 neither were mounted. I'll try to attach screenshots. I'd like to be sure that we're to be working only with this /sdb partition? Or, are we going to proceed as your screenshot seems to show with /sda??? My guess is you want to wipe the slate but don't want to risk it w/o confirmation.
    Screenshot from 2019-04-28 10-40-59.png Screenshot from 2019-04-28 10-49-32.png
     
  12. wizardfromoz

    wizardfromoz Super Moderator
    Staff Member Gold Supporter

    Joined:
    Apr 30, 2017
    Messages:
    2,982
    Likes Received:
    2,348
    No work to be done on /dev/sda Dick, until we clean it up in a separate Thread afterwards.

    I can only duplicate your situation to a certain extent, because the drive designations are already assigned. For me, I had the space to work with on my internal SATA HDD 2 TB, which is currently not in use.

    With your screenshotting:

    1. Set the timer to 20 seconds or so, you are capturing too soon and it gets confused
    2. Set it to Take a Screenshot of the Current Windows each time, the background confuses.
    So now follow the GParted instructions with those 2 partitions on your /dev/sdb

    Back later

    Wizard
     
    #72 wizardfromoz, Apr 28, 2019
    Last edited: Apr 29, 2019
  13. whazzupdoc

    whazzupdoc Active Member

    Joined:
    Jun 21, 2018
    Messages:
    191
    Likes Received:
    30
    O.K.!!! I've stopped short of trying to setup the new partitions. Your call. I'm sending a 20sec delay screenshot of the new /dev/sdb.

    I'm still having to monitor my yahoo mail on the desktop because until we get Sylvia reinstalled, yahoo will only work with 18.3 or newer...says Flatpak (Geary). It'll be a lot more familiar once we're there.

    Thanks, Chris!
    Doc Screenshot from 2019-04-28 21-19-33.png
     
    wizardfromoz likes this.
  14. whazzupdoc

    whazzupdoc Active Member

    Joined:
    Jun 21, 2018
    Messages:
    191
    Likes Received:
    30
    Wiz, I should've included a screenshot of the creating partition setup. I don't know how to change from gpt partition to MSDos...that's why I've halted.
    Doc Screenshot from 2019-04-28 21-42-33.png
     
  15. wizardfromoz

    wizardfromoz Super Moderator
    Staff Member Gold Supporter

    Joined:
    Apr 30, 2017
    Messages:
    2,982
    Likes Received:
    2,348
    Hope you're catching good zzz's by now, Friend. You're doing fine and we are making progress :)

    Screenshots are way better, too.

    Cancel out of that GParted sub-window for now, but we will come back to it soon.

    I am off over to a Serena I have installed to use Timeshift on it to restore a Sylvia to my now large amount of unallocated space, and then I will present you with a blow by blow.

    One thing you can do for me is to let me know the version of Timeshift you have on Serena. Go to Terminal and enter

    Code:
    apt-cache policy timeshift
    and report back.

    Cheers

    Wiz
     
    Vrai likes this.
  16. whazzupdoc

    whazzupdoc Active Member

    Joined:
    Jun 21, 2018
    Messages:
    191
    Likes Received:
    30
    Good to hear, Chris. Here's a screenshot of what you asked me to do. I'm standing by.
    D Screenshot from 2019-04-29 10-14-39.png oc
     
    wizardfromoz likes this.
  17. wizardfromoz

    wizardfromoz Super Moderator
    Staff Member Gold Supporter

    Joined:
    Apr 30, 2017
    Messages:
    2,982
    Likes Received:
    2,348
    Thanks for that output Dick, I've made accommodation to make sure I have the same version as you, so the interface (look and feel) will be the same.

    GPARTED

    1. On the Toshiba, without the T5 connected (but have it ready to go), launch GParted again, and navigate to /dev/sdb, where there is 465.76 GiB of unallocated space.

    2. The top Menu bar has 6 entries. Click Device, it is between View and Partition. Choose Create Partition Table ...

    3. The popup window will default to showing "msdos", that is as we want it, so leave it unchanged and click Apply. That alone is enough for it to perform the opertion, you will see it happening, and when it is complete, you will be returned to the original window pane. It looks like no changes, but you now have converted the drive from GPT to MSDOS, which was like your old hard drive that Sylvia was on.


    [​IMG]

    SCREENSHOT 1 - NEW PARTITION TABLE FOR TARGET DRIVE - GPT TO MSDOS

    Remember, mine says /dev/sda, yours will say /dev/sdb

    4. Still in GParted, right-click the line that shows the unallocated space again, as you did yesterday, and choose New and click, the popup window will appear where you can alter the sizes.

    5. Revisit your screenshot from #74 above, where you had got as far as typing in 40000. Let's go with 60 GiB instead, but don't type in 60000, make it 61440, that is exactly 60 GiB. Then press your Tab key and watch the figure below the 61,440 reduce accordingly.

    So your figures should look something like:

    1

    61440

    415499

    6. If those figures are close or exact, press the Add button, you will be returned to the main window, showing a 60 GiB partition. In the bottom pane will be the words

    Create Primary Partition #1 (ext4, 60.00 GiB) on /dev/sdb

    Below that in the status field will be showing

    1 operation pending

    6. Go up the top, and under Partition or Help, click the right-side check mark or arrow that Smart Tip shows as Apply All Operations.

    A popup warning will appear asking are you sure? You are, so click Apply.

    When the operation completes, you should have a brand spanking new partition /dev/sdb1, sized 60 GiB, and this is going to provide a new home for Sylvia. :D


    LAST THING FOR NOW
    • Reboot the Toshiba. When the desktop has settled in place
    • Connect the T5, wait a minute for it to be recognised
    • Launch GParted, and navigate to the T5 drive, and establish its device name, and the Timeshift partition name. It will likely be something like /dev/sdc for the T5, and something like /dev/sdcx for the Timeshift, where "x" is 1, 2, 3 or 4. If I recall, you had the partition named or labelled. Write down the details
    Cheers, and I'm off to put together the blow-by-blow for Timeshift

    Wizard
     
  18. Vrai

    Vrai Active Member

    Joined:
    Mar 16, 2019
    Messages:
    111
    Likes Received:
    106
    Thanks @wizardfromoz ! :)
     
  19. whazzupdoc

    whazzupdoc Active Member

    Joined:
    Jun 21, 2018
    Messages:
    191
    Likes Received:
    30
    Done...looks o.k. to me. How do I pick you up for the new topic?
    Doc Screenshot from 2019-04-30 08-44-18.png Screenshot from 2019-04-30 08-51-41.png Screenshot from 2019-04-30 10-26-51.png
     
  20. wizardfromoz

    wizardfromoz Super Moderator
    Staff Member Gold Supporter

    Joined:
    Apr 30, 2017
    Messages:
    2,982
    Likes Received:
    2,348
    Good morning all :)

    Dick you are confusing "Post" with "Thread". I am not moving this Thread. It is Vrai's #77 Post and my response at #78 I will move over to the Timeshift Thread, to keep us on track here.

    Your screenshots - it appears from the second one, that you have created /dev/sdb1 consuming a little over 400 GiB , rather than the 60 GiB I advocated in Instruction 5. at my #79.

    I will complete my blow-by-blow on the Timeshift operation as soon as I can and be back with it, but you must follow instructions with it or we will come to grief. :cool:

    Wiz
     

Share This Page