No Sound on Asus Zenbook OLED UX3402ZA

luhthien

New Member
Joined
Jul 5, 2023
Messages
6
Reaction score
2
Credits
41
Hi everyone !
I just install ubuntu on my laptop but after boot, it's haven't sound ...
I Tried follow step below:
sudo #!/bin/bash

sudo hda-verb /dev/snd/hwC0D0 0x20 0x500 0x1b

sudo hda-verb /dev/snd/hwC0D0 0x20 0x477 0x4a4b

sudo hda-verb /dev/snd/hwC0D0 0x20 0x500 0xf

sudo hda-verb /dev/snd/hwC0D0 0x20 0x477 0x74
and run it by: chmod +x file_name.sh
but not work!!

everyone can help me resolved ? please !!
Thanks !!
 


there may be some issues with your script, but it might help to start with what version of ubuntu did you install? did you check the sound icon to see if anything was muted? did you find that script somewhere as a possible solution for your system? was the sound working well before installing ubuntu?
 
there may be some issues with your script, but it might help to start with what version of ubuntu did you install? did you check the sound icon to see if anything was muted? did you find that script somewhere as a possible solution for your system? was the sound working well before installing ubuntu?
I use ubuntu 22.04.2.
There is still a sound icon displayed in the upper right corner of the screen.
When I plug in my headphones it works fine and using bluetooth is ok but speaker builtin not work !!
 
Last edited:
I use ubuntu 22.04.2.
There is still a sound icon displayed in the upper right corner of the screen.
When I plug in my headphones it works fine and using bluetooth is ok but speaker builtin not work !!
you could try checking

alsamixer

to see if anything is muted.

if you go into Settings and then the Sound tab in the left pane, is the builtin speaker listed as an Output Device? if so, can you select it and does anything happen if you click the Test button? in an ubuntu 22.04 virtual machine, if i change the Alert Sound (at the bottom) there is a visual indication in the bar below Output Device that shows sound being played. do you see anything like that?

one last place i can think of to check volume levels is with

pactl list | grep -iE 'volume:|mute:'
 
alsamixer
I had done.....
when i open the music, the waveform show ok. but i'm can't hear but plug in headphone --> it's ok .
 

Attachments

  • Screenshot from 2023-07-06 23-55-14.png
    Screenshot from 2023-07-06 23-55-14.png
    117.4 KB · Views: 288
  • Screenshot from 2023-07-06 23-57-35.png
    Screenshot from 2023-07-06 23-57-35.png
    220.6 KB · Views: 297
the alsamixer levels look like they should be good. usually when there are small blue horizontal lines on the right of the screen that means there are more things to see on that side so you could try checking there using the right arrow key. there is a package called pavucontrol that can show you some more of the PulseAudio volume settings in a graphical manner.

you should be able to install that by updating first with

sudo apt update

and then installing the package with

sudo apt install pavucontrol

or you could also see pulseaudio volume and mute settings with the previously mentioned pactl command:

Code:
pactl list | grep -iE 'volume:|mute:'
    Mute: no
    Volume: front-left: 65536 / 100% / 0.00 dB,   front-right: 65536 / 100% / 0.00 dB
    Base Volume: 65536 / 100% / 0.00 dB
    Mute: no
    Volume: front-left: 65536 / 100% / 0.00 dB,   front-right: 65536 / 100% / 0.00 dB
    Base Volume: 65536 / 100% / 0.00 dB
    Mute: no
    Volume: front-left: 20724 /  32% / -30.00 dB,   front-right: 20724 /  32% / -30.00 dB
    Base Volume: 13076 /  20% / -42.00 dB
 
the alsamixer levels look like they should be good. usually when there are small blue horizontal lines on the right of the screen that means there are more things to see on that side so you could try checking there using the right arrow key. there is a package called pavucontrol that can show you some more of the PulseAudio volume settings in a graphical manner.

you should be able to install that by updating first with

sudo apt update

and then installing the package with

sudo apt install pavucontrol

or you could also see pulseaudio volume and mute settings with the previously mentioned pactl command:

Code:
pactl list | grep -iE 'volume:|mute:'
    Mute: no
    Volume: front-left: 65536 / 100% / 0.00 dB,   front-right: 65536 / 100% / 0.00 dB
    Base Volume: 65536 / 100% / 0.00 dB
    Mute: no
    Volume: front-left: 65536 / 100% / 0.00 dB,   front-right: 65536 / 100% / 0.00 dB
    Base Volume: 65536 / 100% / 0.00 dB
    Mute: no
    Volume: front-left: 20724 /  32% / -30.00 dB,   front-right: 20724 /  32% / -30.00 dB
    Base Volume: 13076 /  20% / -42.00 dB
Yeah... the levels look like ok, waveform still "up up down down" but I'm not hear anything...
plugin headphone and use bluetooth to connect with speaker is also ok
 
Make sure that your speaker output is selected within PA (i.e. not your headphones). enter image description here
Open a terminal and run the following command:

Code:
pactl list | grep 'Active Port.*output.*'

It should output something that looks like this:

Active Port: audiotype-output-speaker

If you get this output from the terminal command it is telling you that you may need to edit the mixer path file audiotype-output-device.conf to get the speakers working.

The PulseAudio mixer path files are usually located in:

/usr/share/pulseaudio/alsa-mixer/paths/

Allow PulseAudio volume to adjust the headphone ALSA volume.

Original:

[Element Headphone]
switch = off
volume = off

Edited:

[Element Headphone]
switch = off
volume = merge
override-map.1 = all
override-map.2 = all-left,all-right

save the file and reboot - hopefully you will have sound if not you can always undo this.
 
I just install ubuntu on my laptop
since you only just installed not long ago, it might help to try some other distributions to see if maybe they can get the sound to work. mx linux 21 (based on debian) has an Advanced Hardware Support (ahs) version that is designed to try and work better with newer systems: https://mxlinux.org/download-links/

other distributions like endeavour os (based on arch linux) and fedora come with newer kernels which sometimes helps provide support for newer hardware. trying any of those live to see if you get sound could be worth a try.
 

Staff online


Top