Move folders in gui

ozstar

New Member
Credits
23
Hi,

I have Zorin 15 (UB18.04)

I am trying to move some folders from opt/lampp/htdocs to var/www/html/ but permissions as root keep stopping me. Have tried a few thing to no avail. Seemed there was gksu but that is now defunct.

Error moving file /opt/lampp/htdocs/1300rentbuy: Permission denied

I initially tried to set up the webserver using the lampp pack but since then are doing it manually piece by piece.. tho' it is taking forever and still stuck with Apache.

To keep it clean, I guess I need to uninstall the files etc that came down with lampp correct ?

How to do: Just delete the lampp folder or..

and how do I move these folders please, in gui if possible.

Thanks
 


Condobloke

Well-Known Member
Credits
2,512
G'day ozstar, and Welcome to linux.org.......from another Aussie

I use Linux Mint so can't offer much regarding Zorin

Someone will be along....there is plenty of knowledge here.

Enjoy yourself !
 

ozstar

New Member
Credits
23
Hi... Happy New Year.. I used Mint before too and really liked its graphical stuff.
Very hot... 49c
Thanks for the Hi !
 

JasKinasis

Well-Known Member
Credits
1,193
I don't know anything about zorin. But to move files owned by root using the GUI, you need to start your file manager as root.
Traditionally, this would be done using something like gksudo.
But gksudo has been deprecated and removed from many distros.

But from what I recall, most file managers accept the admin:// prefix in their address bars.

So if your file manager is running (as you) and is open to /path/to/somethingownedbyroot/

Do the following:
Press Ctrl+L to jump to the address bar, so you can edit the path to view (several file managers use this shortcut, it's also used to jump to the address bar in most web browsers too).
Edit the path so it has admin:// at the start of it. So the path reads:
admin:///path/to/somethinownedbyroot/

Then press enter and you should be prompted to enter your password. As long as you're in the sudoers file and you entered the correct password, the file browser will now be running as root and you should be able to move the folders in the GUI.


If that doesn't work for you - open a terminal and use 'sudo mv /path/to/source/ /path/to/destination/'

Or you could open a terminal and use:
sudo Nautilus
Or whatever your file manager of choice is!
That will prompt you for a password in the terminal and will fire up your file manager as root, so you can move your files.

Personally, I use the terminal for almost everything. Especially anything requiring root permissions. So I haven't tried this new admin:// mechanism yet.

The next time I'm on my laptop, I'll try to remember to take a look!
 


Members online

No members online now.

Latest posts

Top