Solved Low volume, mostly on headphones

Solved issue

ron.alan

Member
Joined
Dec 24, 2023
Messages
90
Reaction score
75
Credits
658
I have a sound problem with my headphones. The volume level is very low, even with the computer volume up to max. Is there any way to fix this? And weirdly, if I plug them into my speaker's headphone jack, the volume knob on the speakers has no effect at all, I have to use the computer's volume control, which is still too low.

Also, since upgrading to Devuan 5 (via Crowz) even the regular computer speakers seem to have a low level. Does anyone have any ideas how to fix this issue?

These are my headphones.

Here's my computer info:

Code:
System:
  Kernel: 6.1.0-17-amd64 arch: x86_64 bits: 64 compiler: gcc v: 12.2.0
    Desktop: MATE v: 1.26.0 Distro: Crowz GNU/Linux 5.0.0 daedalus
Machine:
  Type: Desktop System: ASUS product: All Series v: N/A
    serial: <superuser required>
  Mobo: ASUSTeK model: H81M-C v: Rev X.0x serial: <superuser required>
    BIOS: American Megatrends v: 3602 date: 03/26/2018
CPU:
  Info: dual core model: Intel Pentium G3220 bits: 64 type: MCP arch: Haswell
    rev: 3 cache: L1: 128 KiB L2: 512 KiB L3: 3 MiB
  Speed (MHz): avg: 1137 high: 1176 min/max: 800/3000 cores: 1: 1099 2: 1176
    bogomips: 11972
  Flags: ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
Graphics:
  Device-1: Intel Xeon E3-1200 v3/4th Gen Core Processor Integrated Graphics
    vendor: ASUSTeK driver: i915 v: kernel arch: Gen-7.5 bus-ID: 00:02.0
  Display: x11 server: X.Org v: 1.21.1.7 driver: X: loaded: modesetting
    unloaded: fbdev,vesa dri: crocus gpu: i915 resolution: 1920x1080~60Hz
  API: OpenGL Message: Unable to show GL data. glxinfo is missing.
Audio:
  Device-1: Intel 8 Series/C220 Series High Definition Audio vendor: ASUSTeK 8
    driver: snd_hda_intel v: kernel bus-ID: 00:1b.0
  API: ALSA v: k6.1.0-17-amd64 status: kernel-api
Network:
  Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
    vendor: ASUSTeK H81M-C driver: r8169 v: kernel port: e000 bus-ID: 03:00.0
  IF: eth0 state: up speed: 10 Mbps duplex: full mac: <filter>
Drives:
  Local Storage: total: 387.53 GiB used: 101.97 GiB (26.3%)
  ID-1: /dev/sda vendor: Crucial model: CT256MX100SSD1 size: 238.47 GiB
  ID-2: /dev/sdb vendor: Seagate model: ST3160815AS size: 149.05 GiB
Partition:
  ID-1: / size: 233.66 GiB used: 5.3 GiB (2.3%) fs: ext4 dev: /dev/sda5
Swap:
  Alert: No swap data was found.
Sensors:
  System Temperatures: cpu: 35.0 C mobo: N/A
  Fan Speeds (rpm): N/A
Info:
  Processes: 148 Uptime: 4h 19m Memory: total: 8 GiB available: 7.63 GiB
  used: 2.31 GiB (30.3%) Init: SysVinit runlevel: 2 Compilers: gcc: 12.2.0
  Packages: 1342 Shell: Bash v: 5.2.15 inxi: 3.3.31
 
Last edited:


Found the problem. In alsamixer the headphone level was low. I was going to delete this thread, but it seems this forum doesn't have a delete option??
 
it seems this forum doesn't have a delete option??

If it can be deleted, it will be in the menu right below the post. I'm not sure if you can delete a whole thread, but you can delete other posts. I can delete whole threads but this thread has a question and answer, so it/s worth keeping around - even if it seems trivial to you.
 
@ron.alan :-

This is why I've preferred USB headphones for the last few years. Many people take a look at them, and get put off by how big the connector appears to be. But there's a reason for that.......because the majority of USB headphones don't rely on working thru the system's internal audio card at all. They have their own, dedicated audio card built-in.....and it generally lives inside the USB connector at the end of the cable. And that's why it looks rather "chunky".

All of which means that they also have their own dedicated software controls.....also accessible through, say, ALSAmixer, yet independent from the system card. I find it makes for a far superior experience, and there's no need to have to dig deep to find arcane solutions. These things just "work".


Mike. ;)
 
This is why I've preferred USB headphones ...
Thanks. Actually I prefer to have a volume control on the headphone wires. I assume all USB headphones would have that? Seems that all the ones I looked at on Amazon (after reading your post) did at least. Next time I need new headphones I'll probably go with USB ones.
 
@ron.alan :-

I've got two pairs.

SOMiC GS401 full-cup wireless headset (NOT Bluetooth, just a good old 2.4 GHz wireless dongle):-

https://www.amazon.co.uk/GS401PRO-M...e-Smartphone-PRO-2-4G-Wired-3-1/dp/B0C6K1DCVL

Mine are the slightly earlier model immediately prior to these; Amazon seem to have moved to offering the BlueTooth version, under the impression - obviously! - that this is the only type anybody would ever want. I specifically went for the previous 2.4 GHz wireless version because I didn't WANT Bluetooth.

These have the volume control on the left ear-cup, along with a bunch of other controls. I just leave the 'PCM' software slider full up, and adjust the volume on the headset itself.

The other set are the now-elderly Logitech H340s:-

https://www.logitech.com/en-gb/products/headsets/h340-usb-pc-noise-cancelling-mic.981-000475.html

These have been around for several years, though the fact that they're still in the line-up must tell you something about them. No volume control on these; if I'd gone for the H540 headset it, too, has the volume control on the ear-piece itself.......except these didn't yet exist when I bought mine. Which goes to show how long I've had them..!

I get the impression USB headphones/headsets all use a fairly basic 'generic' audio chip. Which makes sense, because apart from 'Volume' - for headphones - and 'Mic Level' - for headsets - you really don't need much more for these items. Certainly you don't require all the other controls that come with an internal audio card.....do you?

No, I'd recommend USB headsets/ headphones to anyone. They DO make life a LOT simpler......even more so for those of us on this side of the fence.


Mike. ;)
 
Last edited:


Top