Kali 2020.3 Live USB with persistence: stuck on Live Boot Menu


New Member
Oct 26, 2020
Reaction score
Hello everyone, I have previously ran a 2020.3 live usb on this device with no issues. I then reformatted the USB, flashed it again with the same OS and then created a persistent partition (logical using ext4). After booting it works through grub fine and then comes to blue “Kali Live Boot Menu”...It loads fully but I am not given a mouse curser and non of my keyboard strokes are recognized. I am unable to use arrow keys, enter, e to enter options, or c to enter cmd-line. I have tried to use a usb mouse with no avail. I have also tried redoing the usb numerous times and actually even went back to try again without persistence...now it does the same thing with no persistent drive present on the usb. Any help would be GREATLY appreciated.


  • image.jpg
    2.5 MB · Views: 1,318

Update...I now know is must be an issue with my bios. I had to sue windows ten to exit to bios because my keyboard would not allow me to enter it during startup. One I’m bios my laptops keyboard isn’t working either. I may have to try a usb keyboard to see if it will allow me to navigate bios.

Members online