Intel® Wi-Fi 6E AX210 Card Not working on Unbuntu or Mint

mikehall419

New Member
Joined
Nov 7, 2021
Messages
1
Reaction score
0
Credits
25
Hi! Before I dive in here are my PC specs.
Let me know if anyone needs additional info on any hardware.

1. Motherboard: Gigabyte Aorus Master X570S
2. Processor: Ryzen 5 5600X
3. GPU: Nvidia EVGA GeForce 2070 XC
4. RAM: (16GBx2) Crutial Ballistix 3600MHz
5. T-Force Cardea ZERO Z330 M.2 NVME SSD (x2)
6. Wifi Card: Intel® Wi-Fi 6E AX210

I currently have Unbuntu on one SSD, and Windows 10 on the other.

My Wi-Fi works perfect on Windows, but Unbuntu does not see my Wi-Fi adapter. It displays "No Wifi Adapter found" when I search for the Wi-Fi setting. Otherwise, in the top right is displays "cable unplugged".

Everything else works, just not my Wi-Fi on Linux.
Here is what I have tried to fix the issue:

1. Reinstall Linux, I've tried Mint, and reinstalled twice for Unbuntu making sure "install proprietary drivers" is selected when installing.
2. Unplugged the Windows SSD, and in the wifi adapter settings in WINDOWS I selected in the power management settings to keep the wifi card running while the computer is sleeping or off.
3. Checked to make sure the driver for my card is installed. In this case, iwlwifi.
4. Checked to make sure Linux can see the card itself using sudo lspci and sudo lshw -C network.
5. Checked to see if the driver is loaded using sudo lsmod, followed with sudo modprobe.
6. Used the synaptic package manager to install the backport driver that way.
7. Disabled validation with sudo mokutil --disable-validation
8. And I should've said this first, but checked the additional drivers tab in software and updates. I only see the drivers for Nvidia there.
9. Force module to load on boot with sudo nano /etc/modules and entering the driver there.

I'm pretty stumped! Any help would be awesome. Also let me know if this has already been solved, or if I have my forum format wrong.
Thanks!
 


brickwizard

Well-Known Member
Joined
Apr 28, 2021
Messages
1,253
Reaction score
957
Credits
9,458
welcome to the forums, as @Lord Boltar has said the new drivers are in the 5.10 or higher kernels, mint and Ubuntu are still currently on 5.4
your options are install the wi-fi drivers , upgrade your kernel, or try a distro which already uses the later kernels eg. MX 21 linux

Bwiz
 

Lord Boltar

Well-Known Member
Joined
Nov 24, 2020
Messages
996
Reaction score
646
Credits
7,385
You can upgrade the kernel to 5.11 for Ubuntu 20.04 or Mint 20.2 by downloading the following 5 files make sure and click on amd64 version of the file by scrolling down towards the bottom
------------------------------------------------------




-----------------------------------------------------
1.png

Just make sure no other deb files are present in that folder only the 5 you download and once downloaded to an empty folder you need to open a terminal inside that folder usually Right click and Open Terminal Here - once the terminal is open -
2.png

you can type in
Code:
sudo dpkg -i *.deb
to install the new kernel now reboot your new kernel should be loaded and your WiFi should be detected - once it has rebooted open the terminal again and type in
Code:
uname -r
it should display the 5.11.0-38 kernel
 
Last edited:
$100 Digital Ocean Credit
Get a free VM to test out Linux!

Members online


Top