How To Reconnect My Ubuntu 18.04 LTS Server To The Internet When I Can Still Access It Locally?

blackneos940

Active Member
Credits
67
Hey guys!..... :3 I'm back with another problem..... One I think could be a help to others..... :3 So anywho, this all happened after I installed Pihole, Apache2, PHP, mySQL, and everything else needed to turn my Server into a Web Server..... :) These are the things I have tried to fix the issue, according to various posts on the Internet..... :3 I tried: Editing the /etc/resolv.conf File, using
Bash:
resolvconf -u
, editing DNS settings to point to Google's 8.8.8.8 DNS, but nothing has worked so far..... :( During the initial setup of PiHole, I accidentally changed my I.P. Address..... Could this be the issue.....? :< How do I change it back to the default one.....? :< My Penguin buddy can't access the Server from the outside, nor can I, but I can access it locally, from inside the Network..... :( Thanks for any help guys, I truly appreciate it!..... ^^
 


TechnoJunky

Well-Known Member
Credits
314
This isn't exactly an answer to your problem, but a suggestion that you "should" do before or after you get things fixed. I personally would not use google's DNS. Google already has it's fingers in most of what you do online. Using their DNS, ensures that they have their fingers in every thing you do online. I use Cloudfare. Here's a statement about them:
According to Cloudflare, it is the fastest, most private DNS service available, surpassing both OpenDNS and GoogleDNS. Unlike its competitors, Cloudflare’s option wipes all logs of DNS queries within 24 hours.

Maybe you don't care about your privacy, and that's your choice, but if you do, I'd change that. Their DNS server is 1.1.1.1.

To change your IP back to the default, which should actually be DHCP on a hardwired NIC, try this:
ifconfig eth0 down
edit /etc/network/interfaces and remove any lines with your hardcoded IP and replace with “iface eth0 inet dhcp”
then
ifconfig eth0 up
 

blackneos940

Active Member
Credits
67
This isn't exactly an answer to your problem, but a suggestion that you "should" do before or after you get things fixed. I personally would not use google's DNS. Google already has it's fingers in most of what you do online. Using their DNS, ensures that they have their fingers in every thing you do online. I use Cloudfare. Here's a statement about them:
According to Cloudflare, it is the fastest, most private DNS service available, surpassing both OpenDNS and GoogleDNS. Unlike its competitors, Cloudflare’s option wipes all logs of DNS queries within 24 hours.

Maybe you don't care about your privacy, and that's your choice, but if you do, I'd change that. Their DNS server is 1.1.1.1.

To change your IP back to the default, which should actually be DHCP on a hardwired NIC, try this:
ifconfig eth0 down
edit /etc/network/interfaces and remove any lines with your hardcoded IP and replace with “iface eth0 inet dhcp”
then
ifconfig eth0 up
Ok!..... :3 I'll give it a shot, and let you know what comes of it!..... :3 But I didn't know that about Google..... :(
 

blackneos940

Active Member
Credits
67
This isn't exactly an answer to your problem, but a suggestion that you "should" do before or after you get things fixed. I personally would not use google's DNS. Google already has it's fingers in most of what you do online. Using their DNS, ensures that they have their fingers in every thing you do online. I use Cloudfare. Here's a statement about them:
According to Cloudflare, it is the fastest, most private DNS service available, surpassing both OpenDNS and GoogleDNS. Unlike its competitors, Cloudflare’s option wipes all logs of DNS queries within 24 hours.

Maybe you don't care about your privacy, and that's your choice, but if you do, I'd change that. Their DNS server is 1.1.1.1.

To change your IP back to the default, which should actually be DHCP on a hardwired NIC, try this:
ifconfig eth0 down
edit /etc/network/interfaces and remove any lines with your hardcoded IP and replace with “iface eth0 inet dhcp”
then
ifconfig eth0 up
Nope..... :( No go..... :( I'm just going to start from scratch..... :) It shouldn't be too long..... :)
 



Top