[Don't Need To Fix The Problem Anymore So Idc, Thanks For The Help] Desktop Isn't Scaling Properly At 1080p And I Don't Know How To Fix It

NePoran

Member
Joined
Mar 24, 2021
Messages
32
Reaction score
3
Credits
266
Ever since I switched to Linux whenever I tried using 1080p the taskbar and windows would go outside of the screen, hence I figured it wasn't scaled properly.
DIdn't know how to fix it, was able to use 1050p without a problem so I just stuck with that.

Yesterday I was following Christ Titus Tech's guide to improving Linux gaming, I installed Nvidia's drivers, and today I'm finding it's set to 1080p and the only other option is to set it to 720p now.



Here's the error that comes up whenever I try to install Nvidia's drivers:
[email protected] user-:/$ sudo add-apt-repository ppa:graphics-drivers/ppa -y
[sudo] password for user:
Hit:1 https://dl.winehq.org/wine-builds/ubuntu focal InRelease
Hit:2 http://gb.archive.ubuntu.com/ubuntu focal InRelease
Hit:3 https://dl.winehq.org/wine-builds/ubuntu groovy InRelease
Hit:4 https://repo.steampowered.com/steam stable InRelease
Hit:5 http://ppa.launchpad.net/christian-boxdoerfer/fsearch-daily/ubuntu focal InRelease
Hit:6 http://security.ubuntu.com/ubuntu focal-security InRelease
Hit:7 http://gb.archive.ubuntu.com/ubuntu focal-updates InRelease
Hit:8 http://prerelease.keybase.io/deb stable InRelease
Hit:9 https://download.sublimetext.com apt/stable/ InRelease
Hit:10 https://screenrec.com/download/ubuntu stable InRelease
Hit:11 http://gb.archive.ubuntu.com/ubuntu focal-backports InRelease
Hit:12 https://brave-browser-apt-release.s3.brave.com stable InRelease
Hit:13 http://ppa.launchpad.net/graphics-drivers/ppa/ubuntu focal InRelease
Hit:14 https://packages.riot.im/debian default InRelease
Hit:15 http://ppa.launchpad.net/lutris-team/lutris/ubuntu focal InRelease
Ign:16 http://ppa.launchpad.net/modycz/heimdall/ubuntu focal InRelease
Ign:17 http://ppa.launchpad.net/nathan-renniewaldock/flux/ubuntu focal InRelease
Hit:18 http://ppa.launchpad.net/qbittorrent-team/qbittorrent-stable/ubuntu focal InRelease
Err:19 http://ppa.launchpad.net/modycz/heimdall/ubuntu focal Release
404 Not Found [IP: 91.189.95.85 80]
Err:20 http://ppa.launchpad.net/nathan-renniewaldock/flux/ubuntu focal Release
404 Not Found [IP: 91.189.95.85 80]
Reading package lists... Done
E: The repository 'http://ppa.launchpad.net/modycz/heimdall/ubuntu focal Release' does not have a Release file.
N: Updating from such a repository can't be done securely, and is therefore disabled by default.
N: See apt-secure(8) manpage for repository creation and user configuration details.
E: The repository 'http://ppa.launchpad.net/nathan-renniewaldock/flux/ubuntu focal Release' does not have a Release file.
N: Updating from such a repository can't be done securely, and is therefore disabled by default.
N: See apt-secure(8) manpage for repository creation and user configuration details.
[email protected] user-:/$

Also I forgot to mention my audio also isn't working.

A;sp
 
Last edited:


KGIII

Super Moderator
Staff member
Gold Supporter
Joined
Jul 23, 2020
Messages
4,055
Reaction score
3,723
Credits
32,562
Remove the broken PPAs and then:


Install the tested and recommended drivers to see if that gets it sorted for you.
 
OP
N

NePoran

Member
Joined
Mar 24, 2021
Messages
32
Reaction score
3
Credits
266
I installed the drivers that were recommended from the article.

The desktop's still bigger than the resolution.
 

KGIII

Super Moderator
Staff member
Gold Supporter
Joined
Jul 23, 2020
Messages
4,055
Reaction score
3,723
Credits
32,562
Now that you have the correct drivers installed, you can use xrandr (use a search engine) to set a custom resolution if you want. You appear to want 1050 and that's not going to appear by default, so you'll have to set it manually.
 
OP
N

NePoran

Member
Joined
Mar 24, 2021
Messages
32
Reaction score
3
Credits
266
I tried to run this command: sudo ubuntu-drivers autoinstall

This was the output:
The following packages have unmet dependencies:
nvidia-driver-460 : Depends: nvidia-kernel-source-460 (= 460.39-0ubuntu0.20.04.1) but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

I would just install the dependency but I get the impression I've already bricked/fucked something up and this isn't going to help.
 
OP
N

NePoran

Member
Joined
Mar 24, 2021
Messages
32
Reaction score
3
Credits
266
"You appear to want 1050 and that's not going to appear by default"

I have been using 1050p because my desktop scaled to my screen correctly/adequately when the resolution was set to 1050p.
I would prefer 1080p over 1050p.
I would use 1080p if I knew how to make the desktop scale so it fits the screen.
 

KGIII

Super Moderator
Staff member
Gold Supporter
Joined
Jul 23, 2020
Messages
4,055
Reaction score
3,723
Credits
32,562
Let's try this... If nothing else, we can get you to a known state.

Open the 'additional drivers' GUI and select the opensource drivers for your graphics card. It'll be something like: Using X:Org X Server and include the word "Nouveau". Make sure to "apply changes" and then reboot.
 
OP
N

NePoran

Member
Joined
Mar 24, 2021
Messages
32
Reaction score
3
Credits
266
It was using Nvidida 450 before.
I've heard of Nouveau before, didn't know what it was.
 

Crippled

Member
Joined
Mar 25, 2021
Messages
27
Reaction score
14
Credits
170
"You appear to want 1050 and that's not going to appear by default"

I have been using 1050p because my desktop scaled to my screen correctly/adequately when the resolution was set to 1050p.
I would prefer 1080p over 1050p.
I would use 1080p if I knew how to make the desktop scale so it fits the screen.
Make sure you don't have any other screens hooked up like through a HDMI cable because it will cause what you describe. If so, unplug those and reboot the computer. It should be set to 1920X1080. Also check that you have the correct refresh rate. If it still doesn't work, this is why as the creator of Linux, Linus Torvalds explains it.
 
OP
N

NePoran

Member
Joined
Mar 24, 2021
Messages
32
Reaction score
3
Credits
266
"Make sure you don't have any other screens hooked up like through a HDMI cable because it will cause what you describe."

I only have and use one monitor/TV.
 
OP
N

NePoran

Member
Joined
Mar 24, 2021
Messages
32
Reaction score
3
Credits
266
I rebooted my machine, the desktop is still bigger than the screen.
It is now set to 1080p 59.94 Hz (it won't let me set it to 60FPS).
 

Crippled

Member
Joined
Mar 25, 2021
Messages
27
Reaction score
14
Credits
170
That's why I don't use NVIDIA. Looks like you need to find someone who knows how to fix NVIDIA video issues.
 
$100 Digital Ocean Credit
Get a free VM to test out Linux!


Top