Debian 10 Mate Blkid and /etc/fstab Don't Match SOLVED


Well-Known Member
Jun 1, 2019
Reaction score
Boot time for Debian 10 on my rig normally takes under a minute to boot.
Now since installing Elementary OS Debian has had a start job running for 1 min and 30 seconds holding up the boot process.

The output of blkid does not match what's in my fstab file.

/dev/nvme0n1p1: UUID="9cf94bb0-42fa-4b87-943d-48aac22e0310" TYPE="swap" PARTUUID="9ad6e6dd-01"
/dev/nvme0n1p2: UUID="822701b4-8e44-4315-b331-7d847cb9f7fd" TYPE="ext4" PARTUUID="9ad6e6dd-02"
/dev/sda1: UUID="2495b76b-b0d5-4177-9507-f51a2acac787" TYPE="ext4" PARTUUID="00046882-01"
/dev/sda2: UUID="27af6dc6-5ef4-4275-95bd-ad4721d67ee9" TYPE="swap" PARTUUID="00046882-02"
/dev/sdb1: UUID="88cc8300-dd9c-47c5-b12a-39658d12b7ee" TYPE="ext4" PARTUUID="3fc0a6bb-01"
/dev/sdb2: UUID="f156e1ff-df41-44c8-b6d3-85c18a0a001c" TYPE="swap" PARTUUID="3fc0a6bb-02"
/dev/nvme0n1: PTUUID="9ad6e6dd" PTTYPE="dos"
@debian:~$ cat /etc/fstab
# /etc/fstab: static file system information.
# Use 'blkid' to print the universally unique identifier for a
# device; this may be used with UUID= as a more robust way to name devices
# that works even if disks are added and removed. See fstab(5).
# <file system> <mount point> <type> <options> <dump> <pass>
# / was on /dev/sda1 during installation
UUID=2495b76b-b0d5-4177-9507-f51a2acac787 / ext4 errors=remount-ro 0 1
# swap was on /dev/nvme0n1p1 during installation
UUID=9cf94bb0-42fa-4b87-943d-48aac22e0310 none swap sw 0 0
# swap was on /dev/sda2 during installation
UUID=27af6dc6-5ef4-4275-95bd-ad4721d67ee9 none swap sw 0 0
# swap was on /dev/sdb5 during installation
UUID=40bbaed3-36e1-4b24-9db4-e51b2ae7c98c none swap sw

Here's the output of fdisk -l Elementary OS

/dev/sdb1 * 2048 899999743 899997696 429.2G 83 Linux
/dev/sdb2 899999744 976771071 76771328 36.6G 82 Linux swap / Solaris

/dev/sdb1 is the fs for Elementary OS and /dev/sdb2 is the swap partition for Elementary.

Debian is on /dev/sda-
Linux Mint is on the nvme drive-

Here's the ouput of lsblk -f:

│ ext4 2495b76b-b0d5-4177-9507-f51a2acac787 423.8G 2% /
swap 27af6dc6-5ef4-4275-95bd-ad4721d67ee9 [SWAP]
│ ext4 88cc8300-dd9c-47c5-b12a-39658d12b7ee
swap f156e1ff-df41-44c8-b6d3-85c18a0a001c

│ swap 9cf94bb0-42fa-4b87-943d-48aac22e0310 [SWAP]
ext4 822701b4-8e44-4315-b331-7d847cb9f7fd

From what I can tell /dev/sdb5 isn't being used yet it's in the fstab file.

Any ideas how I can fix this?
Last edited:


As you can see in the screen shot /dev/sdb5 does not exist.

Can I remove it from the fstab file w/o any issue's?
I solved the issue.

I edited my fstab file in nano and put a # sign in front of this:
UUID=40bbaed3-36e1-4b24-9db4-e51b2ae7c98c none swap sw

That above UUID was associated with /dev/sdb5 which did not exist anymore.
It was an old partition from a previous installation.

Rebooted and boom the system no longer hangs running a start job for 1 minute and 30 seconds.

Members online

Latest posts