Debain based distros don't show up as boot options


New Member
Nov 6, 2020
Reaction score
So recently I've tried switching from Manjaro to Parrot OS. I have an ssd and a hard disk, I have windows 10 installed on the ssd and linux on the hard disk. I've tried both auto and manual partitioning, installing without the windows ssd plugged in and using legacy+uefi instead of just uefi but after the installation the os just isn't a boot option. I've tried both Parrot OS and Kali Linux with the same result and since I've been able to reinstall Manjaro I'm pretty sure that the problem is with debian based distros.

When you install any distro, you should choose a boot option "UEFI", otherwise it won't appear in the UEFI menu as boot options. When you select "UEFI", the distro creates a small boot partition and that's why it appears as a boot option when you boot up the computer. So, if you really want a UEFI boot for your OS, you should reinstall it. When you choose to boot up from the USB or the DVD, see if there's anything that reads "UEFI" and choose that.
Or you can try installing grub-customizer, though I'm not sure if it offers any UEFI options.
Why can't you use a normal grub like everyone else? Why does it have it be a UEFI boot option, anyway?

Members online