damagedrepomd.xml

f33dm3bits

Gold Member
Gold Supporter
Credits
5,924
What happens when you just run it without using the service?
Code:
collectd
 


f33dm3bits

Gold Member
Gold Supporter
Credits
5,924
What centos 7x version are you running and what version of collectd do you have installed? Try updating the system?
 
Last edited:

f33dm3bits

Gold Member
Gold Supporter
Credits
5,924
collectd-5.8.1-1.el7.x86_64 is the version of collectd
3.10.0-1127.13.1.el7.x86_64
is the version of CentOS7
I meant that full version which is you can see in /etc/redhat-release, but looking at the kernel version you are probably running on the latest version. Install the following package strace. Then run it like this
Code:
strace -o collectd.log collectd
Then attach the collectd.log file here.
 

f33dm3bits

Gold Member
Gold Supporter
Credits
5,924
How can I attach collectd.log file ? And Where is it exactly??
I literally told you how in my previous post. You can attach a file by using the attach button when you make a post.
 

f33dm3bits

Gold Member
Gold Supporter
Credits
5,924
How can I attach collectd.log file ? And Where is it exactly??
Code:
yum install strace
strace -o collectd.log collectd
strace: is the command
-o: is the option standing for output file
collectd: command which you are running strace on.
 
Last edited:

Mohamad.1996

Member
Credits
230
Hi I wanted to compile my kernel and upgrade it but I receive this error?
./include/linux/compiler-gcc.h:15:3: error: #error Sorry, your compiler is too old - please upgrade it.
I get this error when I run make bzImage
 

f33dm3bits

Gold Member
Gold Supporter
Credits
5,924
Hi I wanted to compile my kernel and upgrade it but I receive this error?
./include/linux/compiler-gcc.h:15:3: error: #error Sorry, your compiler is too old - please upgrade it.
I get this error when I run make bzImage
If you are having a new problem you should start a new topic. It's just telling you your compiler version(gcc) is to old to compile what you are trying to compile. The kernel you are trying to compile probably needs a newer gcc version in order to compile. Which kernel are you wanting to install?
Since you are running rhel7/centos7, you can just install the elrepo repository and than install the mainline kernel: https://elrepo.org/tiki/kernel-ml.
 

f33dm3bits

Gold Member
Gold Supporter
Credits
5,924
I want a newest kernel 5.8.1
my Kernel version is I think 3....
As I said install kernel-ml from the elrepo repository, I just installed it on my test system:
Code:
[[email protected] ~]# rpm -q kernel-ml
kernel-ml-5.8.1-1.el7.elrepo.x86_64
Looks like the kernel version you want, mainline means that it's the kernel closes to the most current one available.
 

f33dm3bits

Gold Member
Gold Supporter
Credits
5,924
If I run this command uname -a Will I see the new kernel version?
Yes, when you reboot you will have to select the kernel version because it will by default boot in a 3x kernel.
 



Latest posts

Top