Solved CPU1 running at 98% Constantly.....CPU2 running at 15% varying with load

Solved issue

Condobloke

Well-Known Member
Joined
Apr 30, 2017
Messages
8,654
Reaction score
7,011
Credits
58,205
inxi -Fnxxz
brian@brian-desktop:~$ inxi -Fnxxz
System:
Kernel: 5.15.0-56-generic x86_64 bits: 64 compiler: gcc v: 11.3.0
Desktop: Cinnamon 5.6.5 tk: GTK 3.24.33 wm: muffin dm: LightDM
Distro: Linux Mint 21.1 Vera base: Ubuntu 22.04 jammy
Machine:
Type: Desktop Mobo: ASRock model: B150M Pro4 serial: <superuser required>
UEFI: American Megatrends v: P1.60 date: 11/09/2015
CPU:
Info: dual core model: Intel Pentium G4400 bits: 64 type: MCP
arch: Skylake-S rev: 3 cache: L1: 128 KiB L2: 512 KiB L3: 3 MiB
Speed (MHz): avg: 3300 min/max: 800/3300 cores: 1: 3300 2: 3300
bogomips: 13199
Flags: ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
Graphics:
Device-1: Intel HD Graphics 510 vendor: ASRock driver: i915 v: kernel
ports: active: DP-2,HDMI-A-2 empty: DP-1,HDMI-A-1,HDMI-A-3 bus-ID: 00:02.0
chip-ID: 8086:1902
Display: x11 server: X.Org v: 1.21.1.3 driver: X: loaded: modesetting
unloaded: fbdev,vesa gpu: i915 display-ID: :0 screens: 1
Screen-1: 0 s-res: 3840x1080 s-dpi: 96
Monitor-1: DP-2 pos: primary,right model: Samsung S24D300 res: 1920x1080
dpi: 92 diag: 609mm (24")
Monitor-2: HDMI-2 mapped: HDMI-A-2 pos: primary,left model: Acer G246HL
res: 1920x1080 dpi: 92 diag: 609mm (24")
OpenGL: renderer: Mesa Intel HD Graphics 510 (SKL GT1) v: 4.6 Mesa 22.0.5
direct render: Yes
Audio:
Device-1: Intel 100 Series/C230 Series Family HD Audio vendor: ASRock
driver: snd_hda_intel v: kernel bus-ID: 00:1f.3 chip-ID: 8086:a170
Device-2: Logitech Z Cinéma type: USB
driver: hid-generic,snd-usb-audio,usbhid bus-ID: 1-8:4 chip-ID: 046d:0a0f
Sound Server-1: ALSA v: k5.15.0-56-generic running: yes
Sound Server-2: PulseAudio v: 15.99.1 running: yes
Sound Server-3: PipeWire v: 0.3.48 running: yes
Network:
Device-1: Intel Ethernet I219-V vendor: ASRock driver: e1000e v: kernel
port: N/A bus-ID: 00:1f.6 chip-ID: 8086:15b8
IF: enp0s31f6 state: up speed: 1000 Mbps duplex: full mac: <filter>
Drives:
Local Storage: total: 2.43 TiB used: 501.98 GiB (20.2%)
ID-1: /dev/nvme0n1 vendor: Samsung model: SSD 970 EVO Plus 250GB
size: 232.89 GiB speed: 31.6 Gb/s lanes: 4 serial: <filter> temp: 36.9 C

ID-2: /dev/sda vendor: Samsung model: SSD 750 EVO 120GB size: 111.79 GiB
speed: 6.0 Gb/s serial: <filter>
ID-3: /dev/sdb vendor: Seagate model: ST3300822AS size: 279.46 GiB
speed: 3.0 Gb/s serial: <filter>
ID-4: /dev/sdc type: USB vendor: Western Digital model: WD Elements 2621
size: 1.82 TiB serial: <filter>

Partition:
ID-1: / size: 227.68 GiB used: 30.97 GiB (13.6%) fs: ext4
dev: /dev/nvme0n1p2
ID-2: /boot/efi size: 511 MiB used: 12.1 MiB (2.4%) fs: vfat
dev: /dev/nvme0n1p1
Swap:
ID-1: swap-1 type: file size: 2 GiB used: 0 KiB (0.0%) priority: -2
file: /swapfile
Sensors:
System Temperatures: cpu: 75.0 C pch: 41.0 C mobo: N/A
Fan Speeds (RPM): N/A
Info:
Processes: 228 Uptime: 4h 49m Memory: 15.31 GiB used: 2.26 GiB (14.8%)
Init: systemd v: 249 runlevel: 5 Compilers: gcc: 11.3.0 alt: 11
Packages: 2417 apt: 2403 flatpak: 14 Shell: Bash v: 5.1.16
running-in: tilix inxi: 3.3.13
brian@brian-desktop:~$

NOTE : CPU1 @ 100%

resources 2.png

cpu.png


htop1.png


1 top.png

kworker/0:0+kacpid ....above^^^ .....???

The pc never freezes....never (cinnamon occasionally craps itself, but that is rare...maybe once per month)
 


I rebooted....and as far as I can tell it is now running normally !
wtf

I am trying to remember if I had anything out of the ordinary running during its 100% time......I closed all open windows...news/linux.org/....and was just sitting watching the system monitor at 100%....it occasionally dropped to 97%......but otherwise it stayed there for well over 30 minutes

 
Weird... Your load average isn't even all that outlandish.

What happens if you sit and watch the processes for a few minutes?

I don't think I've ever seen it with just one core pegged like that.
 
During that high use time I ran top in terminal......there is a screenshot above......it shows a PID ...17323.....root......96.3%cpu

That would be the culprit

I am running top right now when the resources page is showing normal.......and top looks like below

top 3.png
 
I think I better reach for the hard stuff.....(coffee instead of tea)
....and its new years eve......maybe the cpu gremlins are having a night on the town....

Screwed if I know !
 
your Birthday !!??.......truly ??.....why didnt I know about this event ??
 
LOL You made the very first profile post I have. It being my birthday, I guess that's a fine time to have a first profile post.

I'm 65 today... On a good day, I act like I'm 45. On the average day, I act like I'm 15. On my worst day, I act like I'm 5!

That's why I always say, "I'm pretty much a big five year old." I do not expect this to change in the coming year.

HAPPY BIRTHDAY, DAVID !!!!!!!!!!
 
About "tracker-miner-fs-3" in the reply in the other topic.
Tracker Miners contains the indexer daemon (tracker-miner-fs-3) and tools to extract metadata from many different filetypes.
 
The tracker miner makes much better sense now. :) :cool:
 
I am in the process of trying to remember what, if any, apps were running when this happened.

Difficult, because today has been a busy day......lots of people coming and going and lots of chatter taking place.

I have made a few changes to acpi control in grub which I believe were done incorrectly some time ago. I have also put a shortcut to system monitor in the panel on both monitors and I will make a habit of keeping a check on cpu1.
 
Booted the pc up.....immediately kicked system monitor into life......it resides in the bottome left hand corner of my left hand monitor.
All normal as can be. Just ticking along nicely.
 

Attachments

  • 1st Jan,2023.png
    1st Jan,2023.png
    89.7 KB · Views: 159
Just ticking along nicely.

That's a good thing. You can add an applet (you're using Cinnamon, right?) that will let you look in the system tray to monitor that sort of thing. I'm sure there's a CPU monitoring applet.
 
I'm sure there's a CPU monitoring applet.
There probably is......however I typed in system monotor and then right clicked on it and added it to the panel.
I then shrunk it to its smallest possible size on the screen and I just leave it there.
The windows I open on the screen are rarely there for any more than a few minutes....and if I sense some lag etc I will simply click to bring the sysmonitor screen to the top.

So far, it works for me.
 
I reset grub back to the below this afternoon
1672573189234.png


I was having a problem with the pc refusing to shut down......altered the grub to the above and that problem is fixed.

However...I then shut the pc down for a couple of hours....
When I restarted, I immediately turned on system monitor......result below...
1672573325794.png

cpu 1 on 100%....and it was staying there

I rebooted and the result is below
1672573441383.png
I took a rough stab in the dark and made the assumption that maybe one of the startup applications is the culprit.
startup applications below
1672573577074.png


if it is one of these, it obviously needs a little time out to 'reset itself??......the pc was turned off for approx 1.5 hours...maybe a little more.

Do I turn off one at a time, and rule them out by the process of elimination....or am I barking right up the wrong tree?
 
I turned the pc off......then turned off the power switch beside the power cable on the rear of the tower....gave it a minute...flicked the switch back on and started the pc.
1672574169952.png

Weird.
@JasKinasis ....do you have any ideas where this concerned?

I am stumped

@Lord Boltar ...any idea?

@dos2unix

Anybody?

AFter reboot
1672574605516.png
 
This time I shut down. No power switch off....just normal shutdown
1672574838506.png

I then shut down again normally
1672575038230.png


and then rebooted
1672575200830.png
 
Last edited:
I think your issue is with the processor itself -

Info: dual core model: Intel Pentium G4400 bits: 64 type: MCP arch: Skylake-S rev: 3 cache: L1: 128 KiB L2: 512 KiB L3: 3 MiB
Speed (MHz): avg: 3300 min/max: 800/3300 cores: 1: 3300 2: 3300 bogomips: 13199

I would suggest upgrading to a quad-core - this is what I did with my Dell E6530 I had a dual core I3 originally I upgraded it to a quad-core i7 and my cpu usage went way down
Have a look here for upgrades - https://www.cpu-upgrade.com/CPUs/Intel/Pentium_Dual-Core/G4400.html
Personally I would recommend the Intel Core i7-6700 series for an upgrade - I bought my cpu from ebay - here is my usage now I was running between 80 to 95% constantly - now you can see
3.png

Code:
System:
  Host: expirion Kernel: 5.15.84-xanmod1 x86_64 bits: 64
  Desktop: Xfce 4.16.0 Distro: Expirion Xfce 11 (bullseye)
Machine:
  Type: Laptop System: Dell product: Latitude E6530 v: 01
  serial: <superuser required>
  Mobo: Dell model: 07Y85M v: A01 serial: <superuser required>
  BIOS: Dell v: A21 date: 02/21/2018
CPU:
  Info: Quad Core model: Intel Core i7-3630QM bits: 64
  type: MT MCP L2 cache: 6 MiB
  Speed: 1657 MHz min/max: 1200/3400 MHz Core speeds (MHz):
  1: 1657 2: 1907 3: 1923 4: 3125 5: 3086 6: 1744 7: 2458
  8: 3142
Info:
  Processes: 256 Uptime: 1h 37m Memory: 15.54 GiB
  used: 2.97 GiB (19.1%) Shell: Bash inxi: 3.3.01

That upgrade I did breathed a whole new life in my old machine made in 2012
 
Last edited by a moderator:

Members online


Top