Chrome - unlock authentication required before opening


Well-Known Member
Apr 25, 2017
Reaction score
I use MX21 and get the Authentication required which I have to press cancel three times to get rid of to open chrome anyone know how to get rid of this??

First, I have no idea... I have some questions that might help.

So, how'd you install Chrome?

Did you install it with root or did you install it with sudo?

Hmm... Is the ~/.config/google-chrome where the config is stored?

Also, what happens if you enter your password into the authentication required window?
Used a .deb package from Chrome Site.
I wonder if it somehow needs access to the keyring?

That's kinda what the symptoms describe, but I'm not sure why it'd let you get past it by pressing enter a few times - unless it then loads it from a different location with different permissions.

Again, I'm speculating based on the content you've posted.

Hmm... Do you have a master password for Chrome? Is that even possible in Chrome? I know you can in Firefox, where before it'll let you use stored passwords you have to authenticate with a master password.

Hopefully someone else will opine, but that it stops with the root password intrigues me.

Also, your signature indicates that you use Debian.
Yeah nee to change Signature. Use Debian on my Sonys.
Just in case this type of garbage comes into play

Warning: apt-key is deprecated. Manage keyring files in trusted.gpg.d instead

Problem came back when I rebooted. Had to use password again :(
The next time you see it, can you screenshot the screen asking you for the password?

I'm well and truly at a loss.
Follow the instructions in the link I posted @ #7

Worked for me
Are you using MX-21 xfce or kde?
in any event I don't have MX installed at the moment but there is a setting in the settings panel to disable the key ring which does away with the problem.
Ha! I knew it was a keyring issue. One of the links provided should get you sorted. If not, I can try to recreate it - assuming I get that kind of free time today.
I have made the change. Will report back on results. Thanks all.
I had the same problem a few years I found and used this and it worked but it removes all Browser have them backed up.

Disable the keyring password​

This tip should only be relevant when you're being logged into your user account automatically, without having to enter your username and password.

The keyring is the safe in which some web browsers store the passwords for websites you visit. Some email clients, chat clients and remote access clients use the keyring too. Even your file manager might use it, for storing network share passwords.

Note: the keyring does not store your root password or user password! It only stores additional network (internet) related passwords.

The keyring password can be annoying when you use automatic login. Some web browsers invoke it when you want to store website passwords or when you have stored those in the past.

The most secure solution by far, is to simply turn off automatic login for your user account! But if you don't want to do that and if you never store passwords anyway (because you're about to leave the door of the password safe open permanently), this is how to disable the keyring password:

a. First delete the current user keyring. Don't be afraid: you won't remove your root password or your user password, but only your personal user keyring. Note: this will delete all the website passwords you've stored in your web browsers!

Proceed like this:
Launch a terminal window.
(You can launch a terminal window like this: *Click*)

Use copy/paste to transfer the following command line to the terminal:

rm -v ~/.local/share/keyrings/*.keyring

Press Enter.

b. The next time when you're being prompted for a keyring password, leave the password field blank (simply click Continue and then again Continue, thus agreeing to unsafe storage). That disables the keyring password for good.

c. Let your web browsers wipe any passwords they've stored, and configure them never to offer to store a password again.
(simply click Continue and then again Continue, thus agreeing to unsafe storage). That disables the keyring password for good.
Not desirable or ideal ?
there used to be this problem in Mint where Chrome would ask me for a keyring and i had to basically do the same thing, kinda a silly predicament

Members online