Can't install anything with apt install in ubuntu

glebov

New Member
Joined
Apr 1, 2024
Messages
3
Reaction score
0
Credits
23
Any request like sudo apt-get install *** starts the installation process, but when unpacking it throws an error, after which some packages are installed and work fine, some do not work fine, and some do not show up as installed.


Code:
dpkg: error processing package openmpi-bin (--configure):
 installed openmpi-bin package post-installation script subprocess returned error exit status 2
dpkg: dependency problems prevent configuration of mpi-default-bin:
 mpi-default-bin depends on openmpi-bin; however:
  Package openmpi-bin is not configured yet.

dpkg: error processing package mpi-default-bin (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libcoarrays-openmpi-dev:amd64:
 libcoarrays-openmpi-dev:amd64 depends on openmpi-bin; however:
  Package openmpi-bin is not configured yet.

dpkg: error processing package libcoarrays-openmpi-dev:amd64 (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libopenmpi-dev:amd64:
 libopenmpi-dev:amd64 depends on openmpi-bin (>= 3.0.0-1); however:
  Package openmpi-bin is not configured yet.

dpkg: error processing package libopenmpi-dev:amd64 (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libboost-mpi-python1.74.0:
 libboost-mpi-python1.74.0 depends on mpi-defauNo apport report written because the error message indicates it's a follow-up error from a previous failure.
           No apport report written because the error message indicates it's a follow-up error from a previous failure.
                                                                                                                       No apport report written because MaxReports has already been reached
                                           No apport report written because MaxReports has already been reached
                                                                                                               lt-bin; however:
  Package mpi-default-bin is not configured yet.

dpkg: error processing package libboost-mpi-python1.74.0 (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libboost-mpi-python1.74-dev:
 libboost-mpi-python1.74-dev depends on libboost-mpi-python1.74.0 (= 1.74.0-14ubuntu3); however:
  Package libboost-mpi-python1.74.0 is not configured yet.

dpkg: error processing package libboost-mpi-python1.74-dev (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libboost-mpi-python-dev:
 libboost-mpi-python-dev depends on libboost-mpi-python1.74-dev; however:
  Package libboost-mpi-python1.74-dev is not configured yet.

dpkg: error processing package libboost-mpi-python-dev (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libboost-all-dev:
 libboost-all-dev depends on libboost-mpi-python-dev; however:
  PackageNo apport report written because MaxReports has already been reached
                                                                             No apport report written because MaxReports has already been reached
 No apport report written because MaxReports has already been reached
                                                                      libboost-mpi-python-dev is not configured yet.

dpkg: error processing package libboost-all-dev (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of mpi-default-dev:
 mpi-default-dev depends on libopenmpi-dev; however:
  Package libopenmpi-dev:amd64 is not configured yet.

dpkg: error processing package mpi-default-dev (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libboost-mpi1.74-dev:
 libboost-mpi1.74-dev depends on mpi-default-dev; however:
  Package mpi-default-dev is not configured yet.

No apport report written because MaxReports has already been reached
                                                                    No apport report written because MaxReports has already been reached
                                                                                                                                        dpkg: error processing package libboost-mpi1.74-dev (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libboost-mpi-dev:
 libboost-mpi-dev depends on libboost-mpi1.74-dev; however:
  Package libboost-mpi1.74-dev is not configured yet.

dpkg: error processing package libboost-mpi-dev (--configure):
 dependency problems - leaving unconfigured
No apport report written because MaxReports has already been reached
                                                                    Errors were encountered while processing:
 openmpi-bin
 mpi-default-bin
 libcoarrays-openmpi-dev:amd64
 libopenmpi-dev:amd64
 libboost-mpi-python1.74.0
 libboost-mpi-python1.74-dev
 libboost-mpi-python-dev
 libboost-all-dev
 mpi-default-dev
 libboost-mpi1.74-dev
 libboost-mpi-dev
E: Sub-process /usr/bin/dpkg returned an error code (1)

I tried the following:

Code:
sudo apt clean
sudo dpkg --configure -a
sudo apt -f install
sudo dpkg --remove --force-remove-reinstreq openmpi-bin
sudo apt update
sudo apt install openmpi-bin
sudo apt autoremove
sudo apt update && sudo apt upgrade

But sudo dpkg --remove --force-remove-reinstreq openmpi-bin answer:
Code:
dpkg: dependency problems prevent removal of openmpi-bin:
 mpi-default-bin depends on openmpi-bin.
 libopenmpi-dev:amd64 depends on openmpi-bin (>= 3.0.0-1).
 libcoarrays-openmpi-dev:amd64 depends on openmpi-bin.

dpkg: error processing package openmpi-bin (--remove):
 dependency problems - not removing
Errors were encountered while processing:
 openmpi-bin

This answer from this and this also can not help me.
Code:
sudo apt-get clean
sudo apt-get update
sudo apt-get upgrade
sudo apt-get install -f

I tried everything from apt update to restart. What can I do to remove this error and install packages correctly?
 


Code:
dpkg: error processing package openmpi-bin (--configure):
 installed openmpi-bin package post-installation script subprocess returned error exit status 2
dpkg: dependency problems prevent configuration of mpi-default-bin:
 mpi-default-bin depends on openmpi-bin; however:
  Package openmpi-bin is not configured yet.

dpkg: error processing package mpi-default-bin (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libcoarrays-openmpi-dev:amd64:
 libcoarrays-openmpi-dev:amd64 depends on openmpi-bin; however:
  Package openmpi-bin is not configured yet.

dpkg: error processing package libcoarrays-openmpi-dev:amd64 (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libopenmpi-dev:amd64:
 libopenmpi-dev:amd64 depends on openmpi-bin (>= 3.0.0-1); however:
  Package openmpi-bin is not configured yet.

dpkg: error processing package libopenmpi-dev:amd64 (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libboost-mpi-pythonNo apport 
report written because the error message indicates it's a follow-up error from a
 previous failure.
                  No apport report written because the error message indicates i
t's a follow-up error from a previous failure.
                                              No apport report written because M
axReports has already been reached
                                  No apport report written because MaxReports ha
s already been reached
                      No apport report written because MaxReports has already be
en reached
          No apport report written because MaxReports has already been reached
                                                                              No
 apport report written because MaxReports has already been reached
                                                                  No apport repo
rt written because MaxReports has already been reached
                                                      No apport report written b
ecause MaxReports has already been reached
                                          No apport report written because MaxRe
ports has already been reached
                              1.74.0:
 libboost-mpi-python1.74.0 depends on mpi-default-bin; however:
  Package mpi-default-bin is not configured yet.

dpkg: error processing package libboost-mpi-python1.74.0 (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libboost-mpi-python1.74-dev:
 libboost-mpi-python1.74-dev depends on libboost-mpi-python1.74.0 (= 1.74.0-14ub
untu3); however:
  Package libboost-mpi-python1.74.0 is not configured yet.

dpkg: error processing package libboost-mpi-python1.74-dev (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libboost-mpi-python-dev:
 libboost-mpi-python-dev depends on libboost-mpi-python1.74-dev; however:
  Package libboost-mpi-python1.74-dev is not configured yet.

dpkg: error processing package libboost-mpi-python-dev (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libboost-all-dev:
 libboost-all-dev depends on libboost-mpi-python-dev; however:
  Package libboost-mpi-python-dev is not configured yet.

dpkg: error processing package libboost-all-dev (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of mpi-default-dev:
 mpi-default-dev depends on libopenmpi-dev; however:
  Package libopenmpi-dev:amd64 is not configured yet.

dpkg: error processing package mpi-default-dev (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libboost-mpi1.74-dev:
 libboost-mpi1.74-dev depends on mpi-default-dev; however:
  Package mpi-default-dev is not configured yet.

dpkg: error processing package libboost-mpi1.74-dev (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libboost-mpi-dev:
 libboost-mpi-dev depends on libboost-mpi1.74-dev; however:
  Package libboost-mpi1.74-dev is not configured yet.

dpkg: error processing package libboost-mpi-dev (--configure):
 dependency problems - leaving unconfigured
Errors were encountered while processing:
 openmpi-bin
 mpi-default-bin
 libcoarrays-openmpi-dev:amd64
 libopenmpi-dev:amd64
 libboost-mpi-python1.74.0
 libboost-mpi-python1.74-dev
 libboost-mpi-python-dev
 libboost-all-dev
 mpi-default-dev
 libboost-mpi1.74-dev
 libboost-mpi-dev
E: Sub-process /usr/bin/dpkg returned an error code (1)
also
 
Go to a terminal and type this report the results

Code:
sudo dpkg --configure -a
 
Go to a terminal and type this report the results

Code:
sudo dpkg --configure -a
Code:
dpkg: dependency problems prevent configuration of libboost-mpi-python1.74.0:
 libboost-mpi-python1.74.0 depends on mpi-default-bin; however:
  Package mpi-default-bin is not configured yet.

dpkg: error processing package libboost-mpi-python1.74.0 (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libboost-mpi-python1.74-dev:
 libboost-mpi-python1.74-dev depends on libboost-mpi-python1.74.0 (= 1.74.0-14ubuntu3); however:
  Package libboost-mpi-python1.74.0 is not configured yet.

dpkg: error processing package libboost-mpi-python1.74-dev (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libcoarrays-openmpi-dev:amd64:
 libcoarrays-openmpi-dev:amd64 depends on openmpi-bin; however:
  Package openmpi-bin is not configured yet.

dpkg: error processing package libcoarrays-openmpi-dev:amd64 (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libboost-mpi-python-dev:
 libboost-mpi-python-dev depends on libboost-mpi-python1.74-dev; however:
  Package libboost-mpi-python1.74-dev is not configured yet.

dpkg: error processing package libboost-mpi-python-dev (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libboost-all-dev:
 libboost-all-dev depends on libboost-mpi-python-dev; however:
  Package libboost-mpi-python-dev is not configured yet.

dpkg: error processing package libboost-all-dev (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libopenmpi-dev:amd64:
 libopenmpi-dev:amd64 depends on openmpi-bin (>= 3.0.0-1); however:
  Package openmpi-bin is not configured yet.

dpkg: error processing package libopenmpi-dev:amd64 (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of mpi-default-dev:
 mpi-default-dev depends on libopenmpi-dev; however:
  Package libopenmpi-dev:amd64 is not configured yet.

dpkg: error processing package mpi-default-dev (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libboost-mpi1.74-dev:
 libboost-mpi1.74-dev depends on mpi-default-dev; however:
  Package mpi-default-dev is not configured yet.

dpkg: error processing package libboost-mpi1.74-dev (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libboost-mpi-dev:
 libboost-mpi-dev depends on libboost-mpi1.74-dev; however:
  Package libboost-mpi1.74-dev is not configured yet.

dpkg: error processing package libboost-mpi-dev (--configure):
 dependency problems - leaving unconfigured
Errors were encountered while processing:
 libboost-mpi-python1.74.0
 libboost-mpi-python1.74-dev
 libcoarrays-openmpi-dev:amd64
 libboost-mpi-python-dev
 libboost-all-dev
 libopenmpi-dev:amd64
 mpi-default-dev
 libboost-mpi1.74-dev
 libboost-mpi-dev
 
@glebov welcome to linux.org

You have not, so far, told us what you were doing prior to these errors occurring.

Were you
  • trying to install a package if so which, and was it by adding a PPA or other source, if so which?
Was it kicad or something similar?

Tell us more of the background leading up to this.

TIA

Chris Turner
wizardfromoz
 
Ok you have a broken package that the repositories can't not reconcile. Looks to be Libboost - So I would first go to Syanptic Package manager and click on edit tab and then fix broken. Then apply. If that does not work Remove the package you were trying to install. and try and update. If all that fails. see this page. It's for ubuntu but will work with any deb Distro.
 


Top