Purchase Linux CDs / DVDs / Flash Drives at OSDisc.com

Welcome to Our Community

While Linux.org has been around for a while, we recently changed management and had to purge most of the content (including users). If you signed up before April 23rd, 2017 please sign up again. Thanks!

Buying a new Computer/Laptop - Avoid screen tearing (and some more)

Discussion in 'Linux Hardware' started by tbtb, Dec 24, 2018.

  1. tbtb

    tbtb New Member

    Joined:
    Dec 24, 2018
    Messages:
    4
    Likes Received:
    1
    Hi!

    I went from Windows to Linux about 4 years ago, and from the beginning the problem with screen tearing has always been there. More or less. Sometimes it works fine for a long time, then it comes back again. Getting tired of this. really tired. So tired that I'm actually thinking about going back to Windows because of it. But I really don't want to. Linux is so much better when it comes to everything else.

    First, I could only use Linux Mint Cinnamon to avoid screen tearing, then that stopped working, and I got tearing. Switched to Debian with Gnome, and had no tearing for a long time, updated and, tearing all over again. Switched around like this for 4 years now. And right now, KDE Neon is the only distro that doesn't give me tearing, until now. It's not too bad, but it hurts my eyes when scrolling in Skype, scrolling in web browser, file manager etc. But I don't get tearing when watching videos (VLC/SMPlayer/YouTube works fine). I've tried every setting in the compositor, full screen repaint is what works best, but i'm not satisfied.

    What kind of graphics card works best with Linux to avoid tearing? What kind of screen? What kind of CPU? Should I go for Nvidia and Intel instead of AMD and Radeon? Please help me out with this! If you have a laptop or stationary PC, running Linux, with NO TEARING, please help me out!

    Now, my computer has started to randomly freeze, randomly reboot, randomly shutdown. And I've tried everything trying to find the problem, everything except getting a new motherboard and CPU. I've tested my RAM, and it's all OK. Switched power supply, switch hard drives, switched s-ata ports and so on. I've been building my own computers since I was 13-14 years old, now I'm 32 and have always been able to find out what's wrong with my computers, but not this time.


    (Log in to hide this advertisement)


    Now I'm thinking about buying a new one. Maybe a laptop or build my own PC again. And before buying the parts or a new laptop, I want to make SURE I don't go buy components that's not compatible with Linux, or that gives me screen tearing. I don't have that much money to spend on it, around 400USD, maybe 450USD. I don't play games or anything like that. I mostly use it to watch movies, youtube, surfing, skype etc.

    Is there ANY PC's/Laptops you can buy, that's made for Linux? It's been a long time since I bought new components or a new computer, so I'm not really up to speed with the latest equipment.

    This is what I use today:

    CPU: AMD A4-7300 APU with Radeon HD Graphics 3800.00 MHz
    SSD: INTENSO SSD 128GB
    Motherboard: Gigabyte F2A78M-D3H (F3)
    RAM: 2x Crucial Ballistix Sport 2GB
    Power Model: LC420H-12 MAX420 ATX Switching Power Supply
    And 2x Internal WD 4TB HDD's.
    Screen: Samsung T24C300 24" LED Screen/TV (with DVB-T) HDMI from Motherboard (built-in ATI Radeon Graphics) to HDMI-port on screen.

    // TB
     
  2. wizardfromoz

    wizardfromoz Super Moderator
    Staff Member Gold Supporter

    Joined:
    Apr 30, 2017
    Messages:
    2,110
    Likes Received:
    1,930
    NOW, I'm envious :)

    G'day @tbtb and welcome to linux.org :D

    What a tragic story, no wonder you are peed off.

    Can you give us the output for

    Code:
    inxi -Fxz
    ... the "z" will filter out your MAC addresses, better than "s".

    You may already be aware we have some other commands for getting details on the graphics, so the more the merrier.

    Cheers

    Chris Turner
    wizardfromoz

    BTW - have you got vsync enabled? And have you tried Wayland over the X Server?
     
  3. tbtb

    tbtb New Member

    Joined:
    Dec 24, 2018
    Messages:
    4
    Likes Received:
    1
    Hi! And thank you! :)

    This is what I got:

    System: Host: tbt-neon Kernel: 4.15.0-43-generic x86_64 bits: 64 gcc: 7.3.0
    Desktop: KDE Plasma 5.14.4 (Qt 5.11.2) Distro: KDE neon User Edition 5.14
    Machine: Device: desktop System: Gigabyte product: N/A serial: N/A
    Mobo: Gigabyte model: F2A78M-D3H v: x.x serial: N/A BIOS: American Megatrends v: F3 date: 01/08/2014
    CPU: Dual core AMD A4-7300 APU with Radeon HD Graphics (-MCP-) arch: Piledriver rev.1 cache: 2048 KB
    flags: (lm nx sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm) bmips: 15172
    clock speeds: max: 3800 MHz 1: 1934 MHz 2: 2418 MHz
    Graphics: Card: Advanced Micro Devices [AMD/ATI] Richland [Radeon HD 8470D] bus-ID: 00:01.0
    Display Server: x11 (X.Org 1.19.6 ) drivers: ati,radeon (unloaded: modesetting,fbdev,vesa)
    Resolution: [email protected]
    OpenGL: renderer: AMD ARUBA (DRM 2.50.0 / 4.15.0-43-generic, LLVM 6.0.0)
    version: 4.3 Mesa 18.0.5 Direct Render: Yes
    Audio: Card-1 Advanced Micro Devices [AMD] FCH Azalia Controller driver: snd_hda_intel bus-ID: 00:14.2
    Card-2 Advanced Micro Devices [AMD/ATI] Trinity HDMI Audio Controller
    driver: snd_hda_intel bus-ID: 00:01.1
    Sound: Advanced Linux Sound Architecture v: k4.15.0-43-generic
    Network: Card: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller
    driver: r8169 v: 2.3LK-NAPI port: e000 bus-ID: 01:00.0
    IF: enp1s0 state: up speed: 1000 Mbps duplex: full mac: <filter>
    Drives: HDD Total Size: 6129.2GB (0.8% used)
    ID-1: /dev/sdc model: INTENSO size: 128.0GB temp: 30C
    ID-2: /dev/sdb model: WDC_WD30EZRX size: 3000.6GB temp: 32C
    ID-3: /dev/sda model: WDC_WD30EZRX size: 3000.6GB temp: 31C
    Partition: ID-1: / size: 116G used: 47G (43%) fs: ext4 dev: /dev/dm-1
    ID-2: /boot size: 704M used: 229M (36%) fs: ext4 dev: /dev/sdc1
    ID-3: swap-1 size: 1.03GB used: 0.00GB (0%) fs: swap dev: /dev/dm-2
    RAID: No RAID devices: /proc/mdstat, md_mod kernel module present
    Sensors: System Temperatures: cpu: 6.2C mobo: N/A gpu: 2.0
    Fan Speeds (in rpm): cpu: N/A
    Info: Processes: 198 Uptime: 3 min Memory: 1406.4/7224.3MB Init: systemd runlevel: 5 Gcc sys: 7.3.0
    Client: Shell (bash 4.4.191) inxi: 2.3.56

    Oh, my wrong, got 2x3TB WD HDD's, not 4TB. And I just added 4GB of RAM. So, total of 8GB RAM right now.

    I have vsync enabled, "full screen repaint", tried all the options for vsync available in KDE Neon, full screen repaint works best.

    Have tried wayland, but Plasma (KDE) just crashes and get's really...unstable when I try using it. Right now, I just want to throw this machine out the window, and smash it to pieces. Yes, that's how I feel.

    Most annoying problem right now, is the random freezing, random reboots and shutdowns. Sometimes it runs for days without any problem.

    Merry Christmas btw :)

    // tbtb
     
    wizardfromoz likes this.
  4. wizardfromoz

    wizardfromoz Super Moderator
    Staff Member Gold Supporter

    Joined:
    Apr 30, 2017
    Messages:
    2,110
    Likes Received:
    1,930
    OK, Ta (pron. "tar", Aussie for thank you) for that output, Mate.

    (Wizard appears in a puff of smoke humming " 'tis the season to be jolly")

    If you haven't made the acquaintance yet of Tony George's Timeshift, now is a good time.

    Read my Tute here and apply the PPA to your KDE Neon, and install it.

    I'll be back shortly.

    BTW - also a good easy tute by Linux Lite here if you prefer.

    Wiz
     
  5. wizardfromoz

    wizardfromoz Super Moderator
    Staff Member Gold Supporter

    Joined:
    Apr 30, 2017
    Messages:
    2,110
    Likes Received:
    1,930
    Did I say don't throw that machine out the window?

    If not

    DON'T THROW THAT MACHINE OUT THE WINDOW ... YET !!

    Got some leads you can try if you are interested, putting them together, back soon.

    Chris
     
  6. wizardfromoz

    wizardfromoz Super Moderator
    Staff Member Gold Supporter

    Joined:
    Apr 30, 2017
    Messages:
    2,110
    Likes Received:
    1,930
    Just so you follow my methodology:

    ... got me to Googling

    linux tearing faulty hdmi cable

    ... went to the Tom's Hardware link http://www.tomshardware.com/answers/id-2364689/bad-hdmi-cable-screen-tearing.html

    and had a read through that. So I guess that is an obvious question for you if you have not tried a different cable?

    Also saw the references on vsync from that search, hence my asking you.

    One thing led to another, and thus the Wayland query.

    This reference is worth reading, for a reasons I will explain - https://unix.stackexchange.com/questions/182801/why-is-video-tearing-such-a-problem-in-linux

    The second answer, there, posted by their member kirill-a and receiving 16 up votes, was edited by one St├ęphane Chazelas . This is a significant name in Linux.

    Linux's main terminal shell, the Bash (Bourne Again SHell) is maintained by one Chet Ramey.

    Around September 26 2014, we had our most significant flaw found in the Linux Kernel, and the event was known alternatively as Shell Shock and The Bash Bug.

    Stephane was the one who found it, and he reported it to Chet Ramey that day, and the entire Linux Community, led by Red Hat, had it wrapped up within 24 - 48 hours. New kernel, &c.

    So I figure if Stephane has edited that Post, it is likely good value. (You've gotta think like a wizard - weird).

    To cut a long story short, (hurrah, they cheer, Wizard turns some into toads and breaks out his 9-iron)

    I found this video, it is 6:35 long. The guy talks more than he does, or shows (don't know anybody like that), but he references a PPA (Personal Package Archive) that can be added to a Debian-derivative Linux, which should include your KDE Neon.

    He also deals with the issue at his blog, here - https://ajreissig.com/eliminate-screen-tearing-amd-graphics/

    DO NOTE his reference to some having problems, and hence I reiterate you should make the acquaintance of Timeshift, so that you can roll back your system if need be.

    I'll leave you with the video and let us know how you go.





    Cheers

    Wizard
     
  7. mal-2

    mal-2 New Member

    Joined:
    Dec 27, 2018
    Messages:
    24
    Likes Received:
    10
    The HDMI cable doesnt look like the problem - if so the tearing would not stop rendering videos.

    It looks for me more likely that theres a driver problem as there is also something marked "unloaded":

    "Graphics: Card: Advanced Micro Devices [AMD/ATI] Richland [Radeon HD 8470D] bus-ID: 00:01.0
    Display Server: x11 (X.Org 1.19.6 ) drivers: ati,radeon (unloaded: modesetting,fbdev,vesa)
    Resolution: [email protected]
    OpenGL: renderer: AMD ARUBA (DRM 2.50.0 / 4.15.0-43-generic, LLVM 6.0.0)
    version: 4.3 Mesa 18.0.5 Direct Render: Yes"


    On the otherhand the Mesa Driver seems ok - thats afaik the 3D-Part (OpenGL, Vulcan, whatsoever...) of the driver. As most video player make use of hardware acceleration that would also explain why video rendering doesnt cause tearing while the classical desktop rendering does.

    Can you run "lsmod" and print the result? If the module is obvious "modinfo <module_name>" would even help more.

    err... and as I notice just jet, am I right that there is the Radeon HD 8470D and the (IGP) A4-7300 APU with Radeon HD Graphics? Can you then check if the monitor is plugged into the motherboard or into the graphic card?
     
    wizardfromoz likes this.
  8. wizardfromoz

    wizardfromoz Super Moderator
    Staff Member Gold Supporter

    Joined:
    Apr 30, 2017
    Messages:
    2,110
    Likes Received:
    1,930
    Perhaps something like

    Code:
    lsmod | grep video
    ... might shorten that search?

    BTW @mal-2 welcome to linux.org :)

    Wizard
     
  9. mal-2

    mal-2 New Member

    Joined:
    Dec 27, 2018
    Messages:
    24
    Likes Received:
    10
    Not sure if that works. Lsmod shows only a single string per module. At my Intel driven laptop it's just "i915". So it could also be something like "HD8470D" and for the APU I have no idea at all. I looked also around on the web and found often mentionned "frgxl" as driver name in combination with the APU.

    Unfortunately I didnt pay close attention to AMD drivers over the last years but if I'm not wrong there was a change from closed to open source (and possibly that came along with a name change). So I have really no idea.

    But the modinfo gives some more information in the description:

    filename: /lib/modules/4.******-amd64/kernel/drivers/gpu/drm/i915/i915.ko
    license: GPL and additional rights
    description: Intel Graphics
    author: Intel Corporation
    author: Tungsten Graphics, Inc.
    firmware: i915/bxt_dmc_ver1_07.bin

    So he could try this little script which shows the lsmod-string with a short modinfo description.
    Code:
    cat /proc/modules | awk '{print $1}' | while read line; do \
    echo  "$line \n=============";\
    modinfo -d $line;\
    echo  "\n\n";\
     done | less
     
  10. wizardfromoz

    wizardfromoz Super Moderator
    Staff Member Gold Supporter

    Joined:
    Apr 30, 2017
    Messages:
    2,110
    Likes Received:
    1,930
    I was talking about this

    Code:
    [[email protected] ~]$ lsmod | grep video
    uvcvideo              110592  0
    videobuf2_vmalloc      16384  1 uvcvideo
    videobuf2_memops       16384  1 videobuf2_vmalloc
    videobuf2_v4l2         28672  1 uvcvideo
    videobuf2_common       53248  2 videobuf2_v4l2,uvcvideo
    videodev              212992  3 videobuf2_v4l2,uvcvideo,videobuf2_common
    media                  45056  2 videodev,uvcvideo
    ... as opposed to this

    [[email protected] ~]$ lsmod
    Module Size Used by
    cmac 16384 1
    rfcomm 86016 16
    ccm 20480 3
    snd_hda_codec_hdmi 57344 1
    hid_multitouch 24576 0
    fuse 118784 3
    iTCO_wdt 16384 0
    iTCO_vendor_support 16384 1 iTCO_wdt
    bnep 24576 2
    nls_iso8859_1 16384 1
    nls_cp437 20480 1
    vfat 24576 1
    fat 81920 1 vfat
    arc4 16384 2
    ses 20480 0
    enclosure 16384 1 ses
    scsi_transport_sas 45056 1 ses
    dell_wmi 16384 0
    wmi_bmof 16384 0
    intel_rapl 24576 0
    intel_powerclamp 16384 0
    coretemp 16384 0
    kvm_intel 237568 0
    dell_laptop 24576 1
    amdkfd 221184 1
    amd_iommu_v2 20480 1 amdkfd
    kvm 741376 1 kvm_intel
    dell_smbios 28672 2 dell_wmi,dell_laptop
    irqbypass 16384 1 kvm
    crct10dif_pclmul 16384 0
    dell_wmi_descriptor 16384 2 dell_wmi,dell_smbios
    crc32_pclmul 16384 0
    snd_hda_codec_realtek 110592 1
    ghash_clmulni_intel 16384 0
    dcdbas 16384 1 dell_smbios
    ath10k_pci 61440 0
    pcbc 16384 0
    snd_hda_codec_generic 86016 1 snd_hda_codec_realtek
    dell_smm_hwmon 16384 0
    ath10k_core 536576 1 ath10k_pci
    aesni_intel 200704 4
    aes_x86_64 20480 1 aesni_intel
    crypto_simd 16384 1 aesni_intel
    ath 36864 1 ath10k_core
    cryptd 28672 3 crypto_simd,ghash_clmulni_intel,aesni_intel
    glue_helper 16384 1 aesni_intel
    intel_cstate 16384 0
    intel_uncore 139264 0
    mac80211 942080 1 ath10k_core
    intel_rapl_perf 16384 0
    amdgpu 3366912 1
    psmouse 172032 0
    input_leds 16384 0
    pcspkr 16384 0
    rtsx_usb_ms 20480 0
    cfg80211 798720 3 ath,mac80211,ath10k_core
    memstick 16384 1 rtsx_usb_ms
    mousedev 24576 0
    joydev 24576 0
    uvcvideo 110592 0
    videobuf2_vmalloc 16384 1 uvcvideo
    videobuf2_memops 16384 1 videobuf2_vmalloc
    chash 16384 1 amdgpu
    snd_soc_skl 118784 0
    r8169 90112 0
    videobuf2_v4l2 28672 1 uvcvideo
    gpu_sched 28672 1 amdgpu
    videobuf2_common 53248 2 videobuf2_v4l2,uvcvideo
    mii 16384 1 r8169
    snd_soc_skl_ipc 73728 1 snd_soc_skl
    btusb 53248 0
    ttm 126976 1 amdgpu
    btrtl 16384 1 btusb
    snd_soc_sst_ipc 16384 1 snd_soc_skl_ipc
    videodev 212992 3 videobuf2_v4l2,uvcvideo,videobuf2_common
    btbcm 16384 1 btusb
    snd_soc_sst_dsp 36864 1 snd_soc_skl_ipc
    media 45056 2 videodev,uvcvideo
    btintel 24576 1 btusb
    snd_hda_ext_core 28672 1 snd_soc_skl
    i915 2076672 4
    snd_soc_acpi 16384 1 snd_soc_skl
    bluetooth 643072 41 btrtl,btintel,btbcm,bnep,btusb,rfcomm
    snd_soc_core 270336 1 snd_soc_skl
    ecdh_generic 24576 2 bluetooth
    snd_compress 24576 1 snd_soc_core
    rfkill 28672 8 bluetooth,dell_laptop,cfg80211
    ac97_bus 16384 1 snd_soc_core
    snd_pcm_dmaengine 16384 1 snd_soc_core
    ucsi_acpi 16384 0
    snd_hda_intel 45056 3
    typec_ucsi 36864 1 ucsi_acpi
    i2c_algo_bit 16384 2 amdgpu,i915
    snd_hda_codec 151552 4 snd_hda_codec_generic,snd_hda_codec_hdmi,snd_hda_intel,snd_hda_codec_realtek
    typec 32768 1 typec_ucsi
    wmi 28672 4 dell_wmi,wmi_bmof,dell_smbios,dell_wmi_descriptor
    drm_kms_helper 200704 2 amdgpu,i915
    snd_hda_core 94208 7 snd_hda_codec_generic,snd_hda_codec_hdmi,snd_hda_intel,snd_hda_ext_core,snd_hda_codec,snd_hda_codec_realtek,snd_soc_skl
    i2c_hid 24576 0
    snd_hwdep 16384 1 snd_hda_codec
    drm 483328 9 gpu_sched,drm_kms_helper,amdgpu,i915,ttm
    snd_pcm 131072 8 snd_hda_codec_hdmi,snd_hda_intel,snd_hda_ext_core,snd_hda_codec,snd_soc_core,snd_soc_skl,snd_hda_core,snd_pcm_dmaengine
    idma64 20480 0
    snd_timer 36864 1 snd_pcm
    intel_gtt 24576 1 i915
    snd 98304 16 snd_hda_codec_generic,snd_hda_codec_hdmi,snd_hwdep,snd_hda_intel,snd_hda_codec,snd_hda_codec_realtek,snd_timer,snd_compress,snd_soc_core,snd_pcm
    agpgart 49152 3 intel_gtt,ttm,drm
    intel_hid 16384 0
    evdev 24576 18
    int3400_thermal 16384 0
    syscopyarea 16384 1 drm_kms_helper
    sysfillrect 16384 1 drm_kms_helper
    mei_me 49152 0
    int3403_thermal 16384 0
    mac_hid 16384 0
    battery 24576 0
    soundcore 16384 1 snd
    acpi_thermal_rel 16384 1 int3400_thermal
    sparse_keymap 16384 2 intel_hid,dell_wmi
    processor_thermal_device 16384 0
    sysimgblt 16384 1 drm_kms_helper
    int3402_thermal 16384 0
    ac 16384 0
    intel_lpss_pci 20480 0
    i2c_i801 32768 0
    mei 110592 1 mei_me
    fb_sys_fops 16384 1 drm_kms_helper
    int340x_thermal_zone 16384 3 int3403_thermal,int3402_thermal,processor_thermal_device
    intel_lpss 16384 1 intel_lpss_pci
    intel_soc_dts_iosf 16384 1 processor_thermal_device
    intel_pch_thermal 16384 0
    pcc_cpufreq 16384 0
    uinput 20480 0
    crypto_user 16384 0
    ip_tables 28672 0
    x_tables 45056 1 ip_tables
    ext4 745472 1
    crc32c_generic 16384 0
    crc16 16384 2 bluetooth,ext4
    mbcache 16384 1 ext4
    jbd2 122880 1 ext4
    fscrypto 32768 1 ext4
    rtsx_usb_sdmmc 28672 0
    led_class 16384 3 input_leds,rtsx_usb_sdmmc,dell_laptop
    hid_generic 16384 0
    mmc_core 180224 1 rtsx_usb_sdmmc
    uas 28672 0
    usbhid 57344 0
    usb_storage 73728 1 uas
    hid 139264 4 i2c_hid,usbhid,hid_multitouch,hid_generic
    rtsx_usb 20480 2 rtsx_usb_sdmmc,rtsx_usb_ms
    sr_mod 28672 0
    cdrom 69632 1 sr_mod
    sd_mod 61440 3
    ahci 40960 2
    libahci 40960 1 ahci
    serio_raw 16384 0
    libata 278528 2 libahci,ahci
    atkbd 32768 0
    libps2 16384 2 atkbd,psmouse
    xhci_pci 16384 0
    crc32c_intel 24576 2
    scsi_mod 258048 7 ses,scsi_transport_sas,sd_mod,usb_storage,uas,libata,sr_mod
    xhci_hcd 270336 1 xhci_pci
    i8042 32768 1 dell_laptop
    serio 28672 6 serio_raw,atkbd,psmouse,i8042

    And by using the former, I can pick something like the one listed as

    uvcvideo

    and get this with modinfo

    [[email protected] ~]$ modinfo uvcvideo
    filename: /lib/modules/4.18.16-rt9-MANJARO/kernel/drivers/media/usb/uvc/uvcvideo.ko.xz
    version: 1.1.1
    license: GPL
    description: USB Video Class driver
    author: Laurent Pinchart <[email protected]>
    srcversion: B768DE770525128619C215B
    alias: usb:v*p*d*dc*dsc*dp*ic0Eisc01ip01in*
    alias: usb:v*p*d*dc*dsc*dp*ic0Eisc01ip00in*
    alias: usb:v2833p0211d*dc*dsc*dp*icFFisc01ip00in*
    alias: usb:v2833p0201d*dc*dsc*dp*ic0Eisc01ip00in*
    alias: usb:v1C4Fp3000d*dc*dsc*dp*ic0Eisc01ip00in*
    alias: usb:v1B3Fp2002d*dc*dsc*dp*ic0Eisc01ip00in*
    alias: usb:v1B3Bp2951d*dc*dsc*dp*ic0Eisc01ip00in*
    alias: usb:v19ABp1000d00*dc*dsc*dp*ic0Eisc01ip00in*
    alias: usb:v19ABp1000d01[0-1]*dc*dsc*dp*ic0Eisc01ip00in*
    alias: usb:v19ABp1000d012[0-6]dc*dsc*dp*ic0Eisc01ip00in*
    alias: usb:v199Ep8102d*dc*dsc*dp*icFFisc01ip00in*
    alias: usb:v18ECp3290d*dc*dsc*dp*ic0Eisc01ip00in*
    alias: usb:v18ECp3288d*dc*dsc*dp*ic0Eisc01ip00in*
    alias: usb:v18ECp3188d*dc*dsc*dp*ic0Eisc01ip00in*
    alias: usb:v18CDpCAFEd*dc*dsc*dp*ic0Eisc01ip00in*
    alias: usb:v1871p0516d*dc*dsc*dp*icFFisc01ip00in*
    alias: usb:v1871p0306d*dc*dsc*dp*ic0Eisc01ip00in*
    alias: usb:v17EFp480Bd*dc*dsc*dp*ic0Eisc01ip00in*
    alias: usb:v17DCp0202d*dc*dsc*dp*ic0Eisc01ip00in*
    alias: usb:v174Fp8A34d*dc*dsc*dp*ic0Eisc01ip00in*
    alias: usb:v174Fp8A33d*dc*dsc*dp*ic0Eisc01ip00in*
    alias: usb:v174Fp8A31d*dc*dsc*dp*ic0Eisc01ip00in*
    alias: usb:v174Fp8A12d*dc*dsc*dp*ic0Eisc01ip00in*
    alias: usb:v174Fp5931d*dc*dsc*dp*ic0Eisc01ip00in*
    alias: usb:v174Fp5212d*dc*dsc*dp*ic0Eisc01ip00in*
    alias: usb:v152Dp0310d*dc*dsc*dp*ic0Eisc01ip00in*
    alias: usb:v13D3p5103d*dc*dsc*dp*ic0Eisc01ip00in*
    alias: usb:v0E8Dp0004d*dc*dsc*dp*ic0Eisc01ip00in*
    alias: usb:v0BD3p0555d*dc*dsc*dp*ic0Eisc01ip00in*
    alias: usb:v0AC8p3420d*dc*dsc*dp*ic0Eisc01ip00in*
    alias: usb:v0AC8p3410d*dc*dsc*dp*ic0Eisc01ip00in*
    alias: usb:v0AC8p332Dd*dc*dsc*dp*ic0Eisc01ip00in*
    alias: usb:v06F8p300Cd*dc*dsc*dp*ic0Eisc01ip00in*
    alias: usb:v05E3p0505d*dc*dsc*dp*ic0Eisc01ip00in*
    alias: usb:v05C8p0403d*dc*dsc*dp*ic0Eisc01ip00in*
    alias: usb:v05ACp8600d*dc*dsc*dp*ic0Eisc01ip00in*
    alias: usb:v05ACp8501d*dc*dsc*dp*ic0Eisc01ip00in*
    alias: usb:v05A9p7670d*dc*dsc*dp*ic0Eisc01ip00in*
    alias: usb:v05A9p264Ad*dc*dsc*dp*ic0Eisc01ip00in*
    alias: usb:v05A9p2643d*dc*dsc*dp*ic0Eisc01ip00in*
    alias: usb:v05A9p2641d*dc*dsc*dp*ic0Eisc01ip00in*
    alias: usb:v05A9p2640d*dc*dsc*dp*ic0Eisc01ip00in*
    alias: usb:v058Fp3820d*dc*dsc*dp*ic0Eisc01ip00in*
    alias: usb:v04F2pB071d*dc*dsc*dp*ic0Eisc01ip00in*
    alias: usb:v046Dp082Dd*dc*dsc*dp*ic0Eisc01ip00in*
    alias: usb:v046Dp08C7d*dc*dsc*dp*icFFisc01ip00in*
    alias: usb:v046Dp08C6d*dc*dsc*dp*icFFisc01ip00in*
    alias: usb:v046Dp08C5d*dc*dsc*dp*icFFisc01ip00in*
    alias: usb:v046Dp08C3d*dc*dsc*dp*icFFisc01ip00in*
    alias: usb:v046Dp08C2d*dc*dsc*dp*icFFisc01ip00in*
    alias: usb:v046Dp08C1d*dc*dsc*dp*icFFisc01ip00in*
    alias: usb:v045Ep0723d*dc*dsc*dp*ic0Eisc01ip00in*
    alias: usb:v045Ep0721d*dc*dsc*dp*ic0Eisc01ip00in*
    alias: usb:v045Ep00F8d*dc*dsc*dp*ic0Eisc01ip00in*
    alias: usb:v0458p706Ed*dc*dsc*dp*ic0Eisc01ip00in*
    alias: usb:v0416pA91Ad*dc*dsc*dp*ic0Eisc01ip00in*
    depends: videobuf2-v4l2,videodev,videobuf2-common,videobuf2-vmalloc,media
    retpoline: Y
    intree: Y
    name: uvcvideo
    vermagic: 4.18.16-rt9-MANJARO SMP preempt mod_unload modversions
    sig_id: PKCS#7
    signer:
    sig_key:
    sig_hashalgo: md4
    signature: 30:82:02:A5:06:09:2A:86:48:86:F7:0D:01:07:02:A0:82:02:96:30:
    82:02:92:02:01:01:31:0D:30:0B:06:09:60:86:48:01:65:03:04:02:
    03:30:0B:06:09:2A:86:48:86:F7:0D:01:07:01:31:82:02:6F:30:82:
    02:6B:02:01:01:30:46:30:2E:31:2C:30:2A:06:03:55:04:03:0C:23:
    42:75:69:6C:64:20:74:69:6D:65:20:61:75:74:6F:67:65:6E:65:72:
    61:74:65:64:20:6B:65:72:6E:65:6C:20:6B:65:79:02:14:57:CC:73:
    B0:0E:82:4A:8D:92:1E:8E:22:42:C0:F8:14:CA:82:67:5A:30:0B:06:
    09:60:86:48:01:65:03:04:02:03:30:0D:06:09:2A:86:48:86:F7:0D:
    01:01:01:05:00:04:82:02:00:B2:0E:C3:7B:02:53:19:8F:2E:DE:D6:
    F5:E2:56:52:6C:33:9B:11:68:7C:B6:64:F2:59:22:43:69:AC:F1:5C:
    CB:DA:24:90:B5:95:12:FC:25:16:11:62:BE:F7:59:78:AB:2A:D4:AF:
    E8:69:9A:5B:2F:CF:50:97:DB:72:9B:6B:FB:FB:2A:E0:AC:9B:3E:CC:
    00:E9:D8:7A:D0:79:ED:AB:C1:1D:16:8B:87:4E:DD:2B:3F:12:F8:A1:
    F6:08:E5:9A:3D:A2:DD:73:51:35:8D:22:82:E0:82:9C:CB:B8:A5:B4:
    0D:C4:F6:74:18:82:4E:2B:19:75:AD:E4:67:D2:68:0C:7C:BF:A3:95:
    71:79:03:5C:04:46:67:93:4B:A3:51:AF:27:0D:B0:64:DA:D5:48:8C:
    FB:C2:F0:0B:6B:D2:BE:A5:FC:33:E2:3A:3A:0F:8E:94:8C:7B:5D:DC:
    85:94:65:94:99:1A:9A:D5:36:E4:CE:95:C7:F9:7E:2F:25:F9:97:B3:
    55:28:D7:66:CD:F6:7E:FB:87:D8:67:01:52:D2:A9:DD:EC:38:59:75:
    84:57:51:4D:BF:37:D8:89:96:9C:14:CC:01:2B:CD:E6:B7:AE:8A:3F:
    39:AE:B2:07:20:BB:96:9B:5C:C2:D6:32:C7:08:7A:59:DD:6D:2B:A7:
    DE:49:B6:FB:F7:3D:17:8C:F2:BD:D5:0F:C8:C4:AA:63:EA:30:93:AC:
    BE:E5:40:67:8C:03:73:DA:9C:C5:4D:D0:8B:02:29:E1:D4:41:61:7E:
    7A:A4:E5:F3:F2:9C:B5:C4:AE:7A:1F:0E:9A:88:58:F7:8F:33:84:26:
    E8:67:07:46:4D:2C:EC:C1:06:11:00:3C:0B:EE:5A:D8:22:EA:AE:43:
    19:24:06:71:49:80:92:84:DE:36:72:E3:B0:20:3F:87:F1:A4:15:08:
    B6:02:A5:AE:6A:77:E0:38:8A:A2:30:7E:FB:E0:95:B3:80:34:E9:6D:
    3B:C8:7D:57:FA:B0:70:03:94:E1:DB:AC:63:9F:F7:2B:1D:AC:EE:F3:
    C5:4B:1C:9D:49:39:BF:83:8D:89:22:EC:09:A9:D5:A4:C1:F4:32:F1:
    F8:19:47:27:65:92:27:E2:3F:5F:2A:DF:7E:75:6B:76:C7:86:A7:74:
    D2:AC:AE:A7:7F:3A:AF:2E:F8:97:7F:71:AB:62:F1:CC:A6:32:48:BE:
    31:AF:D8:08:7E:49:A2:55:82:69:F3:E6:53:82:0B:3A:36:14:26:F6:
    39:8E:C3:CD:F4:3F:6C:6D:4F:6E:DC:D0:47:9A:32:6E:E0:BC:7A:E8:
    11:59:20:CE:B6:A6:CE:15:B4:59:D2:4A:85:F5:5D:3B:D7:13:31:79:
    BD
    parm: clock:Video buffers timestamp clock
    parm: hwtimestamps:Use hardware timestamps (uint)
    parm: nodrop:Don't drop incomplete frames (uint)
    parm: quirks:Forced device quirks (uint)
    parm: trace:Trace level bitmask (uint)
    parm: timeout:Streaming control requests timeout (uint)

    I like the script idea, though

    Cheers

    Wizard
     
  11. mal-2

    mal-2 New Member

    Joined:
    Dec 27, 2018
    Messages:
    24
    Likes Received:
    10
    Sometimes I just love the "Tab" with Bash-completion. Just hit it some moments ago and found a program called "xdriinfo". And guess what that program does? It displays just the connected screens and the graphic driver :D

    If not available, X11-utils will provide it.

    Just Enter "xdriinfo" and it prints out the screen and the driver.
    With "xdriinfo options <driver_name>" it will also list the driver config.
     
  12. tbtb

    tbtb New Member

    Joined:
    Dec 24, 2018
    Messages:
    4
    Likes Received:
    1
    Hi!

    Thank you for your answer! I will check all this when I got the time.

    But I don't think it's the cable, Since I can play videos in VLC/YT without any tearing.

    I've got a bigger issue then the tearing also. My computer continues to freeze/reboot randomly. Really annoying. I think it's the motherboard that's not working as it should, since I've tried to switch all other parts (except another CPU). Different RAM, HDD/SSD, SATA-cables, fans, Power supply, etc. Nothing works. :/

    However, I will try to fix this tearing anyway. Can't afford a new motherboard right now anyway (and it might not even be the problem...).

    // tbtb
     
  13. tbtb

    tbtb New Member

    Joined:
    Dec 24, 2018
    Messages:
    4
    Likes Received:
    1
    Yes, the cable doesn't seem to be the problem. Have tried another one too.

    Here is lsmod:

    Code:
    Module                  Size  Used by
    nf_conntrack_ipv6      20480  1
    nf_defrag_ipv6         36864  1 nf_conntrack_ipv6
    nf_conntrack_ipv4      16384  1
    nf_defrag_ipv4         16384  1 nf_conntrack_ipv4
    nft_ct                 20480  1
    nf_conntrack          131072  3 nf_conntrack_ipv6,nf_conntrack_ipv4,nft_ct
    libcrc32c              16384  1 nf_conntrack
    nft_meta               16384  33
    nf_tables_inet         16384  3
    nf_tables_ipv6         16384  1 nf_tables_inet
    nf_tables_ipv4         16384  1 nf_tables_inet
    nf_tables              90112  113 nf_tables_ipv4,nft_ct,nf_tables_inet,nft_meta,nf_tables_ipv6
    nfnetlink              16384  1 nf_tables
    pci_stub               16384  1
    vboxpci                24576  0
    vboxnetadp             28672  0
    vboxnetflt             28672  0
    vboxdrv               471040  3 vboxpci,vboxnetadp,vboxnetflt
    input_leds             16384  0
    edac_mce_amd           28672  0
    kvm_amd                86016  0
    kvm                   598016  1 kvm_amd
    irqbypass              16384  1 kvm
    serio_raw              16384  0
    k10temp                16384  0
    snd_hda_codec_realtek   106496  1
    snd_hda_codec_generic    73728  1 
    modinfo <module_name> Don't know what to put in module name? :p

    Thanks for helping out!
     
  14. mal-2

    mal-2 New Member

    Joined:
    Dec 27, 2018
    Messages:
    24
    Likes Received:
    10
    That looks or like a virtual machine to me? Which distribution are you running again?
     
  15. olds442

    olds442 Member

    Joined:
    Dec 2, 2018
    Messages:
    59
    Likes Received:
    28
    Just a thought...I have been doing gaming for many years, and have always ran a separate video card. I can get rid of the screen tears by using vsync. Have you considered going to a video card like an nVidia GTX1050? That would help with performance, and free up your memory, since you would be going through the card to process the graphics instead of using the system memory.

    I am just now learning about Linux, so I can't give any solutions about command lines and so on, just what I have learned about hardware.

    Just my 2 cents....
     
    wizardfromoz likes this.
  16. wizardfromoz

    wizardfromoz Super Moderator
    Staff Member Gold Supporter

    Joined:
    Apr 30, 2017
    Messages:
    2,110
    Likes Received:
    1,930
    I agree.

    @tbtb if you are running Linux under a virtual environment, that can be a different "kettle of fish" to a full install.

    Can you tell us what is the host? Is it Windows 10 or other?

    Wizard
     

Share This Page