WiFi Disabled on Kali Linux 2020.1b

chimpanzeecoder

New Member
Credits
81
I've just installed Kali on my laptop. And to my surprise the wifi is disabled on it. Please help someone it's very urgent. Here's an image of right click on "connections" (if that's what it's called) icon on top. And here's an image of left click on the same icon. There's an checkbox which says "Enable Wi-Fi" but It's not doing anything. This is the output image of "sudo airmon-ng start wlan0".

From the previous command I found out the chipset of my WiFi: Ralink corp. RT3290 Wireless 802.11n 1T/1R PCIe.

Can someone please tell me what's going on here?
 


Tolkem

Well-Known Member
Credits
1,796
I've just installed Kali on my laptop. And to my surprise the wifi is disabled on it. Please help someone it's very urgent. Here's an image of right click on "connections" (if that's what it's called) icon on top. And here's an image of left click on the same icon. There's an checkbox which says "Enable Wi-Fi" but It's not doing anything. This is the output image of "sudo airmon-ng start wlan0".

From the previous command I found out the chipset of my WiFi: Ralink corp. RT3290 Wireless 802.11n 1T/1R PCIe.

Can someone please tell me what's going on here?
Is this a VM? The output from the last image says it is; a KVM virtual machine. In that same image also says the wifi switch is off, did you check that?
 

chimpanzeecoder

New Member
Credits
81
Is this a VM? The output from the last image says it is; a KVM virtual machine. In that same image also says the wifi switch is off, did you check that?
No this is not a VM. Not at all. I installed Kali from a bootable USB. And this is the only OS on my laptop. I don't know why it is saying it's a VM.
Yes I do have a key on my keyboard with "network" symbol. But ever since I installed Kali it remains red. Earlier when I had win10 installed it turns white as soon as my laptop boots. I pressed that key many times but it doesn't affect anything. You can take a look here.
 

Tolkem

Well-Known Member
Credits
1,796
@chimpanzeecoder I had a similar issue with Debian Bullseye, I resolved it by installing the dhcpcd5 package
Code:
sudo apt-get install dhcpcd5
hit enter and wait for it to be installed, once it is run
Code:
sudo dhcpcd
I think it might work since Kali is based on Debian. Can't rememeber if I had to reboot for it to work so you might have to do that.
 

captain-sensible

Well-Known Member
Credits
5,792
There's no such file or directory named "rc.d" in /etc/. But yes there are following directories with these names:
rc0.d
rc1.d
rc2.d
rc3.d
rf4.d
rc5.d
rc6.d
rcS.d
ok just a long shot ; in slackware for instance wifi is not enabled and you have to do it yourself by setting permissions on /etc/rc.d/rc.wireless
 

chimpanzeecoder

New Member
Credits
81
@chimpanzeecoder I had a similar issue with Debian Bullseye, I resolved it by installing the dhcpcd5 package
Code:
sudo apt-get install dhcpcd5
hit enter and wait for it to be installed, once it is run
Code:
sudo dhcpcd
I think it might work since Kali is based on Debian. Can't rememeber if I had to reboot for it to work so you might have to do that.
Hey buddy, I did exactly what you said. And this is the output of "sudo dhcpcd". And yeah, even after going through all your steps, it still shows that my WiFi is disabled.
Is there any way to get my wifi up and running again? I'm frustrated now.
 

Tolkem

Well-Known Member
Credits
1,796
Hey buddy, I did exactly what you said. And this is the output of "sudo dhcpcd". And yeah, even after going through all your steps, it still shows that my WiFi is disabled.
Is there any way to get my wifi up and running again? I'm frustrated now.
Can't see that pic. Why don't you take a screenshot right from the system and attach it here? It's much better than looking at those taken with a phone plus having to access google drive. I think Kali ships with some screenshot tool, look under accesories or, from the terminal run
Code:
scrot -d 5  #the -d 5 means "delay 5 secs" so you can close other windows you don't want to appear on the shot, change that number as per your convenience
which should be available, if it's not, you may install it with
Code:
sudo apt-get install scrot
once installed run that command again, the pic will be saved on your home.
 

chimpanzeecoder

New Member
Credits
81
Can't see that pic. Why don't you take a screenshot right from the system and attach it here? It's much better than looking at those taken with a phone plus having to access google drive. I think Kali ships with some screenshot tool, look under accesories or, from the terminal run
Code:
scrot -d 5  #the -d 5 means "delay 5 secs" so you can close other windows you don't want to appear on the shot, change that number as per your convenience
which should be available, if it's not, you may install it with
Code:
sudo apt-get install scrot
once installed run that command again, the pic will be saved on your home.
Okay sorry for the inconvenience. But unluckily it didn't work. Here's the image:
1588455462506.png
 

darry1966

Active Member
Credits
1,523
I had this stupid behaviour happen in later versions of Devuan especially Devuan Beowulf but not Buster which is the Debian version. So added the rfkill line in /etc/rc.local
 

Tolkem

Well-Known Member
Credits
1,796
Did I miss something? I've entered all the commands accurately. Those steps removed the soft block from my wifi but it is still hard blocked as you can see this picture:
View attachment 6189
Is there any way to remove this hard block? I tried pressing that "Network" button many times but it didn't change anything.
Try this from the kali forum https://forums.kali.org/showthread.php?28657-Wi-FI-Hardware-Disabled a user posted this tutorial claiming it solved the same issue as yours, so it must work.
 

chimpanzeecoder

New Member
Credits
81
Try this from the kali forum https://forums.kali.org/showthread.php?28657-Wi-FI-Hardware-Disabled a user posted this tutorial claiming it solved the same issue as yours, so it must work.
According to the link you sent I should have my wifi up and running by now. I followed every step precisely. It worked for them but not for me.
According to that tutorial, on entering "sudo rfkill list all" the second time, it should have shown that my wifi is successfully hard unblocked. But for some reason it is still showing "hard blocked: Yes"
 

Attachments

Tolkem

Well-Known Member
Credits
1,796
@chimpanzeecoder I just tried Kali from a live usb to see if I could reproduce your issue and find a solution but wifi worked for me OOTB, however, it's not 2020-b1 but 2019-W48-light version since that's the one I have at hand now, so I don't know ... try that one, 2019-W48-light instead of 2020-b1 and see if that way you get your wifi working? You can get it here kali-linux-2019-W48-light-amd64.iso or any of the other images like this one kali-linux-2020-W04-light-amd64.iso from here https://mirrors.huaweicloud.com/kali-images/kali-weekly/ I know it's not an ideal solution but I'm out of ideas here ... sorry. Also, if you installed Kali in order to learn/practice some hacking, you could do that by using any other distro, just install the same packages as in Kali. For instance, you could install Debian via netinst.iso https://www.debian.org/CD/netinst/ which is around 350mb and build your system up to your liking.



You can see at the top right side of the panel that wifi is enabled and working.
 

darry1966

Active Member
Credits
1,523
There a lot of threads. Coming out about Kali wireless not working. Like others have said use something else and add penetration tools. You are not the only one having Kali issues.
 
Last edited:



Top