Unable to run Teamviewer inside a Docker container

johny.faillab

New Member
Credits
0
I ran into a issue when I’m not able to run Teamviewer (GUI) inside a container. Does anyone experienced this issue and have some solution? Or maybe know how to fix it? I was able to use Teamviewer outside of docker container without any issue. Any help is highly appreciated.

I'm using Ubuntu 18.04 | Docker 19.03.8 | Teamviewer 15.4.4445 [DEB]

Dockerfile:
Code:
FROM ubuntu:18.04

RUN apt-get update \
     && apt-get upgrade --yes \
     && apt-get install --yes wget \
     && wget https://download.teamviewer.com/download/linux/teamviewer_amd64.deb \
     && apt install --yes ./teamviewer_amd64.deb
     && rm teamviewer_amd64.deb \
     && apt-get clean \
     && rm -rf /var/cache/* \
     && rm -rf /var/lib/apt/lists/*

CMD ["teamviewer"]
Run Teamviewer:
[email protected]:~$ xhost local:root
non-network local connections being added to access control list
[email protected]:~$ docker run \
> --rm \
> -it \
> --name teamviewer \
> --volume /tmp/.X11-unix:/tmp/.X11-unix \
> --env DISPLAY=:0 \
> teamviewer

Init...
CheckCPU: SSE2 support: yes
Checking setup...
Launching TeamViewer ...
Starting network process (no daemon)
Network process started (44)
Launching TeamViewer GUI
After running it, teamviewer window and icon shows up for a few sec but disappears few sec later with following error:

Aborted (core dumped)
Pic:
The window that shows up is not properly graphically displayed though.

Teamviewer logfile:
Starting teamviewerd…::::::::::::::::::::…
Warning: The postinst maintainerscript of the package teamviewer
Warning: seems to use apt-key (provided by apt) without depending on gnupg or gnupg2.
Warning: This will BREAK in the future and should be fixed by the package maintainer(s).
Note: Check first if apt-key functionality is needed at all - it probably isn’t!
E: gnupg, gnupg2 and gnupg1 do not seem to be installed, but one of them is required for this operation
I tried to install gnupg, gnupg2 and gnupg1 but with no luck.
 


Members online


Latest posts

Top