Unable to delete files on USB hard disk


New Member
I use FreeFileSync in one direction to backup my data files from my Fedora 33 computer onto a USB hard disk.

It has worked well on thousands of files for years. However, a bit ago, FreeFileSync could not update five files on the USB hard disk. They do NOT have unusual characters in their filenames.

When FreeFileSync updates a file, it appears to delete the previous version at the target location, then copies the new version across. It could not do that. I get this message:
Unable to move "/run/media/u/My Passport/FedoraBoxMirror/Documents/quotes.odt" to the recycle bin.
G_IO_ERROR_NOT_FOUND: Unable to trash file /run/media/u/My Passport/FedoraBoxMirror/Documents/quotes.odt: No such file or directory [g_file_trash]

The five target files can be seen on the Fedora 33 Files Manager, they open in LibreOffice, but can not be deleted because supposedly I do not have permission. But, looking at permissions for the files, I do.

So, I tried to use terminal. I changed to root user. I CD'ed to the directory on the USB hard disk, the files come up on "ls", but when I try "rm", the system says there is "No such file or directory".

Does anyone have any ideas how to resolve this?


Last edited:


New Member
Sounds like a good candidate for some corruption of the filesystem. Have you tried running fsck on it?
I tried to run fsck, but it did not work.
It seemed to want an ext2 or ext3 or ext4 file system. But the USB hard disk is a fuse filesystem.

The full text is:
[[email protected] /]$ fsck /run/media/u/'My Passport' -a
fsck from util-linux 2.36.1
fsck.ext2: Is a directory while trying to open /run/media/u/My Passport
/run/media/u/My Passport:
The superblock could not be read or does not describe a valid ext2/ext3/ext4
filesystem. If the device is valid and it really contains an ext2/ext3/ext4
filesystem (and not swap or ufs or something else), then the superblock
is corrupt, and you might try running e2fsck with an alternate superblock:
e2fsck -b 8193 <device>
e2fsck -b 32768 <device>


Well-Known Member


Active Member
It is a USB hard disk, NOT a USB memory stick.
The propeties panel says it is a "fuse" filesystem.
(I am totally unfamiliar with that.)
Both USB hard drive or USB flash drive can be FAT32, NTFS, EXT2/3/4, or other filesystem. It should normally have an ID like /dev/sdc, /dev/sdd, etc. Your internal Linux drive is normally /dev/sda. I'm not familiar with "fuse" either, but @Condobloke's link describes it as a "software interface"... so this may be peculiar to your backup software.

So let's try to go back to basics. If you can, make a bootable Linux USB flash drive. Any Linux should be okay, but most of us are more familiar with Linux Mint or other Debian/Ubuntu based distros.

After booting on a Live Linux USB, try these:

1. su or sudo su to become root. (Live version won't need a password.)

2. fdisk -l (That's lower-case -L) and show us the output.

3. Also lsblk (That's lower-case LSBLK) and show us the output.

4. Don't run fsck again for now. The outputs from #2 and #3 above will tell us more.

[EDIT] If you wonder why a bootable Live Linux USB, it is to be sure that your backup software is not running any background daemon or other process that might interfere with the regular Linux tools and troubleshooting. FUSE interfaces directly with the kernel, and that might cause confusion. Please let us know what Live Linux you decide to use... which distro, version, and desktop. Thanks.
Last edited:


Active Member
According to the Development Status on the FUSE GitHub site, this application lacks active contributors and the maintainer is only putting out fires and not expanding further development.

@aLinuxUser, this might be a good time to consider other backup solutions as you go forward from here. But let's see if we can help you get out of the current jam first.

Another question: Does FreeFileSync provide you any troubleshooting or diagnostic tools?

Members online

Latest posts