Trying to install Linux on a new SSD (Solved)

Nearly 40 minutes and it's got to retrieving file 2 of 7, this could take hours, I've never known an installation to take this long. Something is still not right
 


My wife's desktop pc
What are the specs of this pc? Make and model?
Nearly 40 minutes and it's got to retrieving file 2 of 7, this could take hours, I've never known an installation to take this long. Something is still not right
Maybe need to re-create the live USB?
 
It's a Dell desktop pc about 4 years old the only specs I know are it has 4gb ram, don't know what the processor is but last time I installed Linux mint on it the process only took 20-30 mins in total.
The memory stick I have is quite old, maybe I need to get a new one & put a fresh mint iso on it
 
I've cancelled the installation & I've found a dvd with mint 21.1 on it. I've tried that but it's also taking forever to load, so I'm concluding there must be some sort of compatibility issue between the SSD and the desktop. No idea where to go with this now, I don't have another system I could put the SSD in to test the theory. If I get a usb to sara adaptor and connect it to my laptop is there a way I can do an installation on the SSD in order to see if the drive is incompatible with the desktop
 
Did you make sure that both windows quick-start [fast-boot] and secure boot were both disabled in the bios., if mint runs ok from the "live" session try running inxi -Fnxxz connect to the internet and paste the results back here
 
the process only took 20-30 mins in total
This is still a lot of time, for a distro like Mint. Maybe, try "unchecking" the "download updates" at the install, and update the system once is installed. Please, try and find the exact model dell computer it is as well as the motherboard, that might help narrow the probable cause down.
 
Ok Tolkem & brickwizard, I will follow your advice but I'll have to come back to later or maybe tomorrow, in the meantime thanks for the support
 
I would boot up live linux and use diagnistoc tools available (e.g. SMART) to check ssd health.
Assuming all is fine, as suggested use gpart for partitioning. If partitioning is slow, then the issue is with your ssd. I would not partition whole disk to fat32 or exfat just because this is not necessary, does not provide any information. If you use gpart just partition it as needed. Small msdos partition is needed for uefi.
After partitioning with gpart just install os. If still slow the issue may be your net connection.
 
You shouldn't have any trouble installing Mint Cinnamon on a new SSD...you never need to format it either as there's nothing on it to format.
m1213.gif


The Mint installer formats the SSD and installs Mint for you and takes about 15 to 20 mins...depending on how fast your computer is...I always install to the whole Drive and don't create extra partitions.

I can't think why you're having this trouble...I have 3 500GB SSDs...one in my Laptop...two in my Tower...All have Mint Cinnamon 21.1 on them. Two had a clean install and the other is a Clone.
m100.gif


Have you tried a different Flash Drive or another SSD...is secure boot and fast boot turned off...have you tried downloading the Mint ISO from a different link...https://www.linuxmint.com/edition.php?id=311 and check the ISO...
https://linuxmint-installation-guide.readthedocs.io/en/latest/verify.html
Hope this helps.
m1212.gif
 
I'm back on the case but nothing has changed. Fast boot is off, I can't find any reference to secure boot in the bios, I've been out and bought a brand new flash drive then I've downloaded mint 21.3 from a different mirror. The live mint loaded without trouble, I clicked on the install mint and it took twenty minutes before the installation screen appeared, I selected my keyboard layout (English UK) and again I'm just watching a spinning logo ( ten mins so far and counting) to make thing worse I tried it on my laptop, I was going to do a fresh install on the laptop anyway but I had exactly the same problem . I gave up on that but found the laptop now won't boot at all. The laptop did have secure boot off and it was set to uefi so I tried changing it to legacy and then both, nothing helped. Back to the desktop it does say it's now copying files, I will see how long that runs for and post back
 
You should not be having this problem with a Dell. Secure boot [if you have it] should be in the security settings, win quick-start should be in the power settings [UEFI machines only]

before installing again try a BIOS Purge
 
Thanks for the reply, unfortunately I don't know how to do a bios purge, can you help me with that please. As far as the laptop is concerned I set it back from legacy to UEFI again and it's booted up ok.
The desktop installation is still running and is showing retrieving files 2 of 7 but it got to that stage 15 mins ago, so although it appears to be installing, it is very very slow, I don't want to stop it yet as it's been running so long. If it fails I will stop it and try the bios purge thing (I'll look that up and see if I can workout what to do while I'm waiting. Thanks again.
 
see the other thread
 
Well I started the installation on the desktop at about 3pm UK time, it's now 7pm and it still hasn't finished & I started an install on my laptop around 5pm & thats still running. I installed mint 21.1 on my laptop a few months back and it took about 40 minutes, nothing has changed in the bios so what is going on here, it really makes no sense.
 
IT'S DONE!
At last I found the answer, I booted into the live Linux and using gparted I deleted all partitions and formatted the whole drive as ext4 then I disabled WiFi and ran the installer, this time it took about 25 mins.
Thank you so much to everyone who assisted me, you wouldn't get that help in Windows.
I'm really appreciative to you all for your time and patience
 
I deleted all partitions and formatted the whole drive as ext4
In one of your screenshots I did notice you formated to exfat, but thought you'd let the installer format to ext4, which is the default for most distros, so I guess you didn't, and instead chose not to format and use the exfat, which wouldn't work. For future reference, just let the installer do its job; format and install the system. Anyway, glad you sorted it out. Remember to mark the thread as solved. :)
 
Ok maybe I got carried away, the system has indeed install but there's a problem. as usual the update manager suggested I change to a local mirror, no surprise but every single mirror I've tried to use fails to update the cache and I get the message attached
 

Attachments

  • synaptic.jpg
    synaptic.jpg
    1.3 MB · Views: 67

Members online


Top