• We had to restore from a backup today after a failed software update. Backup was from 0000 EDT and restored it at 0800 EDT so we lost about 8hrs. Today is 07/20/2024. More info here.

Trying to install a Linux Distro on a Chromebook

All right so it appears it was the right choice because now when I run the crossystem command to boot from USB, it didn't just sit there and wait for me to sudo reboot it. It gave me a long list of other commands, of which I had not seen before until now. I still proceeded to reboot as is, tried CTRL+L, got beeped at so that was no where.

Logged in as Guest, ran a browser tab, got into the terminal, then shell then ran the command there. No go.

Did this again in Developer Mode through the boot screen and same idea.

Okay, currently at this rate, nothing is doing it.

Developer Mode
Tried to Boot USB
Didn't matter if I was guest or whatever. Didn't matter if I got into Dev Mode through boot or into Guest through browser.

Same results.

Went back, thinking it's the flash stick, got rid of Bunsenlabs, went with Bodhi, formatted the flash stick. Tried again hoping to see a single shred of a live boot screen from the flash drive.


I'm very close to giving up here.
Step back and try again tomorrow...;)
G'day @pyrinder and welcome to linux.org from DownUnder :)

The timeframe may not be appropriate, but I have just read this


which led me to here https://blog.fyralabs.com/ultramarine-40-release/

where they are releasing a Chromebook edition in a couple of weeks.

Of the three desktops available, I will be downloading and installing the XFCE one in the next two days.

If you indicate a Fedora-like alternative is not a deal-breaker, I can come back and let you know what the memory consumption is like.


Chris Turner
Try this:
Install Fossapup on a USB
Boot it (with Ctrl + L)
Install Fossapup on the hard drive
Power off the laptop
Take off the USB
Reboot (with Ctrl + L)

You have to Install Grub for DOS (in the menu), before reboot.
Hello, giving a bit of an update since it's been awhile.

I've conceded defeat. This Chromebook is resilient to my efforts to turn it around as a Linux laptop. Sad to come to this reality but it is what it is and I really should've known better when it comes to Chromebooks.

On the flip side, recently while thrifting, I've picked up a Toshiba Satellite C6550 that's dated in the late 2000s (since it has the Windows 7 badge) for $15. This is going to be the successor of the failed Chromebook attempt and immediately I gave this laptop Lubuntu because it was running bad on the Windows 7 OS that someone configured on it. All that this laptop needs is maybe a new battery or charger and Memtest reported over 400 errors on one of the memory sticks so I'll have to replace one of or both of them.

This Chromebook has 2 more years left in it before Google decides to disown it from updates so I guess in the meantime until I get the replacement parts, it'll just have to be as it is.

Thanks so much for all of the help.

Members online