Trackpad driver issue?

fx9

Member
Joined
Apr 5, 2021
Messages
92
Reaction score
57
Credits
1,098
Good day!


I am having trackpad issues. I can move the arrow around, but I have no scroll or click options.

I am on a dell XPS plus that is only a few months old. I can often fix it by restarting cinnamon with the alt/F2 r command. This morning it was persistent and I couldn't correct with restarting the computer and after about 10 minutes after starting it resolved itself. I was using the touchscreen. I tried a usb mouse and had the same issue, arrow moves, but no click or scroll.


System:
Kernel: 6.2.0-39-generic x86_64 bits: 64 compiler: N/A Desktop: Cinnamon 5.8.4 tk: GTK 3.24.33
wm: muffin dm: LightDM Distro: Linux Mint 21.2 Victoria base: Ubuntu 22.04 jammy
Machine:
Type: Laptop System: Dell product: XPS 9320

Any help is greatly appreciated.
 


So it's not a driver issue. When I wake my computer up the pad won't have click or scroll, but I can't minimize my browser or open the 'start' menu with touch screen, either.

Then my pad clicks as something wakes up and I have full function again. Any ideas?

Everything is up to date.
 
Try changing Kernel

It would be wise to take a Timeshift snapshot before doing that
 
I updated to the latest kernel last night. I woke it up this morning and it hung for about 5 seconds, but that was the only time so far so hopefully it helps.

I love Linux, but I get lost easily with these issues. It is great that it is easy enough for the average user to change over these days, but sadly I have to come running to those with more knowledge than myself any time I have a hiccup.

Is this something I might be able to fix using another distro?
 
It will be of interest to see what, if anything, happens when you reboot or restart.

let us know.

Coming running to us when you strike an issue is perfectly normal. WE have no problem at all with that.

Which distro are you using right now?......does it suit your needs?...Still booting ok?

if it is booting ok and working as it should, and you like using it, I would stay there
 
Is this something I might be able to fix using another distro?

I run 84 distros and they all have an issue or three.

But I only keep onboard distros I like and that have some intrinsic value to them, so that means there are plenty of viable distros, I would think.

Cheers

Wizard
 
I did a restart after I installed the new kernel. I only had one short glitch yesterday which is how it has always been. Today was almost 30 minutes.

I had a zoom call. I had no mouse click, but I was able to open zoom with the touchscreen. I was able to type in the chat and my audio was working, but no video. I am using Mint which suits my needs. I was just wondering if it could be a compatibility issue with my hardware and the distro.

My last issue was a failing keyboard which was typing adsf over and over and freezing up the system. I replaced it and everything is fine. I thought it was software or a virus. Is this possibly a hardware failure? seems more software related, especially because I can't open the LM menu when things are frozen. When everything comes on I can hear the trackpad click and then everything is fine.

I did get normal function back, but I still wasn't able to turn my cam on. Gonna restart and see what I get.
 
I had to revert back to the old kernel and that go my camera back up and running. Still lost on what is hanging and causing the click issue, though.
 
Anything you would advise to start troubleshooting? Disk scan to see if there is a harware issue. Verifying install to see if something might be corrupt?
 
This is a generous and helpful community, it leads me to wonder... Does the lack of responses imply that these are just Linux quirks that I need to learn to get used to?
 
Linux quirk.....possibly Yes.

I do not use a laptop. therefore no experience with trackpads.

However, it is possible that with a bit of skylarking around you may just come across the solution.

What i mean is;

A deep search for "trackpad problem with Dell XPS 9320"

I would investigate that in depth...inother words, after you have exhausted the first page of answers, click through to the second page etc

If this is a known problem with that particular dell, it should be able to be found somewhere

WHat year model is that laptop ??....if it is a fairly recent model, there may not have been an inclusion in the kernel yet to absorb that particular chip

I would definitely approach Dell. If anyone will know that info it will be them. They will keep a knowledge base, which will have every possible problem in it

You can be assured that if any one here had that same problem, they would have spoken up by now.


The page I have linked was the first in the search i suggested above.

Read it carefully...it is a 'highly active topic'

There is an answer there, I have taken a screenshot of and pasted below.

1704949990274.png


Just a hint here....a great number of members here will have assumed that you have already carried out an extensive search.
 
this page may take care of that problem....maybe....note the release date of 4th January, 2024


MAKE SURE, you follow this :
This is a comprehensive list of all available downloads for your XPS 13 Plus 9320
Some downloads may already exist on your device. Select “This Device” to view and manually install available downloads specific to your device’s unique identifier. (Show me how).
 
iu



OK, so that was a big smack in the face... I assumed that I was completely voiding warranty dumping windows for Linux, and any official support was out the window. This is the main reason I was looking for a preloaded linux machine in another post.

I always search before I come for help, but I search for why it's not working with linux, not thinking Dell would have a solution....

So, I followed your first reply and wound up at the drivers page you shared after. I found a Jan 4 2024 release for Ubuntu® Desktop 7.04 and Ubuntu 22.04 LTS which is what I would need for Mint. Yes?

And this is where I have gotten lost a few times. I find a downloadable fix, but can't figure out how to install it.

I don't want to ramble on, but I am more confused than when I started searching for how to complete the install. I found an easy to follow video for windows, but not linux. Any articles have jsut steered me further from where I was going. I would be very grateful if you could nudge me onto the next step of the lesson.
 
Last edited:
G'day.

Mint ships with a small utility program known as Gdebi.
22.04 LTS which is what I would need for Mint. Yes?

Likely.

If the downloaded file ends in .deb , you can navigate to it in your File Manager, right click the file and choose to install using Gdebi.

See how that goes.

Wizard
 
  • Like
Reactions: fx9
Ubuntu 22.04 LTS which is what I would need for Mint. Yes?
Yes.

Screenshots
2024-01-12_16-44.png


The one selected in category is for mouse, keyboard and input devices
2024-01-12_16-47.png

Click on download.....and save to somewhere you can find it easily.

@wizardfromoz will be along shortly to tell you how to install that .zip download
 

Attachments

  • 2024-01-12_16-44.png
    2024-01-12_16-44.png
    214.7 KB · Views: 71
  • 2024-01-12_16-47.png
    2024-01-12_16-47.png
    82.5 KB · Views: 74
@wizardfromoz will be along shortly to tell you how to install that .zip download

Maybe yes, maybe no.

The bit that says "Show Me How" appears to be there for the entry of a code unique to the OP's computer.

I can't do other, at this point than suggest that the OP download the zip to their Downloads folder, then right-click to to extract and see what files it comes up with.

Wiz
 
I will wait for feedback from fx9
 
Sorry I meant to include that last night. The Appimage is why I got stuck.

Extracted file name.

update-ath8124_tributo-82023-12-13-946-RDP2-E1.AppImage
 
Right click on that app-image, and select properties.

Then click on Permissions, and dwn the bottom put a tick in the box to 'Allow executing file as a program

click on close, and then double click the file....it should install

It may ask for a reboot after installing.
 
Last edited:
I am doing my best to figure it out on my own and I found instruction to do that this morning, but it is unresponsive when I click on it after allow it to execute.
 


Top