• We had to restore from a backup today after a failed software update. Backup was from 0000 EDT and restored it at 0800 EDT so we lost about 8hrs. Today is 07/20/2024. More info here.

Terminal not responding

There’s another possibility here.
If the OP pressed ctrl+s at any point whilst the terminal was open and in-focus, the terminal will stop responding to input from the keyboard and will stop showing output from any programs that might be running in that terminal. Any program output, or key-presses are buffered until the terminal resumes again.

To get it to resume, you can simply press ctrl+q and then it will process all keyboard events that happened whilst the terminal was stopped, or will resume displaying output from running commands.

The reason for these stop/start shortcuts is mostly historic. Back in the day, most terminals didn’t have any kind of scroll-back, or paging mechanisms. So if a program produced a lot of output to the screen, the user could hit ctrl+s to stop the terminal, in order to read the output, before resuming it again, to let the program continue.

It’s easy to accidentally stop the terminal with ctrl+s. The most common scenario is that you go to press ctrl+d to exit the terminal, but accidentally hit ctrl+s and end up stopping the terminal.

Another, less common scenario is when you have multiple windows open. It’s easy to forget which application is in focus sometimes. So if you’ve got multiple windows open and you’re constantly switching back and forth and one of them is a terminal. You might decide to press ctrl+s to quickly save a document in one of the other application windows. But if you forgot to switch to that other application first and your terminal window currently has focus, you’ll end up stopping the terminal.
This has only happened to me literally once or twice in all the years I’ve been using Linux!

In any case, pressing ctrl+q will resume the terminal.

So if the terminal appears to freeze and doesn’t respond to keyboard events, my first port of call is ctrl+q, in case a ctrl+s was accidentally sent to the terminal!
 
Last edited:


It seems that I can't reset or anything in gnome-terminal, I found Xterm on my system and opened it and it works as you would expect. I would still like to fine a reason for the problem with gnome-terminal. I did remove and reinstall terminal to no avail.
 
I do not have a menu button in my terminal window tried to go to view but cannot find it.
 
There’s another possibility here.
If the OP pressed ctrl+s at any point whilst the terminal was open and in-focus, the terminal will stop responding to input from the keyboard and will stop showing output from any programs that might be running in that terminal. Any program output, or key-presses are buffered until the terminal resumes again.

To get it to resume, you can simply press ctrl+q and then it will process all keyboard events that happened whilst the terminal was stopped, or will resume displaying output from running commands.

The reason for these stop/start shortcuts is mostly historic. Back in the day, most terminals didn’t have any kind of scroll-back, or paging mechanisms. So if a program produced a lot of output to the screen, the user could hit ctrl+s to stop the terminal, in order to read the output, before resuming it again, to let the program continue.

It’s easy to accidentally stop the terminal with ctrl+s. The most common scenario is that you go to press ctrl+d to exit the terminal, but accidentally hit ctrl+s and end up stopping the terminal.

Another, less common scenario is when you have multiple windows open. It’s easy to forget which application is in focus sometimes. So if you’ve got multiple windows open and you’re constantly switching back and forth and one of them is a terminal. You might decide to press ctrl+s to quickly save a document in one of the other application windows. But if you forgot to switch to that other application first and your terminal window currently has focus, you’ll end up stopping the terminal.
This has only happened to me literally once or twice in all the years I’ve been using Linux!

In any case, pressing ctrl+q will resume the terminal.

So if the terminal appears to freeze and doesn’t respond to keyboard events, my first port of call is ctrl+q, in case a ctrl+s was accidentally sent to the terminal!
Tried control+Q but did not work, thanks for response
 
clear usually works for me. Even if I can't always see what I'm typing, or it's all garbled up with binary/ascii characters.

But if it doesn't, I use two other methods.
If you're using a GUI, and you know the name of your console/terminal program.. do this...
Open up another console...
ps -ef | grep xterm (or whatever console you're using)
kill (pid)
Usually the first login will almost always have a lower PID than the second window.

If you're not using a GUI.
Hold down the alt key and press F2, or F3, or anything up to F7.
This will open another login screen. Then repeat the steps above, with a slight difference.
ps -ef | grep tty (usually agetty or something like that).
kill (pid) again, use the lower numbered one for the first locked up login screen.
I started XTerm and it works as expected so I have a working terminal but still would like to find problem with gnome-terminal
 
What a conundrum.

In this order please David

1. Open Terminal and type in clear ....then hit enter

Any result ?

2. ""I did remove and reinstall terminal to no avail."".....how did you remove Terminal?....via the software manager?....Please do so again.....but this time remove it via Synaptic Package Manager.
(click on menu...type in synaptic package manager....hit enter......password......there is a search box in the top right hand corner....type in 'gnome terminal'.....hit enter....it will show with green coloured squares at the start of the names...one for the terminal itself and one for its data.....hold down the ctrl key and select both of them.....then right click and select 'Mark for Complete Removal'......if it asks for additional required changes....select 'mark' or yes or ok.....and then proceed...allow it to do its thing.
When that finishes......go to Software Manager and reinstall Gnome Terminal.
 
I did remove and reinstall terminal to no avail.
You may report this to Linux Mint developers. I saw this same problem on various forums without any solution. It could be a bug. First, you may want to try Condobloke's solution.
 
What a conundrum.

In this order please David

1. Open Terminal and type in clear ....then hit enter

Any result ?

2. ""I did remove and reinstall terminal to no avail."".....how did you remove Terminal?....via the software manager?....Please do so again.....but this time remove it via Synaptic Package Manager.
(click on menu...type in synaptic package manager....hit enter......password......there is a search box in the top right hand corner....type in 'gnome terminal'.....hit enter....it will show with green coloured squares at the start of the names...one for the terminal itself and one for its data.....hold down the ctrl key and select both of them.....then right click and select 'Mark for Complete Removal'......if it asks for additional required changes....select 'mark' or yes or ok.....and then proceed...allow it to do its thing.
When that finishes......go to Software Manager and reinstall Gnome Terminal.
Clear did not work, followed your instructions in order ran to another problem which I took a screenshot of, also I found my thumb drive with the snapshots on it only problem is the last one was in August, I also have one I just took during all these problems, do you want me to attach the files?
 

Attachments

  • Screenshot from 2022-11-19 15-52-38.png
    Screenshot from 2022-11-19 15-52-38.png
    13.2 KB · Views: 181
Open Synaptic package manager again....click on Edit....then down the list to Fix Broken Packages... Click on that, just once.



You should see "Successfully fixed delendency problems"....down in the bottom left hand corner of the synaptic window.



Then close and reopen synaptic and try again.
.
 
With all the advice given and nothing seems to work...it might be time for a Re-Install.
m1516.gif
 
It seems that I can't reset or anything in gnome-terminal, I found Xterm on my system and opened it and it works as you would expect. I would still like to fine a reason for the problem with gnome-terminal. I did remove and reinstall terminal to no avail.
Ah, I see. So the problem here is only with Gnome-terminal?! In that case, if Xterm works properly, the problem definitely isn’t with bash, or whatever other shell you might be using. It sounds like a definite bug in Gnome terminal.

Personally, I can’t stand Gnome3. I avoid it like the plague!

Best bet is to report the bug to the Mint developers, JIC it’s something that they’ve introduced. If so, they’ll fix it. If not, they’ll probably report the bug upstream to the Gnome developers.

In the meantime, if you want something more reliable:
Xterm, Terminator and Terminology are great terminal emulators.
Xterm is ancient, it’s been around forever. So it has a stable, mature and well tested codebase. Xterm just works!

Terminator has some great modern features, including the ability to add tabs (a common feature in terminals nowadays) plus the ability to split the current window/tab horizontally and vertically, into extra instances of bash.

Terminology has all of that, plus some neat, additional built-ins that allow you to view images and videos in the terminal, play music files, and list directories with thumbnail images next to their filenames. You can also set images, or videos as the background for the terminal - complete with sound!

Years ago, I used to regularly switch between those three terminal emu’s.

Nowadays, on my Debian installation, I’m running suckless.org’s dwm - a minimalist tiling wm, instead of Gnome 3. And I’m using suckless.org’s st terminal as my default terminal. St is extremely minimalist and bare bones. It literally just opens a window and runs your default shell (bash, ash, dash, ksh, zsh, fish etc etc..)
In order to have basic features like scroll-back functionality, or more advanced things like tabs and splits, I run tmux (a terminal multiplexer, similar to screen).

It might not be for everybody, but it works for me, ha ha!
 
Ah, I see. So the problem here is only with Gnome-terminal?! In that case, if Xterm works properly, the problem definitely isn’t with bash, or whatever other shell you might be using. It sounds like a definite bug in Gnome terminal.

Personally, I can’t stand Gnome3. I avoid it like the plague!

Best bet is to report the bug to the Mint developers, JIC it’s something that they’ve introduced. If so, they’ll fix it. If not, they’ll probably report the bug upstream to the Gnome developers.

In the meantime, if you want something more reliable:
Xterm, Terminator and Terminology are great terminal emulators.
Xterm is ancient, it’s been around forever. So it has a stable, mature and well tested codebase. Xterm just works!

Terminator has some great modern features, including the ability to add tabs (a common feature in terminals nowadays) plus the ability to split the current window/tab horizontally and vertically, into extra instances of bash.

Terminology has all of that, plus some neat, additional built-ins that allow you to view images and videos in the terminal, play music files, and list directories with thumbnail images next to their filenames. You can also set images, or videos as the background for the terminal - complete with sound!

Years ago, I used to regularly switch between those three terminal emu’s.

Nowadays, on my Debian installation, I’m running suckless.org’s dwm - a minimalist tiling wm, instead of Gnome 3. And I’m using suckless.org’s st terminal as my default terminal. St is extremely minimalist and bare bones. It literally just opens a window and runs your default shell (bash, ash, dash, ksh, zsh, fish etc etc..)
In order to have basic features like scroll-back functionality, or more advanced things like tabs and splits, I run tmux (a terminal multiplexer, similar to screen).

It might not be for everybody, but it works for me, ha ha!
Thank you for your info, I have been using xterm with no issues I am a novice and moving slowly :
 
I did remove and reinstall terminal to no avail.
A wild guess since nothing else is working: Did you use apt remove or apt purge to remove gnome-terminal? The difference is that purge is supposed to also remove configuration files... except those that might be in your home folder (very old source).

So, try sudo apt purge gnome-terminal... then afterwards also delete any gnome-terminal file or folder in your home folder. Be sure to look in the hidden .config folder in your home... if it has a sub-folder for gnome-terminal, delete that too.

Then reinstall and see how you go.
 
Check your locale file and language settings is set to English - to check your locale file open the terminal and put in
Code:
localectl status
and make sure your system language is set to match your locale - you should see some like this
Code:
@expirion:~$ localectl status
   System Locale: LANG=en_US.UTF-8
       VC Keymap: n/a
      X11 Layout: us
       X11 Model: pc105
     X11 Options: terminate:ctrl_alt_bksp

If the locale and language are different then terminal no worky
 

Members online


Top