[Solved] Running .Appimage files

foremano17

New Member
Joined
Mar 27, 2021
Messages
5
Reaction score
0
Credits
38
Hi,

I've recently downloaded Linux for the first time on my Chromebook and i'm trying to install unity hub. The problem is the downloaded file is in the .AppImage format which i can't run. I did some research and found out you have to make it executable with the command "chmod +x UnityHub.AppImage" then run the file with "./UnityHub.AppImage" but when i do this i get nothing.

I've attached a ss of the terminal after trying this.
 

Attachments

  • Screenshot 2021-03-27 08.40.13.png
    Screenshot 2021-03-27 08.40.13.png
    11.4 KB · Views: 263


Condobloke

Well-Known Member
Joined
Apr 30, 2017
Messages
4,412
Reaction score
3,881
Credits
24,549
G'day foreman017, Welcome to Linux.org

I am a little out of my depth here....however.....wherever the file downloaded to, right click on the file and select properties.
Then select Permissions.......a little way down that window it will hopefully have an option to "Allow executing file as a Program"....put a tick in the box.

Let me know how you get on
 

MatsuShimizu

Well-Known Member
Joined
Jan 14, 2021
Messages
404
Reaction score
581
Credits
8,793
If you are using Ubuntu 20, right-click the appimage file >> properties >> permissions and check ‘Allow executing file as program”.
After that, double-click the file to run.

 
OP
F

foremano17

New Member
Joined
Mar 27, 2021
Messages
5
Reaction score
0
Credits
38
G'day foreman017, Welcome to Linux.org

I am a little out of my depth here....however.....wherever the file downloaded to, right click on the file and select properties.
Then select Permissions.......a little way down that window it will hopefully have an option to "Allow executing file as a Program"....put a tick in the box.

Let me know how you get on

hi, thanks for the reply but when i right click the file i don't get that option. I'll attach what i do get.
 

Attachments

  • Screenshot 2021-03-27 09.42.41.png
    Screenshot 2021-03-27 09.42.41.png
    13 KB · Views: 197
OP
F

foremano17

New Member
Joined
Mar 27, 2021
Messages
5
Reaction score
0
Credits
38
If you are using Ubuntu 20, right-click the appimage file >> properties >> permissions and check ‘Allow executing file as program”.
After that, double-click the file to run.


Thanks for the reply, please see my response to Condobloke's suggestion.
 

Condobloke

Well-Known Member
Joined
Apr 30, 2017
Messages
4,412
Reaction score
3,881
Credits
24,549
Which OS are you using ?

linux mint, ubuntu...??
 

MatsuShimizu

Well-Known Member
Joined
Jan 14, 2021
Messages
404
Reaction score
581
Credits
8,793
OP
F

foremano17

New Member
Joined
Mar 27, 2021
Messages
5
Reaction score
0
Credits
38
I never try that OS, but found this on Google.
https://www.reddit.com/r/Crostini/comments/bpiizj

Thanks, i used some info in that post and now when i try to run i get this message.

Edit: I have it working now, thanks to everyone who helped. for anyone having the same problem i used the package mc (sudo apt install mc) to edit file permissions on the appimage, enabling read/write and execute privileges.
 

Attachments

  • Screenshot 2021-03-27 13.37.26.png
    Screenshot 2021-03-27 13.37.26.png
    18.6 KB · Views: 244
$100 Digital Ocean Credit
Get a free VM to test out Linux!

Members online


Latest posts

Top