• Rob's side project: I recently started Gun-Forums.com and we currently have a $100 raffle - if you're into guns, join up and enter the raffle to win $100.00. Gun Forums

[SOLVED] Peppermint on Toshiba nb500 - no audio

chespa

New Member
Hello to everybody,
I installed Peppermint on a Toshiba nb500-12w, but I have a problem with the audio, which doesn't work.
I found that by starting "alsamixer" from the terminal and then pressing F6 to select my sound card HD Intel, which is NOT the default card, the "Headphone" item is silent and with the volume at 0.
If I move on this item with the cursors and press "M" and then with the cursor "up" I turn up the volume I can hear the audio.
If I did not explain well I filmed the procedure, viewable in the link at the bottom of the post.
The problem is that after every boot I have to do the whole procedure again.
Is there any way to make sure that "Headphone" is not muted and the volume is 0 at startup?

 
Last edited:


chespa

New Member
SOLVED!!!
1) open terminal and type
Code:
sudo alsamixer
set your values and press ESC
2) type
Code:
sudo alsactl --file ~/.config/asound.state store
3) type
Code:
sudo alsactl --file ~/.config/asound.state restore
4) create the file
Code:
sudo nano ~/.config/autostart/alsarestore.desktop
and compile it so:
Code:
[Desktop Entry]
Type=Application
Terminal=false
Name=alsarestore
Exec=bash -c 'sleep 15 ; alsactl --file ~/.config/asound.state restore'
5) delete /var/lib/alsa/asound.state by:
Code:
cd /var/lib/alsa
Code:
sudo rm asound.state
6) reload alsa
Code:
sudo alsactl restore
 


Members online


Top